Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
#226228 05/04/2009 11:00 AM
Joined: Oct 2006
Posts: 67
journeyman
OP Offline
journeyman
Joined: Oct 2006
Posts: 67
Hej

Some of my users complaining that they cant login with IE 8. Im using firefox, and dont have that problem, but some of my users using public computers at universities and cant download other browsers. Is there a problem with IE 8 and UBB?


trosfrihed.dk
Custom Ubb 7.5.2
Joined: Jun 2006
Posts: 3,837
Ian Offline
Carpal Tunnel
Offline
Carpal Tunnel
Joined: Jun 2006
Posts: 3,837
Just tested with IE8 and all fine here.....

Ian #226232 05/04/2009 12:01 PM
Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
I have not used IE8 yet. But I believe there is some type of compatibility setting now. Something to do with how it handles html tags.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Feb 2007
Posts: 1,287
Likes: 1
Veteran
Offline
Veteran
Joined: Feb 2007
Posts: 1,287
Likes: 1
Isn't IE8 still in beta?

Why would you want to test a companies software that has had a very well know past for bugs, security holes, and compatible problems?


Joined: Jun 2006
Posts: 15,973
Likes: 38
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,973
Likes: 38
I'm pretty sure IE8 is out of beta especially wince Windows Vista installed it for me automatically lol...


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Feb 2007
Posts: 1,287
Likes: 1
Veteran
Offline
Veteran
Joined: Feb 2007
Posts: 1,287
Likes: 1
Well, knowing that Vista is crap I'm pretty sure IE8 is crap too, lol.

Joined: Oct 2006
Posts: 67
journeyman
OP Offline
journeyman
Joined: Oct 2006
Posts: 67
Hej
Thanks for your replies. I have istalled IE8 trying investigate login problems. There seems to be a problem with the board url and IE cookies. I had setup my board to force url with 'http://www.domain.com' but even when UBB force the url with 'www' I cant login when typing 'domain.com' in the browser line.

To login, I have to restart the browser and write 'www.domain.com' in browserline and then click on the login-link. So I guess there must be a problem with the way IE8 handle cookies.

IE8 sucks frown , and i have uninstalled it.

But I wants to give mr. Gates a little credit: If you have upgraded from IE7 to IE8, then its possible to get back to IE7 by uninstalling IE8 through control panel on windows Pc's


trosfrihed.dk
Custom Ubb 7.5.2
Joined: Nov 2006
Posts: 40
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
Originally Posted by JAISP
knowing that Vista is crap
Not that I entirely agree with you there, JAISP wink but from today you can download the release candidate for Windows 7 from Microsoft and run it on a "free" license until June 2010. Worth a look, eh?
Originally Posted by JAISP
Isn't IE8 still in beta?
IE8 went on general release 19th March, 2009. It wasn't included in all Windows Updates, but rolled out in Vista updates.
Originally Posted by arentzen
IE8 sucks
Hmm.... weeuuurlll, that aside (!!), are you using an htaccess redirect for your www.domain/domain issue? It might resolve the problem.

Joined: Oct 2006
Posts: 67
journeyman
OP Offline
journeyman
Joined: Oct 2006
Posts: 67
Originally Posted by Neil White
Originally Posted by JAISP
knowing that Vista is crap
Not that I entirely agree with you there, JAISP wink but from today you can download the release candidate for Windows 7 from Microsoft and run it on a "free" license until June 2010. Worth a look, eh?
Originally Posted by JAISP
Isn't IE8 still in beta?
IE8 went on general release 19th March, 2009. It wasn't included in all Windows Updates, but rolled out in Vista updates.
Originally Posted by arentzen
IE8 sucks
Hmm.... weeuuurlll, that aside (!!), are you using an htaccess redirect for your www.domain/domain issue? It might resolve the problem.

Yes, I have tried htaccess. It redirects, but it still wont let IE8 users login. The only way I can make it work is enable 'Allow multi-url access' in control panel.


trosfrihed.dk
Custom Ubb 7.5.2
Joined: Feb 2007
Posts: 1,287
Likes: 1
Veteran
Offline
Veteran
Joined: Feb 2007
Posts: 1,287
Likes: 1
Originally Posted by arentzen
But I wants to give mr. Gates a little credit: If you have upgraded from IE7 to IE8, then its possible to get back to IE7 by uninstalling IE8 through control panel on windows Pc's

Apparently Microsoft knows that their browser sucks if they will let you go back. In past versions they did not let you roll back versions.

Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
Interesting, what is your setting just below allow multi URL in the control panel.
Domains for HTTP Referer Check
and
Disable HTTP Referer Check?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 15,973
Likes: 38
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,973
Likes: 38
Actually, I rolled back from IE7 to IE6 the same way; they're simply letting you KNOW you can do it now tongue...


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
Well I finally got around to installing IE8 on a xp3 machine.
I don't see a issue on at least three sites.
Including registering on your site. Possibly it is the referrer check that really is a issue.
As well as what internet security software is used???


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Ruben #226287 05/07/2009 12:46 AM
Joined: Dec 2003
Posts: 1,796
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,796
I have occasional log in issues and users that report them too :/


- Allen
- ThreadsDev | PraiseCafe
Joined: Oct 2006
Posts: 67
journeyman
OP Offline
journeyman
Joined: Oct 2006
Posts: 67
Hej
I have disabled 'allow multi url, and enabled 'disable http referer check'.

Yesterday i had login problems onto Ubbdev too, with IE8


trosfrihed.dk
Custom Ubb 7.5.2
Joined: Oct 2006
Posts: 67
journeyman
OP Offline
journeyman
Joined: Oct 2006
Posts: 67
Originally Posted by Ruben
Well I finally got around to installing IE8 on a xp3 machine.
I don't see a issue on at least three sites.
Including registering on your site. Possibly it is the referrer check that really is a issue.
As well as what internet security software is used???

Im not using firewall at all, and I dont think it's the problem. If I enter my site typing 'trosfrihed.dk' in the browser line, then im being correctly redirected to http://www.trosfrihed.dk, but im not getting logged in. If i close browserwindow, then open a new browserwindow and typing www.trosfrihed.dk in the browserline, then its possible to log in.

I did try to set my domain with and without 'www' in 'http referer check' and enabled 'http referer check' but it didnt changed anything frown


trosfrihed.dk
Custom Ubb 7.5.2
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
It sounds like IE8 doesn't want to set a cookie on the redirect. We had to put a special clause in for that just for IE7 and prior and sounds like maybe they've changed something again.

I need to find a guinea pig computer to install IE8 on so I can test with it.

Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
okay here is what I tried using the example URls provided.
Which I did not try before. I had tested it using the URL in his signature
Both IE7 and IE8 has the same problem not able to login using trosfrihed.dk

Just for extra info IE7 is installed on a vista box and IE8 is on a xp box.
I tried this same method on my own site without the initial www or http and was successful.

Could it just be the way the particular site is handling the redirect on the URL?


Last edited by Ruben; 05/07/2009 1:37 PM. Reason: Added comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Nov 2006
Posts: 47
journeyman
Offline
journeyman
Joined: Nov 2006
Posts: 47
I am having a rash of these once again myself. getting 1 or 2 complaints a day. I am running with referrer check disabled.


Mike




Mike Wilson
Bowl-Tech Inc.
http://www.bowltech.com
Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
try enabling multi-url access like arentzen did.
See if the problem goes away.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Oct 2006
Posts: 67
journeyman
OP Offline
journeyman
Joined: Oct 2006
Posts: 67
I did worked out a temporary solution to login problems with IE7 and IE8:

Make a htaccess file and let it direct to http://www.domain.com/forums/ubbthreads.php if the url not containing 'www.domain.com'

Code
rewriteengine on
rewritecond %{http_host} !^www\.domain\.com$ 
rewriterule ^(.*)$ http://www.domain.com/forums/ubbthreads.php [r=301]


trosfrihed.dk
Custom Ubb 7.5.2
Joined: Dec 2003
Posts: 1,796
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,796
Thank you smile

It would be nice if this can be fixed for 7.5.3 - might be a while before we have something new and logging in is kind of important smile


- Allen
- ThreadsDev | PraiseCafe
Joined: Nov 2006
Posts: 47
journeyman
Offline
journeyman
Joined: Nov 2006
Posts: 47
As Ruben suggested earlier, multi URL is checked. Still having problems. Just helped a guy tonight with it (I hope).
I do not know what the answer is or if there is one, dealing with IE can really be a hair ripper. smile

Thanks for listening and I hope a closer look can be taken. smile

Sincerely
Mike



Mike Wilson
Bowl-Tech Inc.
http://www.bowltech.com
Joined: Nov 2006
Posts: 40
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
I strongly suspect Arentzen's htaccess solution will solve this issue in a Linux/Apache environment, and it's good SEO practice to have this set up anyway. smile

Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
I'm using my son's computer for my IE8 testbed since I don't want to update my own smile I should be able to get this fixed for 7.5.3.

Rick #226423 05/12/2009 11:31 AM
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
Hmm, can't duplicate this on several sites I've tested so far. Have tried both allow and disallow multi-url and everything works fine. Still looking for what might be going on.

I can't see why it would be the redirect, since the URL is changed when you first go to the site.

Rick #226424 05/12/2009 11:35 AM
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
Just tried on Mike's bowltech site and no issues logging in there either. This is with the default IE8 settings.

Rick #226427 05/12/2009 12:05 PM
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
Doing a little research and this appears to be an issue on several websites, banks, istockphoto, etc. Apparently, you have to add some websites to the compatibility mode list and restart the browser.

Another solution is to add this to the list of meta tags:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

Still doesn't really explain why it's working for some and not for others, but that's what I've found so far.

Rick #226428 05/12/2009 12:14 PM
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
For anyone having an issue try adding that line to your header insert in the control panel:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

If it works, I may just put that in by default until I can figure out specifically what it doesn't like.

Joined: Nov 2006
Posts: 47
journeyman
Offline
journeyman
Joined: Nov 2006
Posts: 47
Ok, have added to the insert lets see what happens.

Thanks Rick.

Mike


Mike Wilson
Bowl-Tech Inc.
http://www.bowltech.com
Joined: Jun 2006
Posts: 9,242
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,242
Ok, just to clarify, that goes in the Header Insert, and not the Default Header wink

Joined: Dec 2003
Posts: 1,796
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,796
I'll try it on a site I get complaints at smile


- Allen
- ThreadsDev | PraiseCafe
Joined: Dec 2003
Posts: 1,796
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,796
hehe, I can't log in to add it crazy


- Allen
- ThreadsDev | PraiseCafe
Joined: Dec 2003
Posts: 1,796
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,796
OK, I logged in with firefox and added it to the headerinsert.

I still couldn't log in with IE8 - I had to close my browser first then open it back up, now I can log in. thumbsup


- Allen
- ThreadsDev | PraiseCafe
Joined: Dec 2003
Posts: 1,796
Pooh-Bah
Offline
Pooh-Bah
Joined: Dec 2003
Posts: 1,796
I've had people in the past with IE7 say they couldn't log in either, sometimes I'd have to log in through photopost to get logged into the forum. Sometimes I'd have to log out through photopost to be logged out. Odd.

Thanks for this fix tho, one less thing to worry about.


- Allen
- ThreadsDev | PraiseCafe
Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
Since the only site I can see this issue on is
arentzen's site. Is this work around inserted in the header on this site now?
Just curious!


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Dec 2003
Posts: 6,210
Likes: 54
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 54
Never mind I can see the meta tag is in place here now.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Nov 2006
Posts: 47
journeyman
Offline
journeyman
Joined: Nov 2006
Posts: 47

So far so good.

Added this into the header insert per Rick 5 days ago and have had no log in problem reports since then.

I will report back in a few days.

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />


Mike



Mike Wilson
Bowl-Tech Inc.
http://www.bowltech.com
Joined: Jun 2006
Posts: 3,837
Ian Offline
Carpal Tunnel
Offline
Carpal Tunnel
Joined: Jun 2006
Posts: 3,837
I have noticed that if you run 7.5.3 in compatability mode you get duplicate images and lines on the page.

I do not know much about the compatability mode, but it certainly looks odd.

However for some reason on Rick's black and gold stylesheet you need to run this in compatability mode and then the pages look fine - all very strange....

Ian #226669 05/21/2009 9:53 AM
Joined: Jun 2006
Posts: 3,837
Ian Offline
Carpal Tunnel
Offline
Carpal Tunnel
Joined: Jun 2006
Posts: 3,837
Okay - still seems to be an issue with IE8.

I have the line <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> showing up in my header see....

http://www.fansfocus.com/forums/ubbthreads.php/forum_summary.html

Yet I see the compatability view icon [Linked Image from ieblog.members.winisp.net]

If I view this forum in IE8 I do not see the image.

Any reason why?

I did find that if I then click on the icon and put it into compatability mode I get extra lines, and double images all over the place frown

Any thoughts or ideas?

Not 100% sure what it looks like IE7 at the moment.

Page 1 of 2 1 2

Link Copied to Clipboard
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Like unlike bug?
by Morgan - 09/24/2020 5:03 PM
looking to renew :)
by Mors - 09/23/2020 7:52 PM
test
by Mors - 09/23/2020 7:51 PM
What triggers page view numbers
by Morgan - 09/21/2020 10:31 AM
Forum Permissions Question
by FREAK - 09/20/2020 2:13 PM
Who's Online Now
4 members (Ruben, Gizmo, Morgan, 1 invisible), 68 guests, and 44 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200925)