Previous Thread
Next Thread
Print Thread
Hop To
Please help with redirect! #226398 05/12/2009 7:24 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
I just successfully migrated my website Forum from ubb.classic to threads and everything went pretty well. I'm just trying to fix a couple of issues that are perplexing me. The first is the redirect. I followed the instructions, and got errors. I then read through previous issues on this Forum and made another adjustment to the code. It still doesn't work. Here's the part that I changed:

- - - -

# Replacement ultimatebb.cgi script.
# $URL needs to be set to your ubb.threads installation.
$URL = "http://www.ericcarmen.com/ubbthreads";

# site_id only needs to be changed if you've imported multiple forums. The importer
# will tell you what your site id needs to be changed to
$site_id = 1;

# What type of redirect shall we send?
# 0 - Don't send a 301/302 header, my webserver does this. (Enable this if 301/302 results in an ISE or blank page)
# 301 - Permanent
# 302 - Temporary
$redirect = 0;

# Search engine friendly redirects? Change to 0 to disable
$search_friendly = 1;

- - - -

This is what comes up when I use my old Message Board link (http://www.ericcarmen.com/scripts/ultimatebb.cgi):

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

- - - -

Can anyone help me, please?

Thanks in advance.

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226402 05/12/2009 7:55 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
Hi Bernie,

Change $redirect=0 to $redirect=301.

Last edited by Neil White; 05/12/2009 7:57 AM.
Re: Please help with redirect! [Re: Neil White] #226404 05/12/2009 8:03 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
Tried it but am still getting the same error.

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226405 05/12/2009 8:08 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
Do you have an htaccess file active on the site? Try temporarily renaming it (if possible) to .htaccessBAK. (Change it back if it doesn't work.)

Can you access the server logs? Can you put any information up here on the forums (obviously be wary of security issues)?

Re: Please help with redirect! [Re: Neil White] #226406 05/12/2009 8:10 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
Neil, where would I find that file if I had it?

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226407 05/12/2009 8:14 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
It would most likley be in the root directory of your server, but there can be more than one.

You have other problems though - your home page:

http://www.ericcarmen.com/

Is showing PHP code. Can your server run PHP?

Re: Please help with redirect! [Re: Neil White] #226408 05/12/2009 8:15 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
You may need to rename the index page to index.php?

Re: Please help with redirect! [Re: Neil White] #226409 05/12/2009 8:21 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
PHP, eh? Well, that's the other problem I'm having. I used to have a "Content Island" showing the 10 newest posts on the ubb.classic Forum. I attempted to do the same with threads, but as you can see...the posts do not display. I was trying to fix the redirect issue first and then tackle the "content island" issue. I'm not sure how to enable PHP on that index page.

But, back to the redirect...

Re: Please help with redirect! [Re: Bernie Hogya] #226410 05/12/2009 8:23 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
By the way, I just tried renaming the index page, but get a bunch of warnings in the "content island" box.

Re: Please help with redirect! [Re: Bernie Hogya] #226411 05/12/2009 8:23 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16

Last edited by Bernie Hogya; 05/12/2009 8:23 AM.
Re: Please help with redirect! [Re: Bernie Hogya] #226412 05/12/2009 8:27 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
I looked and do not see a file named htaccess. What next?

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226413 05/12/2009 8:30 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
Originally Posted by Bernie Hogya
I'm not sure how to enable PHP on that index page.

Just changing the filename to index.php will do it, and it'd be useful to know if it works!

Originally Posted by Bernie Hogya
But, back to the redirect...

wink Well, I can't see anything wrong with the code you've posted. It looks like a CGI related error, but I'd need to see those error logs to know what's what. I'll keep thinking - hopefully in the meantime more help'll be along...

Re: Please help with redirect! [Re: Neil White] #226414 05/12/2009 8:34 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
Originally Posted by Bernie
I just tried renaming the index page, but get a bunch of warnings in the "content island" box

You can't have set your paths properly in the configuration.

You should take that page down immediately, it is now a bit of a security risk - change it back to .htm for now. Then create a test page, a duplicate of your index page called indexSOMETHING.php and use that for testing until we've sorted this out!

Re: Please help with redirect! [Re: Neil White] #226415 05/12/2009 8:37 AM
Joined: Nov 2006
Posts: 40
Neil White Offline
newbie
Offline
newbie
Joined: Nov 2006
Posts: 40
Many apologies, gotta go out now - will be back in about an hour. Fingers crossed there's more help around for you in the meantime. Feel free to PM/email me for more help if necessary. smile

Re: Please help with redirect! [Re: Bernie Hogya] #226420 05/12/2009 10:10 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
I'd try changing this line from:

$search_friendly = 1;

to:

$search_friendly = 0;

I've seen that setting cause errors on some servers.

Re: Please help with redirect! [Re: Rick] #226422 05/12/2009 10:27 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
Thanks for your help everyone, but it is still not redirecting. I still receive the same error. Do I need to set permissions for that file after uploading? Hmmm...

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226425 05/12/2009 10:35 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Yes, permissions should probably be either 755 or 775.

Re: Please help with redirect! [Re: Rick] #226426 05/12/2009 10:44 AM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
Nope. That didn't do it. But, curiously the php script is correctly redirecting. Still looking to fix this.

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226429 05/12/2009 1:14 PM
Joined: Dec 2003
Posts: 5,998
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,998
Here is a dumb question.
What is your path to perl.
If you have the original ultimatebb.cgi file that was working look at the top line see what it says.
Usr/bin/perl
usr/local/bin/perl

Maybe??


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Please help with redirect! [Re: Ruben] #226450 05/12/2009 3:59 PM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
The original file shows:

usr/local/bin/perl

Re: Please help with redirect! [Re: Bernie Hogya] #226452 05/12/2009 4:14 PM
Joined: Dec 2003
Posts: 5,998
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,998
I don't use the redirector but try changing the first line in the new ultimatebb.cgi file to match that.
It is probably set to usr/bin/perl change it to usr/local/bin/perl
It did make a difference with classic on what it was and the server path.
Assuming you have not changed hosts or your host has changed paths.

Maybe??


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Please help with redirect! [Re: Ruben] #226453 05/12/2009 4:22 PM
Joined: Dec 2003
Posts: 5,998
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,998
You still may need to tweak some of the settings.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Please help with redirect! [Re: Ruben] #226454 05/12/2009 4:48 PM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
Well, that didn't work either.

Re: Please help with redirect! [Re: Bernie Hogya] #226455 05/12/2009 4:55 PM
Joined: Dec 2003
Posts: 5,998
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,998
Then you have tried pretty much everything. Other that a corrupted file problem, I suggest you open a support ticket with UBB.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Please help with redirect! [Re: Ruben] #226456 05/12/2009 5:19 PM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
I'll try using a different text editor and a fresh file. Until then I did manage to fix my "Content Island" problem and have physically changed all of the links on the site to direct to the new threads Board, so all hope is not entirely lost. Thanks everyone for their help on this. It is much appreciated!

Bernie

Re: Please help with redirect! [Re: Ruben] #226457 05/12/2009 5:23 PM
Joined: Dec 2003
Posts: 5,998
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,998
Just a couple of observations.
When viewing the site as a guest I get the:
We encountered a problem. The reason reported was

Database error only visible to forum administrators

Please click back to return to the previous page.
When attempting to view a forum.
I also attempted to register but never received the confirmation email.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Please help with redirect! [Re: Ruben] #226458 05/12/2009 5:23 PM
Joined: Dec 2006
Posts: 1,236
ScriptKeeper Offline
veteran
Offline
veteran
Joined: Dec 2006
Posts: 1,236
Try putting this line into your root .htaccess file
Code
redirect 301 /scripts/ultimatebb.cgi http://www.ericcarmen.com/ubbthreads/

Re: Please help with redirect! [Re: ScriptKeeper] #226459 05/12/2009 5:34 PM
Joined: May 2009
Posts: 16
Bernie Hogya Offline OP
stranger
OP Offline
stranger
Joined: May 2009
Posts: 16
Ruben,

I just logged off and found the same error when I tried to read a post as a guest. I see where you can select "can see forums" and "can see topics" but where do I turn on an option where guests can see posts?

As for the confirmation e-mail, that's another problem I'm trying to troubleshoot. I am getting lots e-mails returned to me marked "Mail Delivery Failure" since switching from classic to threads :-(

Bernie

Re: Please help with redirect! [Re: Bernie Hogya] #226460 05/12/2009 5:45 PM
Joined: Dec 2003
Posts: 5,998
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,998
Most of the view stuff is working like calendar, active topics. But you get a error when attempting to view a post.But it looks like it may be a file permission issue with viewing posts.
When you try to view profiles you get the "You do not have permission to view user profiles."
That would be a permission in the control panel for guests.
The database error is something else.
You will need to enable The logging feature to view what the problem is.
Control Panel Primary Settings
Set the path and run the test.
Then you can goto:
Control Panel View SQL Errors
to view the errors.
But I would bet you have a path setting incorrect in the control panel or a file permission setting wrong in one of the folders.


You can also goto:
Control Panel Permission Checks
And see if something is wrong.
If one of the file/folders show failed you can click on it to see more details.

An also if you do have file permission issues that may be why the redirector is not working correctly

Last edited by Ruben; 05/12/2009 5:51 PM. Reason: Added comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Mobile app?
by Baldeagle - 12/06/2019 9:32 PM
How do you change Text Line spacing?
by jorb - 11/23/2019 12:14 AM
What happened to FAQ or Forum Help
by Ruben - 11/20/2019 11:58 AM
Search feature encountering an Error message
by jorb - 11/20/2019 12:06 AM
Followed List v7.7.2 Question
by Ruben - 11/12/2019 12:22 PM
Who's Online Now
3 registered members (Ruben, JAISP, Gizmo), 69 guests, and 379 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)