Previous Thread
Next Thread
Print Thread
Hop To
Forum List NOT Visible after upgrade from 6.50 - 6.73 #229427 09/24/2009 11:59 AM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
Interesting one that has so far stumped the Groupee Support too so throwing this one out to the wider wind...

After upgrading UBB Classic from 6.50 to 6.73 (I backed everything up first and took screengrabs of the settings), the existing list of 4 Forums are no longer visible.

I've checked the existing paths structure (same as before), checked 755/777 permissions, rebuilt all 4 options in the Control Panel and the Forums still aren't showing up through the standard... /cgi-bin/ultimatebb.cgi? route.

Only if I did a direct URL such as the following:
/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=1;t=000115;p=0 or
/cgi-bin/ultimatebb.cgi?ubb=forum;f=1;hardset=0;start_point=0;DaysPrune=0

...(changing f for Forum Number; t for Topic Number) will the Forums and Topics show up.

Any ideas guys?

Your help would be truly appreciated.

Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229430 09/24/2009 2:38 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Thats a tough call since there are only a few people that visit here that still use classic.
But anyway I recall there was a file in the forums folder that held all of the forum data, not the posts which are in a separate folder but one for all of them.
Probably one of the var files which you should not over write if existing during a upgrade.
You said you had 4 forums so you should have four folders ,forum1 ,fourm2,forum3 and forum4.
But there is another file that I believe was just above them in the path to them.
I would guess you have a corrupted file.

But it may be better to just restore your old version in another folder check that it works then upgrade again. if that works then move classic to the old location and update your var files per the documentation for moving.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229437 09/24/2009 5:09 PM
Joined: Jun 2006
Posts: 15,844
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,844
Well, if you're upgrading to threads it should import all of your old stuff (you'll likely need to re-assign categories though).

Classic had a cache, have you tried purging all files in it?


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Gizmo] #229438 09/24/2009 5:38 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Well he already stated that groupee was not able to help.
He is upgrading within the 6.x series.
So I would suspect a corrupted file due to:
1. Wrong file type transfer used.
2. Overwritten file that should not have been.
3. File corrupted due to dropped connection during transfer.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229443 09/24/2009 6:36 PM
Joined: Feb 2007
Posts: 1,273
JAISP Online Tapedshut
Veteran
Online Tapedshut
Veteran
Joined: Feb 2007
Posts: 1,273
vars_forums.cgi


Contents Example:

1|^|Forum 1|^|Forum 1 Description|^|On|^|is not|^|is|^|allreg&allreg|^|SGKPMU|^|1|^|default|^|ON|^|yes|^||^|all&all|^|000001|^|date|^||^|1


This should give you an idea how to rebuild the file. One line per forum in this file.

Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: JAISP] #229457 09/25/2009 10:20 AM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
Thanks guys. (All) your help here is really appreciated.

Here's the first forum's code. The other three have the same structure. Can you see anything awry in it?

|^|AIRWOLF THEMES Discussion|^|Air your constructive views on AIRWOLF THEMES products - past and future|^|On|^|is|^|is|^|allreg&allreg|^||^|1|^|1000|^|ON|^|no|^||^|administrators,moderators&all|^|000001|^|date|^|This Forum has been set up to allow Airwolf fans and the Wolf Pack to air their views on Airwolf Themes products - past and future.|^|0


Mark J.Cairns
Producer, Airwolf Themes CD soundtracks

AIRWOLF WEBSITE https://airwolfthemes.com/mobile/
OFFICIAL AIRWOLF THEMES VIDEOS https://www.youtube.com/airwolfthemes
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229460 09/25/2009 1:56 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Not really sure. I can't remember what each value in the array is for but if you are going to try to repair the board and not re-install. Here is what I would do.
Add a forum in the control panel. Make the settings for what you would have for the existing ones.
Make a test post. If it works double check the new forum in the var file against the others.
Then just disable the test forum from view.
Should take a whole 5 minutes to do and this should at least verify something is working at all.

NOTE:Old school teaching from classic was always never delete a forum just disable it. And recycle for a future forum.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229461 09/25/2009 2:25 PM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
Just tried adding a 5th Forum. Doesn't show up either when the boards either in Admin mode / fully Open Mode.

/cgi-bin/ultimatebb.cgi

Rebuilt the Meta-Data and Cleared Cache again. Still no difference. This is SO frustrating.

Last edited by Mark J.Cairns; 09/25/2009 2:28 PM.

Mark J.Cairns
Producer, Airwolf Themes CD soundtracks

AIRWOLF WEBSITE https://airwolfthemes.com/mobile/
OFFICIAL AIRWOLF THEMES VIDEOS https://www.youtube.com/airwolfthemes
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229462 09/25/2009 2:43 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Okay I feel your pain.
I would double check your permission settings and also look at the file sizes for 0 bytes. The could be a clue to a bad/corrupted file.
I am talking all of the files.
Like I posted before it might be more simple to restore the backup. Get it working and deal with the upgrade on a different folder to test. Since I see your site has been down for this duration.
BTW I have never seen a issue like this upgrading within the 6x version. But from 5x to 6x all kinds of things happen especially when the code was modified.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229465 09/25/2009 6:54 PM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
There's a vars_cats.cgi file sitting at 1-byte in size, which is empty when I open it in a text editor?


Mark J.Cairns
Producer, Airwolf Themes CD soundtracks

AIRWOLF WEBSITE https://airwolfthemes.com/mobile/
OFFICIAL AIRWOLF THEMES VIDEOS https://www.youtube.com/airwolfthemes
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229467 09/25/2009 7:10 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
I think that's normal for your installation since you aren't using categories at all.

Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229473 09/25/2009 8:10 PM
Joined: Feb 2007
Posts: 1,273
JAISP Online Tapedshut
Veteran
Online Tapedshut
Veteran
Joined: Feb 2007
Posts: 1,273
Originally Posted by Mark J.Cairns
Thanks guys. (All) your help here is really appreciated.

Here's the first forum's code. The other three have the same structure. Can you see anything awry in it?

|^|AIRWOLF THEMES Discussion|^|Air your constructive views on AIRWOLF THEMES products - past and future|^|On|^|is|^|is|^|allreg&allreg|^||^|1|^|1000|^|ON|^|no|^||^|administrators,moderators&all|^|000001|^|date|^|This Forum has been set up to allow Airwolf fans and the Wolf Pack to air their views on Airwolf Themes products - past and future.|^|0


You be missing the forums number in the beginning |^|AIRWOLF....

If your folder for that forums is Forum1 then the number should be 1.

Example:

1|^|AIRWOLF THEMES Discussion|^|Air your constructive views on AIRWOLF THEMES products - past and future|^|On|^|is|^|is|^|allreg&allreg|^||^|1|^|1000|^|ON|^|no|^||^|administrators,moderators&all|^|000001|^|date|^|This Forum has been set up to allow Airwolf fans and the Wolf Pack to air their views on Airwolf Themes products - past and future.|^|0

Last edited by JAISP; 09/25/2009 8:11 PM.
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: JAISP] #229474 09/25/2009 11:41 PM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
Thanks, but that didn't work either.


Mark J.Cairns
Producer, Airwolf Themes CD soundtracks

AIRWOLF WEBSITE https://airwolfthemes.com/mobile/
OFFICIAL AIRWOLF THEMES VIDEOS https://www.youtube.com/airwolfthemes
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229479 09/26/2009 5:12 AM
Joined: Feb 2007
Posts: 1,273
JAISP Online Tapedshut
Veteran
Online Tapedshut
Veteran
Joined: Feb 2007
Posts: 1,273
If you would like to zip up your Variable files and UBB files and send them to me through email I will go over all your files and see if I can figure it out for you.

I will PM you my email address.

Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: JAISP] #229480 09/26/2009 7:35 AM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
Originally Posted by JAISP
If you would like to zip up your Variable files and UBB files and send them to me through email I will go over all your files and see if I can figure it out for you.

I will PM you my email address.


That is the most amazing & generous offer I've ever heard and thank you so much.

But I really don't want to trouble you guys with this any longer as I decided today (after a week of fighting with it, with no guarantee in the end) to just do the Import/Export from Classic (all the posts & Member's details exported perfectly to 7 big fat TXT files nicely for me) and go the whole hog and come along for the ride with UBB Threads with the rest of you. It'll take me most of the day no doubt but I just can't not have a Forum any longer (we've a launch of a new 'Airwolf' TV series soundtrack product out today and my In-box is heaving with folks howling for its return).

Guys, honestly I've been *SO* impressed by how friendly and helpful it is here. I've never experienced that before on the web for Tech like this. Kudos to all of you. It has been truly respected and appreciated!

I'll be back regularly to browse the other forums now. Many thanks again.


Mark J.Cairns
Producer, Airwolf Themes CD soundtracks

AIRWOLF WEBSITE https://airwolfthemes.com/mobile/
OFFICIAL AIRWOLF THEMES VIDEOS https://www.youtube.com/airwolfthemes
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229484 09/26/2009 12:09 PM
Joined: Feb 2007
Posts: 1,273
JAISP Online Tapedshut
Veteran
Online Tapedshut
Veteran
Joined: Feb 2007
Posts: 1,273
Don't be a stranger. I have checked out your site and being an Airwolf fan I will be back to look it over even more closely.

If you have any problems and such just ask anyone here will help you to their best ability.

Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229487 09/26/2009 3:38 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
As a caveat if you are going to ubbthreads.
The importer script only works with a functioning classic board. It does not import a classic export file into threads.
At least as far as I know from when i upgraded.
So that means if you don't have your classic board running even the old version(which I believe will import to threads). You may be starting with a completely clean slate no posts from the prior board.

Of course whatever the problem is you have now may not impact the conversion(import).


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229488 09/26/2009 3:42 PM
Joined: Jun 2006
Posts: 15,844
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,844
Actually, I think the import may work regardless of if his classic is working or not in this case; the forums are *there* just not showing on the index. The importer should still be able to grab the content from the data files.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Gizmo] #229489 09/26/2009 3:46 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Yea Giz I am thinking it may work also but I think he should try JAISP's suggestion and edit the var file and add the 1 at least to the first forum line and see if it works.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229492 09/26/2009 4:34 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Okay I think I may have a resolution for you. With the category option.
I was able to duplicate your problem.
Try this in the control panel.
Control Panel » General
Expand Forum Summary Options
Deselect Enable Categories?
It appears that you may have had a category existing and the upgrade may have enabled the above setting.
If the four forums are not assigned a category they will not appear if the item above is enabled.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229493 09/26/2009 5:01 PM
Joined: Jun 2006
Posts: 15,844
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,844
Originally Posted by Ruben
Yea Giz I am thinking it may work also but I think he should try JAISP's suggestion and edit the var file and add the 1 at least to the first forum line and see it it works.
Didn't he say he tried that?

Originally Posted by Mark J.Cairns
Thanks, but that didn't work either.
here



I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Gizmo] #229494 09/26/2009 5:10 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Yea I guess so if that is what he was replying to.But my next post I was able to duplicate his problem.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229495 09/26/2009 6:45 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Well I guess he got threads working and it imported the old topics.
At least for a few moments. Then they disappeared.
Possibly permission settings.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229496 09/26/2009 7:14 PM
Joined: Sep 2009
Posts: 36
Mark J.Cairns Offline OP
newbie
OP Offline
newbie
Joined: Sep 2009
Posts: 36
I'm trying that Categories idea.

Didn't seem to work. The whole ultimatebb.cgi is stuffed now.

Anyway, I've spent quite a few hours installing Threads. At least all the Users data came over, just not the existing Forums/Posts.

Damn, it's ugly in default mode. Lucky I screen-grabbed all my Classic colour / font settings before any of this happened. Will struggle on with this manual chore.


Mark J.Cairns
Producer, Airwolf Themes CD soundtracks

AIRWOLF WEBSITE https://airwolfthemes.com/mobile/
OFFICIAL AIRWOLF THEMES VIDEOS https://www.youtube.com/airwolfthemes
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Mark J.Cairns] #229497 09/26/2009 7:59 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Well it looked like it worked for a moment. Then all of the posts disappeared. Maybe it is a permission issue?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum List NOT Visible after upgrade from 6.50 - 6.73 [Re: Ruben] #229498 09/26/2009 8:05 PM
Joined: Dec 2003
Posts: 5,974
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,974
Try checking;
Control Panel » Group Management
Users Forum Permissions
Make sure things like Can see forum are selected.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Having issue with redirects to UBB classic URLs
by amciotola - 10/16/2019 1:11 AM
Unable to save General settings
by amciotola - 10/13/2019 4:23 AM
I see signature line images, but no avatars
by Morgan - 10/12/2019 2:21 PM
Show PDF
by Geoff - 10/09/2019 1:33 AM
Subscription’s Auto Return URL for PayPal
by Geoff - 09/27/2019 12:10 AM
Who's Online Now
1 registered members (JAISP), 98 guests, and 427 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20190930)