Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
1 registered members (DLWebmaestro), 58 guests, and 251 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
zoomway
zoomway
swamptropolis
Posts: 25
Joined: January 2004
Show All Member Profiles 
Top Posters(30 Days)
isaac 43
M4TT 26
Gizmo 24
Ruben 24
Morgan 13
Jake 4
Latest Photos
Big stuff
Test
Testing to drag photos
Comfortable Cats
Test
Previous Thread
Next Thread
Print Thread
Gallery upload problem #236968
05/23/10 05:35 PM
05/23/10 05:35 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
99% sure this isn't threads - but I would appreciate your input before contacting my host.

1st - would you agree that this isn't a threads issue?

Quote:
Fatal error: Maximum execution time of 30 seconds exceeded in /forums/libs/image.inc.php on line 102


2nd - what can I tell my host to get the most positive response from them?

Thanks smile


Using version :: 7.6.2
Express Hosting
Re: Gallery upload problem [Re: driv] #236969
05/23/10 06:01 PM
05/23/10 06:01 PM
Ruben  Offline
Joined: Dec 2003
Posts: 5,865
Lutz,FL
It could be bats or whales. HE HE!
But it really looks like a timeout issue on the host or isp side. Without even looking at the line in question.
Is it just you or others that have the problem?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Gallery upload problem [Re: driv] #236970
05/23/10 06:02 PM
05/23/10 06:02 PM
SD  Offline
Former Developer
Joined: Apr 2007
Posts: 3,945
SoCal, USA
i'm guessing it's puking on the resize (thumbs etc)

now it might just not have privs to copy the newly created thumb over to the appropriate directory after doing the GD or IM resize.

is this a gallery forum that was working before?

if it's new, then are the dirs chModded to right permissions?

Re: Gallery upload problem [Re: SD] #236971
05/23/10 06:12 PM
05/23/10 06:12 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
Ahhhh - sorry.
I wasn't clear enough.

It's all users, not just me (in fact I didn't know about it!)

The images are all in the size range allowed by (me) & UBB.

If I reduce the image size, I can upload ok (I haven't done many tests yet though).




Using version :: 7.6.2
Re: Gallery upload problem [Re: driv] #236972
05/23/10 06:18 PM
05/23/10 06:18 PM
Ruben  Offline
Joined: Dec 2003
Posts: 5,865
Lutz,FL
Humm maybe your host changed some settings on php.ini?
Sounds suspicious that reducing the file size works.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Gallery upload problem [Re: Ruben] #236973
05/23/10 06:23 PM
05/23/10 06:23 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
Indeed. I can't imagine that UBB is at fault, but I want to go to my host with the best information I have, to get the best result.


Using version :: 7.6.2
Re: Gallery upload problem [Re: driv] #236974
05/23/10 06:26 PM
05/23/10 06:26 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
Interestingly, I couldn't upload a 1Mb file. But by reducing 4 images to a total of 1.2Mb - I was able to upload them.

What does that mean?


Using version :: 7.6.2
Re: Gallery upload problem [Re: driv] #236975
05/23/10 06:32 PM
05/23/10 06:32 PM
Ruben  Offline
Joined: Dec 2003
Posts: 5,865
Lutz,FL
Guessing here.
If you peek at phpinfo what is the value of "post_max_size"
Is it lower that your allowed file upload size?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Gallery upload problem [Re: Ruben] #236976
05/23/10 06:37 PM
05/23/10 06:37 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
I'll take a look, thanks.


Using version :: 7.6.2
Re: Gallery upload problem [Re: driv] #236977
05/23/10 09:24 PM
05/23/10 09:24 PM
SD  Offline
Former Developer
Joined: Apr 2007
Posts: 3,945
SoCal, USA
you can see that value in admin cpanel.. smile

Re: Gallery upload problem [Re: SD] #237047
05/26/10 05:31 PM
05/26/10 05:31 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
Just got this answer from my host.
I'd appreciate any feedback.

Thanks. smile


Quote:
Couple of issues.

1) Most broadband lines are 256 Kbit upload speed so you're looking at
about 20 to 25Kbytes per second.

ie a 30 second script limit is going to be sub 750Kbytes which is about
right for the job you're seeing.

The fix is to extend the script execution time to more than 30 seconds via the php code or .htacess.

The risk is that if anything else wihtin the forum breaks, it'll let the scripts run away with with the CPU resources.

2) If you're letting users upload content are you filtering the files during the upload to ensure they're not pushing PHP/Perl or shell scripts to the server.


Using version :: 7.6.2
Re: Gallery upload problem [Re: driv] #237051
05/26/10 06:30 PM
05/26/10 06:30 PM
R
Rick  Offline
Former Developer
Joined: Jun 2006
Posts: 9,246
Aberdeen, WA
1) You can edit the scripts/filemanager and add the following to it, somewhere after the opening header comments, which will allow the script to run to completion:

set_time_limit(0);

2) Yes wink

Re: Gallery upload problem [Re: Rick] #237091
05/28/10 05:47 PM
05/28/10 05:47 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
Thanks Rick,
What are the implications of making this change (to the rest of the forum)?

Especially with respect to...
Quote:
The risk is that if anything else wihtin the forum breaks, it'll let the scripts run away with with the CPU resources.


Using version :: 7.6.2
Re: Gallery upload problem [Re: driv] #237093
05/28/10 07:54 PM
05/28/10 07:54 PM
R
Rick  Offline
Former Developer
Joined: Jun 2006
Posts: 9,246
Aberdeen, WA
Since you're just making the change to the one script, there isn't much risk. It's only going to allow the upload script to run longer if needed, all other scripts will still timeout after the default php.ini setting.

Re: Gallery upload problem [Re: Rick] #237095
05/28/10 08:04 PM
05/28/10 08:04 PM
driv  Offline
OP
Joined: Jan 2004
Posts: 2,466
Cheers matey.
Much appreciated smile


Using version :: 7.6.2

ShoutChat Box
Today's Birthdays
No Birthdays
Recent Topics
Follow Thread Button Not Aligned
by M4TT - 03/16/19 09:24 PM
Author Content Portrait Avatars
by M4TT - 03/16/19 09:12 PM
problem with ubbthreads dark scheme
by TheBrit - 03/15/19 04:17 PM
7.7.1 Forums and Categories
by AstroCat - 03/15/19 08:16 AM
How to Add Sound Effects Modification
by M4TT - 03/10/19 07:02 PM
Forum Statistics
Forums35
Topics35,259
Posts192,299
Members12,143
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.7.2
(Snapshot build 20190227)