|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
The hostserver where my UBB is loaded to my domain did a SQL database repairs for another software issue and now I find when going to my forum it is crashed saying
We encountered a problem. The reason reported was
Database error only visible to forum administrators
---------------
How can I get to Admin directly (URL) ? page to fix this ASAP or via the Cpanel of the host for SQL ?
Never seen this in 10 years of UBB use so no idea how to quickly fix this
When I try to go directly to admin logn I get
Fatal error: Call to a member function error() on a non-object in /home1/teamzron/public_html/ubbthreads/libs/mysql.inc.php on line 77
Thanks for any help
Last edited by teamzr1; 07/25/2010 1:10 PM.
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
You'll want to get to the root cause of the error. If you don't have SQL error logging turned on, then you'll want to edit the libs/mysql.inc.php file and change the line that says:
$showerror = 0;
to
$showerror =1;
Then report back here with what the actual error is.
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
Does the error I added to above help ?
via Cpanel on host the phpAdmin was used and the databases were all set to repair and then to optimize After that forum was broken
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
Not particularly. It's trying to throw an admin error but can't. We really need to see the actual database error.
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
Changing to 1 and now get
We encountered a problem. The reason reported was
Script: Line#: SQL Error: Access denied for user 'teamzron'@'localhost' (using password: YES) SQL Error #: 1045 Query: Unable to connect to the database!
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
Ok, so it's a database access issue. It seems somehow they've taken away your access to your database. If you've got cpanel you might want to go into the MySQL databases section and confirm that the proper user has access to the database, or create a new user if necessary.
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
Which database is for UBB ?
teamzron_bdd1 0.05 MB teamzron_bdd1 Delete User Delete Database teamzron_dprj1 0.20 MB teamzron_dprj1 Delete User Delete Database teamzron_mychat1 0.00 MB teamzron_mychat1 Delete User Delete Database teamzron_nhs1 0.16 MB teamzron_nhs1 Delete User Delete Database teamzron_pfc01 0.00 MB teamzron_pfc01 Delete User Delete Database teamzron_zc1 72.77 MB teamzron_zc1 Delete User
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
It looks like the teamzron_zc1, but to be sure, take a look at your includes/config.inc.php file and look at the DATABASE_NAME in that file to verify.
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
If you don't recall your database name then you may want to start with looking at includes/config.inc.php. The top few lines will tell you all the info needed. <?php $config = array ( 'DATABASE_SERVER' => 'yourhost', 'DATABASE_USER' => 'username', 'DATABASE_PASSWORD' => 'password', 'DATABASE_NAME' => 'databasename', 'TABLE_PREFIX' => 'ubbt_',( this is the default setting)
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
Whats up with the delete user line?
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
That's a cPanel thing. It allows you to delete that particular user from accessing the database
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
Yes I know. Thats what I mean. How was a user deleted???
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
I suspect the damn tech on hostmonster had me change the main password which now does not match the password I see in the Config.inc.php you had me check
Sound right ? if it no longer matches then forum fails to load ?
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
That is a function that allows user (admin) to click and delete existing database(s)
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
Thats correct. You need to probably start over. Meaning add a user and password to the ubb database. Then edit the config.inc.php to match it. Or vice versa. Check the config file and add a user and password to the database that matches the config file. Your call.
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
OK guys thanks for the help
in 10 plus years of running UBB this is only the 2nd time it was non working :-(
Problem is the morons at hostmonster did backup restore so forum is back up but all posts for the last week are gone :-(
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
That's probably because the backup file was a week old. Might be time to consider your own backup routine. For a CYA situation like this in the future.
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Jun 2006
Posts: 9,242 Likes: 1
Former Developer
|
|
Former Developer
Joined: Jun 2006
Posts: 9,242 Likes: 1 |
Ugh, sorry to hear that. Why did the do a backup restore in the first place? Did they do that for all of the databases on that server or just for you?
|
|
|
|
|
Joined: Jun 2007
Posts: 286
enthusiast
|
|
enthusiast
Joined: Jun 2007
Posts: 286 |
Rick support at Hostmonster pure stinks,
They caused all this as they supply Zen Cart a frontstore software. A update of it wacked a Admin function, HM tech said it was a database issue
Add to problem I suspect HM has had hacking problems and was forcing all domain owners to change master passwords.
Well when the phpadmin was used old password had to be changed BUT it also changed then password to all databases
Bitch is I find the Zen Cart problem was the vendor of software coding issue and not a DB issue.
Thus HM idiots instead of knowing the password was the issue forced a 1 week backup ( they wanted to delete the UBB forum and I reinstall and I refused !)
To make it worse I had told them NOT to do the backup as I changed the PW in the config file to new one so forum was back up Then they did do the back up so now old PW was used so forum was down again and I just had to change PW back to old password again
Happy Admin Sunday blown day :-(
JR Team ZR-1 Corvette Racer's
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
That sucks. Chasing a problem all day that keeps changing and was never something you did to begin with.
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Feb 2007
Posts: 1,294 Likes: 2
Veteran
|
|
Veteran
Joined: Feb 2007
Posts: 1,294 Likes: 2 |
I installed Zen Cart on one of my servers for a client to test the software as he intended to use it if it fit his needs. It appeared to be a good solution for that client but overnight some how through the Zen Cart software the MySQL database user file was accessed and all users were deleted and the user folder on the server was corrupted and unable to be repaired.
I found the problem through a secondary server that monitors all access to the servers through the network and found exactly what was done and how. The person who did this did a very good job at covering his tracks and I would have never found out what happened if I didn't have a secondary server running the log copies and such.
What I had to do is log into the server as a root user and upload a copy of the user records on to the server and reset the file permissions as it is a Linux server. Once that was completed all users were able to access their MySQL databases once again with out any problems and no data was lost in any of the databases running on the server.
|
|
|
|
|
Joined: Jan 2008
Posts: 514
addict
|
|
addict
Joined: Jan 2008
Posts: 514 |
May I make a quick suggestion? Change your hosting to MindRaven and forget about your present people.. we all know that Tech Support for UBB is probably the best there is already so I don't think that their hosting plans would be any different.
Just a thought. I know I run my own equipment but if I didn't I can guarantee you I would be running on MindRaven's servers.
Dunny
|
|
|
|
|
Joined: Jun 2006
Posts: 1,344
veteran
|
|
veteran
Joined: Jun 2006
Posts: 1,344 |
Just a thought. I know I run my own equipment but if I didn't I can guarantee you I would be running on MindRaven's servers.
Dunny Same here and was thinking the same thing!
|
|
|
|
|
Joined: Mar 2008
Posts: 262
enthusiast
|
|
enthusiast
Joined: Mar 2008
Posts: 262 |
I am in the process of moving our club site to Mindraven and can tell you Rick has made it painless!!!!
|
|
|
|
1 members (Gizmo),
156
guests, and
110
robots. |
|
Key:
Admin,
Global Mod,
Mod
|
|
|
|