Previous Thread
Next Thread
Print Thread
Hop To
Joined: Jul 2007
Posts: 103
nims2 Offline OP
member
OP Offline
member
Joined: Jul 2007
Posts: 103
Hi,

I have my site available on multiple domains (.net, and also .nl etc). I noticed that the shoutbox was not working when it was not on my external URL. Digging into this, and while trying to setup the naked shoutbox, I noticed it came from this statement in the page:
Code
var script		= "http://URLFORSITE/ubbthreads.php";

This made it only work for my URL, but not for the others. Looking in the file header.tpl, I noticed this

Code
var script		= "{ubb url="" full="true"}";

I changed this to:
Code
var script		= "{ubb url="" full="false"}";
And voila, the shoutbox is working again!

This is because the script is now actually changed to:
Code
var script		= "/ubbthreads.php";
which makes it work again.

Now my question is, why is it like this and is it OK to just let the header.tpl reside on "false"? What are the side-effects, risks etc?

To me it seems that everything works as it should, but is that true?

Joined: Dec 2003
Posts: 6,278
Likes: 45
Offline
Joined: Dec 2003
Posts: 6,278
Likes: 45
I would only guess that you had Domains for HTTP Referer Check:
configured for only one domain not all
And had Disable HTTP Referer Check?
Not selected.
You probably could have checked the Disable HTTP Referer Check

And accomplished the same thing. Since that setting is going away anyway.

Control Panel » Primary Settings[-]Advanced Options



Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jul 2007
Posts: 103
nims2 Offline OP
member
OP Offline
member
Joined: Jul 2007
Posts: 103
Actually I have had them checked and setupped correctly.
"Disable HTTP Referec Check" is not selected and I have used the following for "Domains for HTTP Referer Check:"

http://nlforum.merudi.net|http://nlforum.merudi.nl|http://nlforum.merudi.eu|http://nlforum.merudi.com|http://nlforum.merudi.org|http://nlforum.uitgedoktert.nl

They are all listed here, but no avail.

Joined: Jul 2007
Posts: 103
nims2 Offline OP
member
OP Offline
member
Joined: Jul 2007
Posts: 103
P.s. I don't want to disable the HTTP Referer check, otherwise my log is not showing any referers anymore, which I actually want to see. So disabeling this checkbox, is not an option for me.

Joined: Dec 2003
Posts: 6,278
Likes: 45
Offline
Joined: Dec 2003
Posts: 6,278
Likes: 45
Humm.
I have had Referer check disabled for years.

And My View Referer Logs in UBB.
Is slam full of entries. I see 20 right now for today.

Like I mentioned before. That option will be gone on the next release anyway.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
v7.7.5 Active Topics Display Name Incorrect
by Jake - 11/17/2020 4:46 PM
custom islands in forums tool
by Ruben - 11/17/2020 3:21 PM
Captcha bug maybe?
by Morgan - 11/16/2020 8:34 AM
Facebook thumbnail issue
by DBryce - 11/08/2020 7:43 PM
No hop to menu in the category pages
by Morgan - 11/05/2020 4:19 PM
Who's Online Now
1 members (JAISP), 67 guests, and 56 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5