Previous Thread
Next Thread
Print Thread
Hop To
Island banner insertion problem #248550 02/29/2012 6:14 PM
Joined: Sep 2008
Posts: 4
natcon Offline OP
stranger
OP Offline
stranger
Joined: Sep 2008
Posts: 4
I am trying to put google ad words and other banner rotation script into a sidebar island on my UBB board and it is showing a syntax error. It was just up and there must be something I am not adding in that I should, to get it to show up. Can you help me?

Re: Island banner insertion problem [Re: natcon] #248551 02/29/2012 6:30 PM
Joined: Dec 2003
Posts: 5,974
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,974


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Island banner insertion problem [Re: natcon] #248552 02/29/2012 6:42 PM
Joined: Sep 2008
Posts: 4
natcon Offline OP
stranger
OP Offline
stranger
Joined: Sep 2008
Posts: 4
I go to protal layout and there is a link to the sidebar that I named resources. I click on the link and it says this

Body
This should contain the PHP code or HTML for the custom box. $body contains the actual content that should be printed in the custom box.

Warning: Invalid PHP code that has syntax errors can result in breaking the entire portal

then in the box I have this

?><script type="text/javascript" src="http://www.1800banners.com/adserver/adserver3.js"></script>
<script type="text/javascript">
var varsarray=[];
varsarray[0]='40165';
if(!token) {var token='0'} else {var token=token+1;}
var loadtype='0';
var adtype='3';
var background_color='#F0F0F0';
var border_color='#000000';
var text_color='#060606';
var text_rollcolor='#0033FF';
var domain_color='#9F9F9F';
varsarray['interhours']='';
varsarray['interpages']='';
adserver_initialize(token,loadtype,adtype,background_color,border_color,text_color,text_rollcolor,domain_color,varsarray);
</script>

?>
?>
?>

after I submit it a new question mark with greater than sign appears at the bottom but nothing shows up, either that or it shows a syntax error like this

Parse error: syntax error, unexpected '<' in /WWW/docs/forums/cache_builders/custom/portal_box_1.php on line 2

Re: Island banner insertion problem [Re: natcon] #248553 02/29/2012 6:45 PM
Joined: Dec 2003
Posts: 5,974
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,974
All completely incorrect.
Go back and read the wiki link I provided.

Re-insert the default code and start over.

Last edited by Ruben; 02/29/2012 6:59 PM. Reason: Added Comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Island banner insertion problem [Re: natcon] #248554 02/29/2012 7:00 PM
Joined: Jan 2004
Posts: 2,468
driv Offline
Offline
Joined: Jan 2004
Posts: 2,468
The ?> should not be there.

Start by resetting your island to something like this...


Code
/* PHP CODE HERE, IF NECESSARY */
/* DO NOT CHANGE THE LINE BELOW */
$body = <<<EOF




EOF;
/* DO NOT CHANGE THE LINE ABOVE */





Now place your code between the two EOFs


(Although, many javascripts need to go in the page header.)


Using version :: 7.7.2
Re: Island banner insertion problem [Re: natcon] #248555 02/29/2012 7:05 PM
Joined: Dec 2003
Posts: 5,974
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,974
Also if you read
http://www.ubbwiki.com/wiki/view/79/custom-islands.html
it will tell you the same thing.
Then get rid of the incorrect php tags.
Like Driv stated ?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Island banner insertion problem [Re: driv] #248556 02/29/2012 7:06 PM
Joined: Sep 2008
Posts: 4
natcon Offline OP
stranger
OP Offline
stranger
Joined: Sep 2008
Posts: 4
cool that worked. I could not get the link to open up, but I copied and pasted what you put and it worked fine. THANKS!

Re: Island banner insertion problem [Re: natcon] #248557 02/29/2012 7:11 PM
Joined: Sep 2008
Posts: 4
natcon Offline OP
stranger
OP Offline
stranger
Joined: Sep 2008
Posts: 4
I was wondering if you could look at my forums and tell me if there is any features that I am missing out on that would spruce it up

www.nationalcontractors.com/forums

Re: Island banner insertion problem [Re: natcon] #248563 03/01/2012 4:08 AM
Joined: Jul 2011
Posts: 22
Cerise Offline
stranger
Offline
stranger
Joined: Jul 2011
Posts: 22
Tried to get on just now to have a look, but no response - is the site down?

Re: Island banner insertion problem [Re: natcon] #248564 03/01/2012 4:12 AM
Joined: Jan 2004
Posts: 2,468
driv Offline
Offline
Joined: Jan 2004
Posts: 2,468
same here...


Using version :: 7.7.2
Re: Island banner insertion problem [Re: natcon] #248797 03/31/2012 12:09 AM
Joined: Sep 2010
Posts: 97
VaGunTrader Offline
member
Offline
member
Joined: Sep 2010
Posts: 97
Great guide Ruben !!
I'm messing around with this for the first time. I have a picture on photobucket that I'm using as my portal island picture. I actually got it to show up on my website. Now... I want members to be able to click on the picture and have them directed to a specific website. Right now it just links them to the photobucket website showing my picture. Whats the best way to link to a specified website?
What would you do Ruben?

Re: Island banner insertion problem [Re: natcon] #248798 03/31/2012 3:46 AM
Joined: Jun 2006
Posts: 15,844
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,844
Code
<a href="http://thesite.tld/linkedpage.php" target="_blank"><img src="http://thesite.tld/image.ext" alt="name describing photo" /></a>


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Having issue with redirects to UBB classic URLs
by amciotola - 10/16/2019 1:11 AM
Unable to save General settings
by amciotola - 10/13/2019 4:23 AM
I see signature line images, but no avatars
by Morgan - 10/12/2019 2:21 PM
Show PDF
by Geoff - 10/09/2019 1:33 AM
Subscription’s Auto Return URL for PayPal
by Geoff - 09/27/2019 12:10 AM
Who's Online Now
1 registered members (Ruben), 81 guests, and 164 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20190930)