Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
3 registered members (JAISP, isaac, Gizmo), 76 guests, and 365 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 25
Joined: November 2012
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 14
FREAK 11
M4TT 9
mmkk 5
Ruben 4
isaac 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Island banner insertion problem #248550
02/29/12 05:14 PM
02/29/12 05:14 PM
Joined: Sep 2008
Posts: 4
N
natcon Offline OP
stranger
natcon  Offline OP
stranger
N
Joined: Sep 2008
Posts: 4
I am trying to put google ad words and other banner rotation script into a sidebar island on my UBB board and it is showing a syntax error. It was just up and there must be something I am not adding in that I should, to get it to show up. Can you help me?

Re: Island banner insertion problem [Re: natcon] #248551
02/29/12 05:30 PM
02/29/12 05:30 PM
Joined: Dec 2003
Posts: 5,823
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,823
Lutz,FL


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Island banner insertion problem [Re: natcon] #248552
02/29/12 05:42 PM
02/29/12 05:42 PM
Joined: Sep 2008
Posts: 4
N
natcon Offline OP
stranger
natcon  Offline OP
stranger
N
Joined: Sep 2008
Posts: 4
I go to protal layout and there is a link to the sidebar that I named resources. I click on the link and it says this

Body
This should contain the PHP code or HTML for the custom box. $body contains the actual content that should be printed in the custom box.

Warning: Invalid PHP code that has syntax errors can result in breaking the entire portal

then in the box I have this

?><script type="text/javascript" src="http://www.1800banners.com/adserver/adserver3.js"></script>
<script type="text/javascript">
var varsarray=[];
varsarray[0]='40165';
if(!token) {var token='0'} else {var token=token+1;}
var loadtype='0';
var adtype='3';
var background_color='#F0F0F0';
var border_color='#000000';
var text_color='#060606';
var text_rollcolor='#0033FF';
var domain_color='#9F9F9F';
varsarray['interhours']='';
varsarray['interpages']='';
adserver_initialize(token,loadtype,adtype,background_color,border_color,text_color,text_rollcolor,domain_color,varsarray);
</script>

?>
?>
?>

after I submit it a new question mark with greater than sign appears at the bottom but nothing shows up, either that or it shows a syntax error like this

Parse error: syntax error, unexpected '<' in /WWW/docs/forums/cache_builders/custom/portal_box_1.php on line 2

Re: Island banner insertion problem [Re: natcon] #248553
02/29/12 05:45 PM
02/29/12 05:45 PM
Joined: Dec 2003
Posts: 5,823
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,823
Lutz,FL
All completely incorrect.
Go back and read the wiki link I provided.

Re-insert the default code and start over.

Last edited by Ruben; 02/29/12 05:59 PM. Reason: Added Comment

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Island banner insertion problem [Re: natcon] #248554
02/29/12 06:00 PM
02/29/12 06:00 PM
Joined: Jan 2004
Posts: 2,650
driv Offline

driv  Offline


Joined: Jan 2004
Posts: 2,650
The ?> should not be there.

Start by resetting your island to something like this...


Code
/* PHP CODE HERE, IF NECESSARY */
/* DO NOT CHANGE THE LINE BELOW */
$body = <<<EOF




EOF;
/* DO NOT CHANGE THE LINE ABOVE */





Now place your code between the two EOFs


(Although, many javascripts need to go in the page header.)


Using version :: 7.6.0
Re: Island banner insertion problem [Re: natcon] #248555
02/29/12 06:05 PM
02/29/12 06:05 PM
Joined: Dec 2003
Posts: 5,823
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,823
Lutz,FL
Also if you read
http://www.ubbwiki.com/wiki/view/79/custom-islands.html
it will tell you the same thing.
Then get rid of the incorrect php tags.
Like Driv stated ?


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Island banner insertion problem [Re: driv] #248556
02/29/12 06:06 PM
02/29/12 06:06 PM
Joined: Sep 2008
Posts: 4
N
natcon Offline OP
stranger
natcon  Offline OP
stranger
N
Joined: Sep 2008
Posts: 4
cool that worked. I could not get the link to open up, but I copied and pasted what you put and it worked fine. THANKS!

Re: Island banner insertion problem [Re: natcon] #248557
02/29/12 06:11 PM
02/29/12 06:11 PM
Joined: Sep 2008
Posts: 4
N
natcon Offline OP
stranger
natcon  Offline OP
stranger
N
Joined: Sep 2008
Posts: 4
I was wondering if you could look at my forums and tell me if there is any features that I am missing out on that would spruce it up

www.nationalcontractors.com/forums

Re: Island banner insertion problem [Re: natcon] #248563
03/01/12 03:08 AM
03/01/12 03:08 AM
Joined: Jul 2011
Posts: 24
C
Cerise Offline
stranger
Cerise  Offline
stranger
C
Joined: Jul 2011
Posts: 24
Tried to get on just now to have a look, but no response - is the site down?

Re: Island banner insertion problem [Re: natcon] #248564
03/01/12 03:12 AM
03/01/12 03:12 AM
Joined: Jan 2004
Posts: 2,650
driv Offline

driv  Offline


Joined: Jan 2004
Posts: 2,650
same here...


Using version :: 7.6.0
Re: Island banner insertion problem [Re: natcon] #248797
03/30/12 11:09 PM
03/30/12 11:09 PM
Joined: Sep 2010
Posts: 100
V
VaGunTrader Offline
member
VaGunTrader  Offline
member
V
Joined: Sep 2010
Posts: 100
Great guide Ruben !!
I'm messing around with this for the first time. I have a picture on photobucket that I'm using as my portal island picture. I actually got it to show up on my website. Now... I want members to be able to click on the picture and have them directed to a specific website. Right now it just links them to the photobucket website showing my picture. Whats the best way to link to a specified website?
What would you do Ruben?

Re: Island banner insertion problem [Re: natcon] #248798
03/31/12 02:46 AM
03/31/12 02:46 AM
Joined: Jun 2006
Posts: 16,784
Portland, OR; USA
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 16,784
Portland, OR; USA
Code
<a href="http://thesite.tld/linkedpage.php" target="_blank"><img src="http://thesite.tld/image.ext" alt="name describing photo" /></a>


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
I want to update forum but can't find license
by dimaninc. 11/23/17 10:51 AM
Forum Statistics
Forums36
Topics35,014
Posts190,530
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)