Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
1 registered members (mmkk), 72 guests, and 412 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
whk
whk
Portsmouth, RI
Posts: 86
Joined: January 2009
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 14
FREAK 11
M4TT 8
mmkk 5
isaac 4
Ruben 3
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Some of the Permission Settings Not Working #255116
03/25/14 04:29 PM
03/25/14 04:29 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Some of the permission settings are not working under Forum Permissions.

I am unable to set any permission settings for Admin, Global Mod, Moderators, etc. for the last four permission types on the right hand side, namely:

Can post using HTML [+]
Edit post time limit [+]
Can move topics [+]
Edit any post [+]

Is this a bug of some sort?

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255117
03/25/14 05:56 PM
03/25/14 05:56 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I am on 7.5.8

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255118
03/25/14 06:15 PM
03/25/14 06:15 PM
Joined: Jun 2006
Posts: 16,784
Portland, OR; USA
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,784
Portland, OR; USA
There was an issue reported before when too many variables are passed that it'll simply just "drop" the additional ones... I'm not sure where the report was.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255119
03/25/14 06:41 PM
03/25/14 06:41 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I discovered this when trying to train a new moderator and discovered that she couldn't use her moderator functions in the forum that had been set up for that purpose.

I discovered the same problem with my test user account.

When I started playing with the moderator permissions, things got worse and even affected by Administrator functions for that training forum. I can't even edit my own posts or any other posts there.

The fact that some permissions stick and others don't tell me there is a bug somewhere.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255126
03/26/14 12:11 PM
03/26/14 12:11 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Is this, or is this not a bug that needs fixing?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255127
03/26/14 12:11 PM
03/26/14 12:11 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I am now afraid to update any of my present permissions,

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255128
03/26/14 12:12 PM
03/26/14 12:12 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Fortunately is was only a training forum that got messed up.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255129
03/26/14 01:30 PM
03/26/14 01:30 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
It might be a owner Group permission issue.
Just guessing.

When you ftp to your files you will see besides the file/folder permissions, A number for a owner/group.
That number should be the same for every file and folder you have.
If some are different you will need to contact your host.

I can't remember the exact symptoms I had but what happened was the host upgraded the server and some files were changed to a group I could not access so some scripts would not execute.

Other than that maybe you have a couple of corrupted files?????


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255132
03/26/14 04:52 PM
03/26/14 04:52 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Could some corrupted files explain why some of the permission changes actually get changed and why some don't???

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255133
03/26/14 04:56 PM
03/26/14 04:56 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
What are the specific files or file groups that I should upload again?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255134
03/26/14 04:59 PM
03/26/14 04:59 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Would it be the changeusergroups.php one?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255135
03/26/14 05:06 PM
03/26/14 05:06 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Oops! It is the one/s for changing permissions that I need to upload again, right?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255136
03/26/14 05:08 PM
03/26/14 05:08 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Possibly.
Other than a support ticket.

I can only suggest to start from scratch at this point.
You can re-upload a virgin copy of the same version following the upgrade docs for what files to upload.
But don't run the upgrade script.
Then go through the file/folder permissions to ensure they are correct,(Again for what the third time)
Also make sure you backup the config.inc.php file so it is not lost.

But all this could also be due to connection issues with the host.
Where you loose connection to the database and the scripts do not complete updating the tables.

This is a hard item to guess what is going on without getting into the nittygritty


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255137
03/26/14 05:26 PM
03/26/14 05:26 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Could I first do the ones dealing with group permission changes and see if that solves the problem with the group permission changes?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255138
03/26/14 05:31 PM
03/26/14 05:31 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Sure.
But it only takes a few moments more to upload all of them.
Then you don't need to keep track of what was done.
For me to upload the files as a upgrade takes a whopping 10 minutes.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255139
03/26/14 05:42 PM
03/26/14 05:42 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
By uploading all of them, do you mean to upload all of the files as if I were doing a complete upgrade from a previous version?

Anyway, I will upload all of the admin folder files first to see if that solves it.

If it doesn't then I will upload all the others, one folder at a time and keep a record of what I have uploaded.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255140
03/26/14 05:51 PM
03/26/14 05:51 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Using the upgrade Docs
Stopping at running the upgrade script:
Quote:
Download the latest version of UBB™ from the Member Area.

Extract the upgrade files, using a program like WinZip to unzip the distribution zip.

Use your UBB™ control panel to turn your board off.

Connect to your server using your FTP client. Navigate the client to your current UBB™ installation directory.

Upload all files and directories from the unzipped UBB™ directory to the UBB™ installation directory, except for the includes, styles, and cache_builders/custom directories. You will want to upload all of the .php files within the cache_builders directory, just make sure not to upload the custom directory or files within it. When upgrading to 7.57 you may need to upload the styles/admin.css and styles/common.css files individually.

Verify that permissions on any newly uploaded files are correct for your server platform. Please review the full installation instructions for a reminder on necessary permissions.


Also you can exclude the install folder since you will not be running install nor upgrade.
Just make sure you copy the same version you are using currently.

The only caveat is you have any mods to the code.
Then you need to edit the specific scripts.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255146
03/27/14 10:58 AM
03/27/14 10:58 AM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I discovered something interesting in that I have two different of the following in the languages/english/admin folder:

cpperms.php (7.5.8 version) and cp_perms.php (7.4.1 version).

Was there a filename change from 7.4.1 version to 7.5.8 version or whatever versions in between?

Could this be the problem?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255149
03/27/14 11:49 AM
03/27/14 11:49 AM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I renamed cp_perms.php to cp_perms.bak to see if that would resolve the problem, but it didn't.

I am now assuming that cpperms.php only deals with the Control Panel itself and not the group permissions?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255150
03/27/14 11:56 AM
03/27/14 11:56 AM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Will continue uploading the other folders, one folder at a time.

May also contact my host provider regarding this problem.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255153
03/27/14 04:36 PM
03/27/14 04:36 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I uploaded the files, however, that didn't resolve the problem.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255154
03/27/14 04:38 PM
03/27/14 04:38 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I also went and changed the permissions again, but still have the problem.

Re: Some of the Permission Settings Not Working [Re: Ruben] #255155
03/27/14 04:39 PM
03/27/14 04:39 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I don't see these owner/group numbers.

Perhaps I need to download the FTP you use and see if that shows the numbers.

Originally Posted by Ruben
It might be a owner Group permission issue.
Just guessing.

When you ftp to your files you will see besides the file/folder permissions, A number for a owner/group.
That number should be the same for every file and folder you have.
If some are different you will need to contact your host.

I can't remember the exact symptoms I had but what happened was the host upgraded the server and some files were changed to a group I could not access so some scripts would not execute.

Other than that maybe you have a couple of corrupted files?????

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255156
03/27/14 04:44 PM
03/27/14 04:44 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Well, Then I suggest to open a support ticket.

Also FYI.
In ubb CP you have a permission check menu item to see if any file/folders fail but it is not 100%.
They should all show OK.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255157
03/27/14 04:51 PM
03/27/14 04:51 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
They are all showing OK.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255158
03/27/14 04:53 PM
03/27/14 04:53 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
I uploaded the FTP you use and am now looking at the owner group permission numbers.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255159
03/27/14 04:54 PM
03/27/14 04:54 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Should those owner group numbers be a specific number or just all have the same number?
Originally Posted by Daryl Fawcett
I uploaded the FTP you use and am now looking at the owner group permission numbers.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255160
03/27/14 04:57 PM
03/27/14 04:57 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
The number is specific to your account with the host.
So yes the owner group number should typically be the same regardless if it is a file or folder.
You can select the header to sort so You can find any different ones easier.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255161
03/27/14 05:09 PM
03/27/14 05:09 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
All the owner/group numbers in all the folders for UBB threads are the same, however, there are a couple outside of those that are different.

Any problem with those different ones?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255162
03/27/14 05:19 PM
03/27/14 05:19 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Should the permissions in all the UBB folders be 777?

I ask, as the permissions in the main admin folder is 755 and the files inside are 644.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255163
03/27/14 05:20 PM
03/27/14 05:20 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
Well.
Right now we are concerned with UBB.

I have no idea what the other files are or what they are used for.
Or if your host has assigned multiple owner/groups to your account.

So back to:
Open a support ticket.

I don't know what else to tell you.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255164
03/27/14 05:24 PM
03/27/14 05:24 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
If I don't find any other way to resolve this, I will plan to open a support ticket on Monday.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255165
03/27/14 05:32 PM
03/27/14 05:32 PM
Joined: Dec 2003
Posts: 5,822
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,822
Lutz,FL
The only other item.
I can think of is your old ftp program.
Did it upload the scripts in ascii?
As per the manual for UBB.
Some files should be uploaded n ascii,Not all.
Filezilla will default to ascii for the proper files.

Since I don't know I can only guess.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255166
03/27/14 08:37 PM
03/27/14 08:37 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Here's something interesting:

I can set the "Can read topics" permissions using "Forum Permissions" for a particular forum, but can't do it using "Group Management" for that same forum, however, when it comes to setting the "Edit any post" permission for that same forum, I can't set it via "Forum Permissions" nor via "Group Management".

This seems to be more than a permissions problem.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255167
03/27/14 08:41 PM
03/27/14 08:41 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Until I tried to update those permissions, all the previous setting were OK, but when I successfully reset some of them, the other previously set ones all reverted to 0 (as in zero).

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255168
03/27/14 08:43 PM
03/27/14 08:43 PM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Could I have corrupted the files when I downloaded and unzipped them from the members area?

Perhaps I should do a new install in a test area and see if I still have the same problem there.

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255170
03/28/14 02:47 AM
03/28/14 02:47 AM
Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Mark S Offline
Mark S  Offline

Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Read this

https://www.ubbcentral.com/forums/ubbthreads.php/topics/254423/Guest_Permissions_update_:_Zer#Post254423

Could be related ?


Version v7.5.8
People who inspire me Gizmo ID242 SD
Its been a long road. . . .to be waiting
Re: Some of the Permission Settings Not Working [Re: Mark S] #255173
03/28/14 08:19 AM
03/28/14 08:19 AM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Related, but worse!

As I posted in that link, was your's ever resolved?
Originally Posted by Mark S
Read this

https://www.ubbcentral.com/forums/ubbthreads.php/topics/254423/Guest_Permissions_update_:_Zer#Post254423

Could be related ?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255174
03/28/14 08:21 AM
03/28/14 08:21 AM
Joined: Jun 2006
Posts: 591
Canada
Daryl Fawcett Offline OP
addict
Daryl Fawcett  Offline OP
addict
Joined: Jun 2006
Posts: 591
Canada
Could it be a table related problem?

If I rebuilt my tables. or the ones affecting permissions, could that resolve it?

Re: Some of the Permission Settings Not Working [Re: Daryl Fawcett] #255175
03/28/14 12:28 PM
03/28/14 12:28 PM
Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Mark S Offline
Mark S  Offline

Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
No it wasn't resolved i just didnt use that again.
I guessed that its not an option that I use very often.

My hope was that when I upgrade it would be resolved. But with 65 forums I didn't have the time to go and do them all individually again.

Would be interesting to understand the problem.

If memory servers me right it only happened as the Guest permissions. I've not had any problems as Admin.


Version v7.5.8
People who inspire me Gizmo ID242 SD
Its been a long road. . . .to be waiting
Page 1 of 2 1 2

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
I want to update forum but can't find license
by dimaninc. 11/23/17 10:51 AM
Thumbs Up/Rate Individual Posts
by M4TT. 11/22/17 01:11 PM
Forum Statistics
Forums36
Topics35,013
Posts190,528
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)