Previous Thread
Next Thread
Print Thread
Hop To
Forum Hanging on New Server #256042 11/06/2014 2:33 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
I have an odd problem which I'm guessing might be related to file permissions.

I own multiple UBB licenses. I recently had to move all my websites over to a brand new hosting facility with Windows Server 2012. I have two virtual servers. One server is working perfectly fine. UBB on there runs quick and easy.

The main BellaOnline forum is on a separate server here -

http://forums.bellaonline.com/

I have the MySQL slow query log turns on and nothing meaningful is showing up. But when I try to post it goes for the full 2 minutes I allow it and then times out. It can't be MySQL because it would show up in the slow query log. I have to guess it's file permissions. And indeed when I run the permission checker I get a variety of errors. But I checked and IUSR does have the rights it needs.

Is it not IUSR? That's what the documentation seems to say?

Lisa


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256043 11/06/2014 2:38 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
Hmmm actually I did the permission check on the other server and it's showing failures in the same places. Could it be the permission check routine doesn't handle Windows Server 2012 well? Is it looking for a different username or something?


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256044 11/06/2014 3:08 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
The failure is on this line -

function ubb_error_handler( $code, $error, $file, $line, $context = array() ) {

but I don't think that's actually the error of course.

The systems are writing the session files. But they aren't making any changes to the RSS files - I imagine that's where the error is.


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256045 11/06/2014 3:28 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
While we're at it, everything in templates/compile is dated from 2012. And there are over 12,000 files in there. Could that be right? Or is that another permissions issue?

Last edited by BellaOnline; 11/06/2014 4:41 AM.

Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256046 11/06/2014 4:30 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
Just to expand, after two minutes I get this:

PHP Fatal error: Maximum execution time of 120 seconds exceeded in C:\aWeb\bellaforums\libs\ubbthreads.inc.php on line 888

but there's nothing showing up in my UBB error log nor in a PHP error log. Which seems odd to me. And there's no entry in the MySQL slow query log for this. Other things do occasionally write to the slow query log so it's working.

The post does get made. The sidebar does get updated. But the RSS feed doesn't get updated. I'm trying to figure out how to step through the code to figure out where it's jamming. It's been a long while since I've had to be in the internals of the code like this.


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256047 11/06/2014 6:42 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
ARRRRRRRRGGGGGGGGGHHHHHHHHHHHHH

The SMTP entry had somehow gotten set to max connections of zero. And for some reason that SMTP service being unavailable caused the forums to continually hang!!

That code needs to be fixed smile.


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256048 11/06/2014 6:48 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
Note that while my forums are running again, I still need to know what to correctly set the file permissions to so my admin area shows everything is correct. Is it the IUSR account or something else?

I'm on Windows Server 2012.


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256056 11/06/2014 6:53 PM
Joined: Dec 2003
Posts: 5,990
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,990
I wish we had another active user like you that uses a Windows server.
I went to Linux years ago. So I am no help.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum Hanging on New Server [Re: BellaOnline] #256060 11/06/2014 8:45 PM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
I suppose if I go digging through the code on that test page it might tell me what it's using to test. Maybe it's coded with an old ISUR_XXXXXX format instead of the new IUSR format.

Lisa


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256069 11/10/2014 3:27 PM
Joined: Dec 2003
Posts: 5,990
Ruben Online Yawn
Online Yawn
Joined: Dec 2003
Posts: 5,990
I got my message today that you migrated to a new server.
Still Windows?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Forum Hanging on New Server [Re: BellaOnline] #256074 11/11/2014 6:39 AM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
Yes, this is now Windows 2012.


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256154 11/25/2014 10:01 PM
Joined: Jun 2006
Posts: 673
BellaOnline Offline OP
old hand
OP Offline
old hand
Joined: Jun 2006
Posts: 673
An update - the username used in Windows Server 2012 is "IUSR". So I'm just going line by line in the permissions check PHP and making sure each directory mentioned has permissions for ISUR as listed in the PHP. It'd be nice if this was documented a bit better - instead of just saying OK or FAIL that it listed the permissions looked for.


Lisa Shea, owner, BellaOnline.com
BellaOnline Website
BellaOnline Forums - UBB since Apr 2002 - 57,000 members / 800,000 posts
Re: Forum Hanging on New Server [Re: BellaOnline] #256155 11/26/2014 12:39 AM
Joined: Jun 2006
Posts: 15,845
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,845
Well, I think the check is just if the webserver responds it should be able to read/write to the appropriate directory.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Followed List v7.7.2 Question
by Ruben - 11/12/2019 12:22 PM
UBB Dev
by JAISP - 11/03/2019 11:01 AM
Exceeded Number of attachments
by rbrtgrmn - 11/02/2019 9:57 PM
Forum New User Registration
by kf6zpl - 10/25/2019 10:45 AM
Having issue with redirects to UBB classic URLs
by amciotola - 10/16/2019 12:11 AM
Who's Online Now
3 registered members (Ruben, Gizmo, isaac), 54 guests, and 417 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)