Previous Thread
Next Thread
Print Thread
Hop To
Unable to run the install/upgrade.php - fatal error #258068 02/21/2016 10:24 PM
Joined: Nov 2004
Posts: 173
luket Offline OP
enthusiast
OP Offline
enthusiast
Joined: Nov 2004
Posts: 173
I've copied the files as I always have, and when I run install/upgrade.php I get the following:

Fatal error: Call to undefined function: date_default_timezone_set() in C:\inetpub\vhosts\game-master.net\httpdocs\pit\libs\ubbthreads.inc.php on line 33

try it yourself: http://www.game-master.net/pit/install/upgrade.php

I'm upgrading Version: 7.5.7 to the latest version 7.5.9

please help.
I've never had a problem upgrading UBB in the many years I have been using it.


Member since November 2004
Gold Member since Feb 2008
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258069 02/21/2016 11:00 PM
Joined: Apr 2004
Posts: 1,549
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,549
As of UBB.threads 7.5.8, your server will need to be running at least PHP version 5.1.2+ (Released November 2005)

-- From PHP 5.1.2+; The "date_default_timezone_set" function started to validate the timezone parameter.
in PHP 5.1/5.2, you will get an error in the server logs if the setting is not set.

-- From PHP 5.3+; The "date_default_timezone_set" function throws an E_WARNING instead of E_STRICT.
In PHP 5.3, you will only get a warning if this variable is not set within your php.ini file.

The PHP function "date_default_timezone_set" is set within your server's php.ini file.

Most modern web servers are running at least PHP 5.3 (Released June 2009), with the most common version being either PHP 5.5 or PHP 5.6.
UBBCentral runs PHP v5.3
My UBB.threads sites are on PHP 5.6


Further reading on server requirements:
https://www.ubbwiki.com/article/view/27/server-requirements-and-suggestions.html
and
https://www.ubbwiki.com/archive/view/43/ubb-threads-v7-6-0-system-requirement-test-20151204.html


NOTE: UBB.threads 7.5.x does not support PHP v7


Current developer of UBB.threads PHP Forum Software // 7.7.3 released!
isaac @ id242.com // my forum @ CelicaHobby.com
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258070 02/21/2016 11:24 PM
Joined: Apr 2004
Posts: 1,549
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,549

WARNING: There may be other issues in running the current version of UBB.Threads on an outdated version of PHP

If you just wanted to get around the error and get your site back up & running right now:

in libs/ubbthreads.php
FIND
Code
date_default_timezone_set(@date_default_timezone_get());


REPLACE WITH:
Code
date_default_timezone_set("UTC");



If you know what state your server is located in, and you wanted to manually set it as such, you could replace UTC with that server timezone code. The common USA time zone codes are:
PST - Pacific Standard Time
MST - Mountain Standard Time
CST - Central Standard Time
EST - Eastern Standard Time

https://simple.wikipedia.org/wiki/List_of_U.S._states_by_time_zone


Lol, Ignore all that. UBB.Threads 7.5.8+ still needs the bare minimum of PHP 5.1 with the recommendation being at least PHP 5.3+

Last edited by id242; 02/21/2016 11:32 PM.

Current developer of UBB.threads PHP Forum Software // 7.7.3 released!
isaac @ id242.com // my forum @ CelicaHobby.com
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258071 02/22/2016 12:09 AM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
The UBBWiki entry "Server Requirements and Suggestions" has been updated; I'll have to put a couple of checks in the test script.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Unable to run the install/upgrade.php - fatal error [Re: Gizmo] #258072 02/22/2016 12:46 PM
Joined: Nov 2004
Posts: 173
luket Offline OP
enthusiast
OP Offline
enthusiast
Joined: Nov 2004
Posts: 173
Okay, thanks guys.

I went into Plesk and selected PHP 5.2.13 and now I get a login screen.
But I cannot login. It's the same user name/password I have been using for years.
It just takes my username / password, and reloads the screen - no error.


scratch that, tried another admin login and got in smile

Last edited by luket; 02/22/2016 12:58 PM.

Member since November 2004
Gold Member since Feb 2008
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258073 02/22/2016 12:58 PM
Joined: Apr 2004
Posts: 1,549
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,549
https://www.ubbcentral.com/forums/ub...n-issue-windows-10-using-edge#Post257474

also, if you cannot update to the current php 5.6, you should look in to upgrading to at least the minimum of php 5.3. for performance and security reasons.


Current developer of UBB.threads PHP Forum Software // 7.7.3 released!
isaac @ id242.com // my forum @ CelicaHobby.com
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258074 02/22/2016 1:01 PM
Joined: Nov 2004
Posts: 173
luket Offline OP
enthusiast
OP Offline
enthusiast
Joined: Nov 2004
Posts: 173
Okay, making progress, but now I get this error:

The following files are reporting a wrong version #
(Make sure you updated these files)
styles/admin.css
styles/common.css
styles/common.css
styles/admin.css


The installation instructions say not to replace these files, right?

How to fix?

Last edited by luket; 02/22/2016 1:02 PM.

Member since November 2004
Gold Member since Feb 2008
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258075 02/22/2016 1:42 PM
Joined: Apr 2004
Posts: 1,549
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,549
You have duplicated your lines. But yes, the two files do need to be the current versions.

styles/common.css
styles/admin.css

How to fix? Copy those two files from the "styles" directory of the installer package, to the "styles" directory of your forum.

Basically: Make sure you updated these files


Current developer of UBB.threads PHP Forum Software // 7.7.3 released!
isaac @ id242.com // my forum @ CelicaHobby.com
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258076 02/22/2016 1:44 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
ONLY upload those two files; NEVER overwrite the wrappers file.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Unable to run the install/upgrade.php - fatal error [Re: Gizmo] #258077 02/22/2016 1:57 PM
Joined: Nov 2004
Posts: 173
luket Offline OP
enthusiast
OP Offline
enthusiast
Joined: Nov 2004
Posts: 173
Okay,

All is well and we are back online.

Thanks guys for the help.


Member since November 2004
Gold Member since Feb 2008
Re: Unable to run the install/upgrade.php - fatal error [Re: luket] #258078 02/22/2016 2:23 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
Also, be sure that you remove the install/ directory after you've completed your upgrade.

Additionally, PHP5.6 has better performance than earlier builds of PHP5, if you have the option.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Unable to run the install/upgrade.php - fatal error [Re: Gizmo] #258079 02/22/2016 5:15 PM
Joined: Nov 2004
Posts: 173
luket Offline OP
enthusiast
OP Offline
enthusiast
Joined: Nov 2004
Posts: 173
got it thanks smile


Member since November 2004
Gold Member since Feb 2008

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Mobile app?
by Baldeagle - 12/06/2019 9:32 PM
How do you change Text Line spacing?
by jorb - 11/23/2019 12:14 AM
What happened to FAQ or Forum Help
by Ruben - 11/20/2019 11:58 AM
Search feature encountering an Error message
by jorb - 11/20/2019 12:06 AM
Followed List v7.7.2 Question
by Ruben - 11/12/2019 12:22 PM
Who's Online Now
1 registered members (Gizmo), 70 guests, and 351 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)