Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
2 registered members (JAISP, M4TT), 58 guests, and 254 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 82
Joined: September 2008
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 15
FREAK 11
M4TT 11
Ruben 5
mmkk 5
isaac 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Mark All Read #260543
10/04/17 04:28 PM
10/04/17 04:28 PM
Joined: Jun 2016
Posts: 5
G
greiffster Offline OP
stranger
greiffster  Offline OP
stranger
G
Joined: Jun 2016
Posts: 5
So we just updated our site http://bmwsporttouring.com to 7.6.0 and are having trouble with a dead "Mark All Read" button. I did a search and it appears that there was an update to the template file markallread.tpl. We have this update and the code looks correct, but we are still having the issue. Thoughts?
-mike

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Mark All Read [Re: greiffster] #260544
10/04/17 05:01 PM
10/04/17 05:01 PM
Joined: Jun 2006
Posts: 16,785
Portland, OR; USA
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,785
Portland, OR; USA
When attempting to browse your Mark All Read page, it comes up completely blank; which wouldn't have been an issue with the patched or unpatched markallread bug you're mentioning. The bug was that users in IE couldn't mark their posts as read, but the page still loaded.

The updated file in the main install archive after Feb 23rd (or p2) should work; all that was added was adding a missing
Code
 type="input"


Firefox and Chrome didn't care about this behavior change, but was added for IE users who where having problems.



I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Mark All Read [Re: greiffster] #260545
10/04/17 05:27 PM
10/04/17 05:27 PM
Joined: Jun 2016
Posts: 5
G
greiffster Offline OP
stranger
greiffster  Offline OP
stranger
G
Joined: Jun 2016
Posts: 5
Thanks for the input. Yup, completely blank. I'll keep digging.

Re: Mark All Read [Re: greiffster] #260546
10/04/17 05:33 PM
10/04/17 05:33 PM
Joined: Jun 2006
Posts: 16,785
Portland, OR; USA
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,785
Portland, OR; USA
I'd try reuploading the following files from the install archive (generally I always re download the archive from Central):
languages/english/markallread.php
scripts/markallread.inc.php
templates/default/markallread.tpl

Then clear the cache from the Control Panel; with any luck it's just a messed up cache file.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Mark All Read [Re: Gizmo] #260578
10/15/17 07:34 PM
10/15/17 07:34 PM
Joined: Sep 2008
Posts: 82
Utah
bakerzdosen Offline
journeyman
bakerzdosen  Offline
journeyman
Joined: Sep 2008
Posts: 82
Utah
Originally Posted by Gizmo
I'd try reuploading the following files from the install archive (generally I always re download the archive from Central):
languages/english/markallread.php
scripts/markallread.inc.php
templates/default/markallread.tpl

Then clear the cache from the Control Panel; with any luck it's just a messed up cache file.

Installed the p2 patch (which included new markallread files), cleared the cache, and still get the same results (unless I need to wait a significant period of time after clearing the cache...)

Ideas?

*NOTE* see final reply below. Apparently it's good that I showed permissions on the files because the dates made me suspicious.

Last edited by bakerzdosen; 10/15/17 07:45 PM.
Re: Mark All Read [Re: bakerzdosen] #260579
10/15/17 07:38 PM
10/15/17 07:38 PM
Joined: Sep 2008
Posts: 82
Utah
bakerzdosen Offline
journeyman
bakerzdosen  Offline
journeyman
Joined: Sep 2008
Posts: 82
Utah
If it matters:

Code
[root@www english]# ll markall*
-rw-rw-rw- 1 root root 428 Sep 29 19:40 markallread.php
[root@www english]# ll ../../scripts/markall*
-rwxr-xr-x 1 root root 1069 Sep 29 19:21 ../../scripts/markallread.inc.php
[root@www english]# ll ../../templates/default/markall*
-rw-rw-rw- 1 root root 354 Feb 23  2017 ../../templates/default/markallread.tpl
[root@www english]# 

Re: Mark All Read [Re: greiffster] #260580
10/15/17 07:44 PM
10/15/17 07:44 PM
Joined: Sep 2008
Posts: 82
Utah
bakerzdosen Offline
journeyman
bakerzdosen  Offline
journeyman
Joined: Sep 2008
Posts: 82
Utah
WAIT.

I maybe lied.

I *thought* that patch included new files for all three, but it didn't.

I think it's working now. Ugh. Sorry for the false alarm. I'll let you know if it didn't.


Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,534
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)