Previous Thread
Next Thread
Print Thread
Hop To
Load issue bug? or not [Not a Bug] #261403 04/29/2018 6:56 AM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
If this is the wrong forum then please move it.

My website has server load issues. it causes the email not to work or arrive.
The host Interserver say that the load issues is due to

Quote
You are facing this issue due to server load. Please refer the below log:
..........................
2018-04-29 09:38:44 1fCim6-0005Tw-Aa no immediate delivery: load average 21.73
..........................
On checking I could see high POST requests to the domain page http://www.britbike.com/xxxxx/ubbthreads.php

Refer the below log:
.................
192.0.174.12 - - [29/Apr/2018:09:57:11 +0000] "POST /xxxxx/ubbthreads.php HTTP/1.1" 200 109 "http://www.britbike.com/xxxxx/ubbthreads.php?ubb=showflat&Number=74412" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0"

They go on and give about 20 forum examples and ask Is it valid requests ?

I replied:
Quote
It looks like ok to me, its normal forum visits which we have had since 1998,
Interserver has been our host since 2013.
The only thing I can think of if its to many visits from spiders and not real visitors.
How would this affect the incoming emails? This is a new issue for us I have never had this problem before at least not to my knowledge.


I then went to forum CP and disabled

For your info I have now changed the settings in our forum CP

Quote
I have disabled:
Enable Spider-friendly URLs
Warning: This function allows most search engine spiders to crawl the community and also allows for specially formatted URLs, which may result in higher bandwidth usage and server load.
Note: The PATH_INFO environmental variable must be available for this feature to function properly.

Also I have disabled:
Enable Debuging
FORUM: Page generation times, number of queries, memory stats, compression, forum server time, and forum software build information is displayed on the page footer. HTML Page minification is also disabled while debugging is enabled.
CONTROL PANEL: File Attachments stats are generated on the dashboard. Sites with a large number of file attachments may experience a delay in producing the page.


Interserver replied with:
Quote
I recommend we try: https://github.com/engintron/engintron

Its nginx for cpanel, there is no extra cost.
The issue is re-occuring, and I have enabled just about everything that would cover: bad bots, slow php, slow mysql.
So we need to find a way to lower the load, in a different way. I think the issue may be scale of the script. Not that I am recommend a change, but it could very well be, the db's are getting bigger causing more load.
UBB was big many years ago, replaced by VB forums which then has really been replaced by Xenforo. I remember people moved from UBB -> VB because of scale issues. Not sure if that is still an issue but if anything can cut the load down it would be nginx.
John Quaglieri
InterServer, Inc


Please advise is there a way for me to reduce the load or do you see anything unusual here?


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261404 04/29/2018 1:29 PM
Joined: Dec 2003
Posts: 5,998
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,998
Well at first glance it appears that you have a popular site and you are just exceeding your limits..
Especially if it is a shared hosting account.
There are hundreds of posts that a unlimited shared account is vaporware.
It truly is not.
They limit it someplace, emails,bandwidth ,resources.
Even if the specs say unlimited if you read the fine print it is really not.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261405 04/29/2018 1:51 PM
Joined: Dec 2003
Posts: 5,998
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,998
All of what you did probably did not help much with your plan.
I think you already turned off indexed unread posts.
The next step would be to turn off the absurd amount of animated banners you have.
I would not turn of the logging of errors at all.
Unless you want to hunt them down with no clue what they are.

Of course the last step is upgrade your plan.
But that costs money.

Last edited by Ruben; 04/29/2018 1:57 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261406 04/29/2018 2:20 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
Eventually we all outgrow our hosted machines; from Shared Hosting to a VPS, from a VPS to a Dedicated machine, and some people even move over to cloud dedicated or multiple servers with one hosting MySQL and the other hosting their site.

I accessed two of my larger client machines for the following data:
A: Octa Core Xeon(R) CPU E3-1271 v3 @ 3.60GHz w/16GB Ram
top - 11:59:09 up 43 days, 6:09, 1 user, load average: 0.59, 0.27, 0.20
19112 Members, 66752 Posts, 469141 Posts
Not on a CDN. UBB.threads v7.5.9

B: Octa Core Xeon(R) CPU E3-1230 v3 @ 3.30GHz w/32GB Ram
top - 19:57:07 up 178 days, 13:26, 1 user, load average: 0.19, 0.26, 0.30
10802 members, 73746 topics, 1070628 Posts
On a CDN. UBB.threads v7.6.0

UBB.threads flies on both of these servers, and neither user has an issue with sending email messages. If you're having difficulties with sending emails it is likely a server issue; you have a significantly large forum, you could need more resources, your forum will have a HUGE impact on server resources.

UBB.threads is a community based platform coded in PHP with a MySQL backend; we assume that your server has been tuned for a large PHP script, some users use different web servers (such as NGIX or others fine tune Apache2), and some users will continuously have their MySQL server tuned based; but eventually people upgrade their server, it's just the price of business. I wouldn't expect you to be hosting your site on a 486 like I did at one point in time, the resources just aren't there for the traffic.

I would highly advise that you turn Spider Friendly URLs back on, it will NOT impact your system resources, but it WILL impact any SEO/Search Engine traffic.

Honestly though, your EMail issues seem like you're hitting some sort of email send limits; what kind of hosting are you on? What are your hard limits? If you have an "unlimited" plan, what are your "within reason" limits?


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261407 04/30/2018 6:20 AM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
Thank for your replies

Gizmo I have now enabled the spider Friendly URLs back on.

as far as popularity it has been more popular in the past with more traffic. (my guess 98.5% traffic is for the forum)
It used to be 10-20% more traffic from users. I have increased from 3 VPS slices and one core to
VPS with 5 slices, CPU 2Cores, Memory= 5120MB, CPU Storage 125GB, CPU Transfer 5TB.

Awstats say for April 1-29
Reported period Month Apr 2018
First visit 01 Apr 2018 - 00:00
Last visit 29 Apr 2018 - 06:02

Viewed traffic *
50,398 Unique visitors, 107,050Visits (2.12 visits/visitor), 4,141,393 Pages (38.68 Pages/Visit), 7,662,507 Hits (71.57 Hits/Visit), 89.76 GB Bandwidth (879.2 KB/Visit)

Not viewed traffic *..........................8,926,222pages ......................9,141,018Hits...........789.20 GBbandwidth

The reason I post this thread here is that Interserver mentioned the forum which I posted in the first post.
My email problems is that all incoming and probably outgoing emails get stuck. not only the ones from the forum AND Interserver say it may be the forum that causes the initial problems for the whole site/domain.

Ruben, Yes I have banners on the about half are a bit animated but they are about 20kb ea and static. there are two rotating banners which has been there for 20 years now.
These problems are new for this year so I'm fishing for ideas what could cause server loads. If its not the UBB then I'll close this thread.
I will contact interserver to look at your answer gizmo.


Last edited by Morgan; 04/30/2018 6:28 AM.

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261408 04/30/2018 2:29 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
Originally Posted by Morgan
I have increased from 3 VPS slices and one core to
VPS with 5 slices, CPU 2Cores, Memory= 5120MB, CPU Storage 125GB, CPU Transfer 5TB.

So, you were effectively running a huge site on 3gb ram and 3 cores? I've been running all of my production sites on a 4gb/4 core VPS and I'm having resource issues at peak times (so I added a CDN).

It really wouldn't matter what software packages or forum software you're running, when you have enough users (including Guests and Spiders) making enough requests (accessing pages, writing data to the database, etc), it's going to chew through resources.

Honestly, I'd expect a site of your size to be utilizing something akin to the servers I shared above... No wonder your host is saying it's UBB.threads, because you don't have the resources available to run a popular community on a tiny VPS account. As a VPS user myself, I'd expect if your site was on one that you'd be utilizing something with at least 6-8gb ram that had been tuned accordingly.

I hope it's an OpenVz VPS vs kvm; OpenVz, in my experience, is much more friendly with system resources.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261409 04/30/2018 5:10 PM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
Gizmo, I am a novice at this, had problems some years back on a shared site and asked for advice, you pointed me to Interserver and to get me a VPS account so I did.
Started at 3 slices and one core and increased to 4 and then now to 5 and two cores.
It looks like I need more then and I'll somehow figure out what I need to upgrade to.

IS now says
Quote
Nginx is on now. Check the speeds and site now.
Load is down. I can browse around the forums.
John Quaglieri
InterServer, Inc


He say that he can browse around but thats not the issue as I don't find it difficult to browse around but I keep getting the load issue emails.
I will have some sleep now its past midnight and will see what tomorrow brings.
Thanks for the input so far I'm all ears as I need to get this fixed.

Cheers


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261410 04/30/2018 9:55 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
I haven't used Interserver in some time; but, at StableHost (affiliate link), my price is a little more per "slice", but each level is an additional CPU core. So for my $29.95/mo 4 GB/ram 4 core VPS at SH, Interserver's equivalent would only get you 2 cpu cores, but 5 gb ram (it's been a while since I made the comparison, it seems like they were more in line a while back).

As times go on we find ourselves needing more resources, on a VPS or a Cloud Host we can scale up relatively easily (note that cloud products have their own caveats), but for purchased dedicated machines people end up having to invest quite a bit more.

I'm happy to help, but unfortunately server configurations are really out of the scope of the support forums for a web script... I've seen similar sites fly with similar resources (~6gb ram, multi-core), the only thing I could suggest is that you monitor your mail logs on the server and see if anything is out of the ordinary.

UBB.threads is a web script that runs on your web server, it'll use whatever resources it needs to run on your server; a busy site with lots of content will use a significant amount of resources. If these resources aren't available one will generally need to upgrade their system resources and tune the server accordingly (such as configuring a new web server, like your host has done).

It seems that your host is trying to show you that the identified heavy system resource hog is the web server, which is running UBB.threads, and they're trying to identify ways to bring resource usage down (which I doubt they're going to be able to do, since it sounds like you need more resources to tame the web server usage).


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261411 05/01/2018 5:48 AM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
Thanks for taking time to explain, when Interserver said they didn't think more resources would fix it I definitely thought maybe there something with UBBThreads, reading your input with your experience gives me doubts that
they will fix it only by adding nginx for cpanel at this point.
Maybe I need to spend a bit more but to get one more core I need to go up to 9 slices which is almost double cost.

Since this is no bug then you may move it to correct forum.
Thanks again


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261412 05/01/2018 10:37 AM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
Gizmo, more info.
John at IS just told me below

Quote
stat("/home/britbike/public_html/forums/sessions/sess_6fe7js6251n7bt4ac47etb2s24", {st_mode=S_IFREG|0600, st_size=133, ...}) = 0

Lots of files in this folder, caused lots of stat calls in linux, which is turn was causing high cpu on httpd processes.
I mounted sessions as a memory file system now.
John Quaglieri
InterServer, Inc


I noticed 19239 session files generated last 60 minutes in the sessions folder.
what creates a session file is it real traffic by members or could it also be spiders and machines creating this traffic?

Last edited by Morgan; 05/01/2018 10:55 AM.

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261413 05/01/2018 11:14 AM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
ooops the website is down and the forum. it reads

Quote
The whole website seems to be down.
on www.britbike,com I get this error message
500 Internal Server Error
nginx


on the forum page
http://www.britbike.com/forums/ubbthreads.php/
I get this message

Forbidden

You don't have permission to access /forums/ubbthreads.php/ on this server.
Server unable to read htaccess file, denying access to be safe

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


I wonder if its the new nginx that is scrwing it up?


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261414 05/01/2018 11:44 AM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
Sessions are created when the forum is accessed, they are held onto until the server purges "trash data"; again, a hugely popular forum will use more resources, and create more sessions to account for the users and spiders who are accessing it.

Your host can configure how long sessions "live" via the php configuration on the server:
http://php.net/manual/en/session.configuration.php.

There you'll find these variables:
session.gc_probability
session.gc_divisor
session.gc_maxlifetime

As for the webserver error, consult your system logs.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261415 05/01/2018 12:07 PM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
I will look into the sessions settings.
what are your recommendations how to set them?

site is down again second time now and I'm consulting the host.
Cheers


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261416 05/01/2018 12:12 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
I have no opinion on the matter, the defaults work fine for me.

Each season accounts for a unique user accessing your site that day.

I was including the information based on their comment about the large amount of sessions; which should only be retained for 24 hours (by default PHP garbage collection settings).

-- Edit --
Isaac just mentioned that he thinks the purging of sessions is controlled with the who's online duration in UBB.threads.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261417 05/01/2018 12:27 PM
Joined: Dec 2003
Posts: 5,998
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,998
FYI,
People in the past have had issues with session files not self deleting.
You could just ftp to that folder and delete them. Only the session files.
All that will happen is members that are currently on line will get logged off.
Including you.
So you could close the board and then delete them then open it again.
At least your members will have a explanation why they got bumped off.

I hope you don't have persistent connections enabled!
That will cause you grief..

Last edited by Ruben; 05/01/2018 12:30 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261418 05/01/2018 1:28 PM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
Ruben I did as you said closed and delete the session files it was 23300+ files. it will take some time with filezilla to delete.

Interserver asked me this question
Quote
Does ubb have a cron to auto remove the session files?


what is the answer? all I know is that it normally is one hour of session files in the session folder


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261419 05/01/2018 1:39 PM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
Gizmo
...................................localvalue...............master value
session.gc_divisor..... ......0...............0
session.gc_maxlifetime 3600...............1440
session.gc_probability......1...............0


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261420 05/01/2018 1:41 PM
Joined: Jun 2006
Posts: 15,852
Gizmo Online Tapedshut
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,852
No, we don't have a cron file. If they think your sessions folder is large, have them look at your attachments folder.

Again, there are sites larger than yours that handle things just fine on their own. This script runs your entire site, it's not just some "its only accessed rarely" script, its constantly hit with active traffic.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Load issue bug? or not [Not a Bug] [Re: Morgan] #261421 05/01/2018 2:15 PM
Joined: Jun 2006
Posts: 683
Morgan Offline OP
Addict
OP Offline
Addict
Joined: Jun 2006
Posts: 683
they have added a cron now


They installed tmpwatch and do something in cron

tmpwatch -c 24 -v /xxxxx/xxxxxx/public_html/xxxxxx/xxxxxxx


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Mobile app?
by Baldeagle - 12/06/2019 9:32 PM
How do you change Text Line spacing?
by jorb - 11/23/2019 12:14 AM
What happened to FAQ or Forum Help
by Ruben - 11/20/2019 11:58 AM
Search feature encountering an Error message
by jorb - 11/20/2019 12:06 AM
Followed List v7.7.2 Question
by Ruben - 11/12/2019 12:22 PM
Who's Online Now
1 registered members (Gizmo), 62 guests, and 418 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)