Site Links
Home
Features
Pricing & Order
Documentation
Support Options
Member Area
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 59 guests, and 212 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 458
Joined: August 2004
Show All Member Profiles 
Top Posters(30 Days)
isaac 25
Gizmo 18
Ruben 10
driv 9
Conrad 3
JAISP 2
Morgan 2
Latest Photos
Trees
Retreats
Rooms
Big stuff
Test
Previous Thread
Next Thread
Print Thread
random 500 server errors on post #261515 05/31/18 09:34 AM
Joined: May 2008
Posts: 735
Bad Frog Offline OP
old hand
OP Offline
old hand
Joined: May 2008
Posts: 735
for the past month, my users have been getting completely random internal server errors when posting/replying.
and I mean random.. someone will have it happen with every post in a certain topic, but it won't happen to any else, then suddenly, they don't get the error.
one day I can post to a topic, it works, I'll post a again later, it doesn't work

there is no rhyme or reason, no pattern.

all I see in the error logs is AH01215: [vanning.com/www/threads] Program mode requires special privileges, e.g., root or TrustedUser

the admin is saying it's the software (UBB), however I had made no changes in a very long time when this had started to happen.

using version 7.6.1.1
PHP Version 5.5.9-2ubuntu4.22a


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Express Hosting
Re: random 500 server errors on post [Re: Bad Frog] #261516 05/31/18 01:05 PM
Joined: Dec 2003
Posts: 5,881
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,881
A 500 error is a generic error code.
Server logs if accessible would be more specific.
If absolutly nothing has changed on your site.
Meaning modifications to the script,changes in the ubb console.
then I would suspect the host provider has changed something like upgrading apache , php , etc ad possibly some settings are now incorrect.
You have the current version I would start with the landing page of ubb cp.
See if it reports any issues to address.
The scroll down to the bottom and check permission checks.
to see if you have any failed file/folder permissions.

Other than that contact your host to resolve your issue, They can provide more specific error info.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: random 500 server errors on post [Re: Bad Frog] #261517 05/31/18 01:15 PM
Joined: May 2008
Posts: 735
Bad Frog Offline OP
old hand
OP Offline
old hand
Joined: May 2008
Posts: 735
As I said Above, This is the error that coincides in the logs with the internal server error when people hit post or reply

AH01215: [vanning.com/www/threads] Program mode requires special privileges, e.g., root or TrustedUser


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Re: random 500 server errors on post [Re: Bad Frog] #261519 05/31/18 01:19 PM
Joined: May 2008
Posts: 735
Bad Frog Offline OP
old hand
OP Offline
old hand
Joined: May 2008
Posts: 735
The only change I had made at about the time that this started happening was updating my Google AdSense code. I completely deleted out all of that updated code and it made no difference the error still happened


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Re: random 500 server errors on post [Re: Bad Frog] #261520 05/31/18 02:27 PM
Joined: Jun 2006
Posts: 15,827
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,827
AH01215 means that there has been a suexec policy violation; the log for such issues would be /var/log/apache2/suexec.log for the Apache webserver on Ubuntu.

Likely there is some security policy that is blocking new post creations based on a keyword (such as what mod_security would throw).


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: random 500 server errors on post [Re: Gizmo] #261521 05/31/18 02:39 PM
Joined: Dec 2003
Posts: 5,881
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,881
Originally Posted by Gizmo
AH01215 means that there has been a suexec policy violation; the log for such issues would be /var/log/apache2/suexec.log for the Apache webserver on Ubuntu.

Likely there is some security policy that is blocking new post creations based on a keyword (such as what mod_security would throw).


There you go Bad Frog.

Probably your host instituted suexec.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: random 500 server errors on post [Re: Bad Frog] #261522 05/31/18 02:41 PM
Joined: May 2008
Posts: 735
Bad Frog Offline OP
old hand
OP Offline
old hand
Joined: May 2008
Posts: 735
I passed that along to them, they claim they haven't changed anything either, but who knows.


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Re: random 500 server errors on post [Re: Bad Frog] #261523 05/31/18 02:44 PM
Joined: Jun 2006
Posts: 15,827
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,827
Well, without seeing the log, all we can do is speculate. But the error that you provided from your apache error log points towards a server issue.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: random 500 server errors on post [Re: Bad Frog] #261563 07/02/18 02:06 PM
Joined: May 2008
Posts: 735
Bad Frog Offline OP
old hand
OP Offline
old hand
Joined: May 2008
Posts: 735
I'm still getting these errors, the host keeps saying they are making adjustments, but keep leaning to something being wrong with my site/software (I had made no changes at all before this started happening)

Code
[Mon Jul 02 00:01:51.241256 2018] [cgi:error] [client 73.188.237.64] AH01215: [vanning.com/www/threads] Program mode requires special privileges, e.g., root or TrustedUser., referer: https://www.google.com/


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Re: random 500 server errors on post [Re: Bad Frog] #261564 07/02/18 02:33 PM
Joined: Jun 2006
Posts: 15,827
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,827
HTTP 400 errors mean there is something wrong with a script, general HTTP 500 errors indicate an issue with the server.

Quoting WestHost:
Quote
The 500 Internal Server Error is a very general HTTP status code that means something has gone wrong on the web site's server but the server could not be more specific on what the exact problem is.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

ShoutChat Box
Today's Birthdays
No Birthdays
Recent Topics
7.7.1 forgotten? //$reply = "off";
by BlackMale - 05/13/19 07:25 PM
[FIXED for 7.7.2] 7.7.1 /admin/edit_subscrip
tion.php

by BlackMale - 05/11/19 08:35 AM
http issues
by justwilliams - 05/10/19 09:20 AM
Open div
by AllenAyres - 05/09/19 01:17 PM
Forum Statistics
Forums35
Topics35,292
Posts192,448
Members12,166
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.7.2
(Snapshot build 20190501)