Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 52 guests, and 109 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Mark J.Cairns
Mark J.Cairns
Northern Ireland, UK
Posts: 38
Joined: September 2009
Show All Member Profiles 
Top Posters(30 Days)
isaac 19
Ruben 10
Gizmo 8
Geoff 3
Slaz 2
FREAK 2
DennyP 1
Latest Photos
Testing to drag photos
Comfortable Cats
Test
BSA photos
Chinese Buddhist temple.
Previous Thread
Next Thread
Print Thread
7.6.1.1 - Broken ReCaptcha (Not A Bug) #261555
07/01/18 06:02 PM
07/01/18 06:02 PM
M4TT  Offline OP
journeyman
Joined: Mar 2015
Posts: 57
Canada, SK
Hi there,

A few days ago, our Google ReCaptcha feature has stopped appearing for our guests. I've checked the keys and they're fine. No indication that ReCaptcha had undergone an update or maintenance. I've tried switching to other styles, but it didn't fix the issue. We're using ImageMagick, I've tried switching to GD2, issue persists.

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: M4TT] #261556
07/01/18 07:06 PM
07/01/18 07:06 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
ReCaptcha is currently working here at UBBCentral, on the New User page; I attempted to test this at your site, but it appears that you've disabled it. I am not seeing any outages listed at:
http://www.isitdownrightnow.com/recaptcha.net.html
http://downdetector.com/status/google
http://www.websitedownup.com/recaptcha.net

As for the built in libraries, as long as the captcha image displays in the Control Panel selection, it should display for your users (as it utilizes the same coding).

Make sure that your users aren't blocking Javascript, or see if they're using a security plugin that'd block 3rd party (offsite) scripts.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: Gizmo] #261557
07/01/18 07:39 PM
07/01/18 07:39 PM
M4TT  Offline OP
journeyman
Joined: Mar 2015
Posts: 57
Canada, SK
Originally Posted by Gizmo
I attempted to test this at your site, but it appears that you've disabled it.


It's enabled under Guest user group and under Display > General > Captcha Settings.

There were a couple spam bots that got by the captcha when it was working, but I haven't changed anything with it as far as I know...

There are 18 errors on the front page though using Chrome Developer Mode, but don't really see any regarding ReCaptcha...

Last edited by M4TT; 07/01/18 07:43 PM.
Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: M4TT] #261558
07/01/18 07:44 PM
07/01/18 07:44 PM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
I'm not seeing any header on your New User page for any of the captcha options. Regardless of the option you select, there should be a section for " CAPTCHA Verification"

As for "bots getting in", a good chunk of spammers aren't automated bots, they're humans who're being paid pennies for posts, so there is always the chance of spam. If the spammer is human, and they are on good IP addresses, then there is not much that can be done to determine if their posted content is spam or useful; which is why we keep moderators around.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: M4TT] #261559
07/01/18 09:13 PM
07/01/18 09:13 PM
M4TT  Offline OP
journeyman
Joined: Mar 2015
Posts: 57
Canada, SK
That's so odd!

I attempted to post as a guest, but it came up with an error:

Message

CAPTCHA Verification incorrect or missing. Please try again.

I've turned on registration verification too, to no avail.

I wonder what happened to the code? Maybe I should restore some original files if they've somehow been altered?

Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: M4TT] #261560
07/02/18 01:32 AM
07/02/18 01:32 AM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
Please remove everything from your HTML includes (or any manually injected coding) and try it again, I see this which may be screwing with the code loading:
Code
<link rel="icon" type="image/x-icon" href="/home/aliendisc/public_html/favicon.ico> <script src='https://www.google.com/recaptcha/api.js'></script><script src="https://www.google.com/recaptcha/api.js"></script>


Its possible that the bad HTML (you're not closing an open quote) is causing issues with following code. Not to mention, your users and bots aren't loading your favicon, because you're linking the local filesystem path vs a web accessible path.

Also make sure that your Secret Key and Site Key are the CORRECT codes, and are not transposed.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: Gizmo] #261561
07/02/18 01:41 AM
07/02/18 01:41 AM
M4TT  Offline OP
journeyman
Joined: Mar 2015
Posts: 57
Canada, SK
You're right Gizmo! It was bad HTML... The CAPTCHA works now... Thank you for your help!!

Re: 7.6.1.1 - Broken ReCaptcha (Not A Bug) [Re: M4TT] #261562
07/02/18 01:43 AM
07/02/18 01:43 AM
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,956
Portland, OR; USA
Be careful with manually updating coding; we work hard to make sure everything loads in a completely stock (unmodified) environment, and can only support stock files (we cannot support your modifications, not our monkeys, not our zoo).

Also, when submitting a bug report, please turn off the code minification option in the control panel (or turn debugging on, which will disable minification as well), so we can read the HTML coding.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
UBB.threads 7.6.2 - Released
by isaac. 09/17/18 08:08 AM
7.6.2 Changelog Discussion
by isaac. 09/17/18 06:35 AM
Upgrade Documentation
by DennyP. 09/15/18 03:55 PM
PHP 7.2
by Geoff. 09/12/18 10:22 PM
Email Cleanup-Is it possible?
by Ruben. 09/06/18 11:25 AM
Forum Statistics
Forums36
Topics35,139
Posts191,437
Members12,106
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2