Previous Thread
Next Thread
Print Thread
Hop To
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
I use 7.7.4

http://www.britbike.com/forums

Files has been corrupted.

I closed the forum when the trouble began.
I updated the Control Panel > General > HTML Includes header form and submitted
then it stalled and after that I had lost all data in all the forms..
Header Insert For All Pages
Header Insert When Not Displaying a Topic
Default Header
Default Footer

I can see above to the left.. You have not set a title for the community. > Control Panel > General ..
Default Time Format tab the forms are empty
Available Time Formats tab the form is empty
HTML Includes tabs all forms are empty

includes/footer.php - file 0 kb file
header.php - file 0 kb file
privacy.php - file 0 kb file
header-insert.php - file 0 kb file
header-insert-descrip.php - file 0 kb file
community_intro.php



Homepage Name is missing
Homepage URL is missing
Who's Online Settings > Robots (Crawlers) is missing
Social/Sharing Settings > everyithing is missing in the forms
Post Likes Settings > everyithing is missing in the forms
New Post/Reply Page Settings > everyithing is missing in the forms
Topic & Post Page Settings > everyithing is missing in the forms
Default Topics Per Page > everyithing is missing in the forms

Top posters numbers are gone in the portal

config.inc.php seems to have lost about 500 bytes and it seem that config-bak.inc.php was updated the same second that I hit submit.
perhaps the system created a config.inc.php backup there... hmm...



Please advise how I can address this issue!!!
Thanks in advance

Last edited by Morgan; 07/27/2020 3:50 PM. Reason: added info

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
I can see in the logs general_settings that SITE_EMAIL changed from 'forum@britbike.com' to 'morgan@britbike.com'
SUBJECT_LENGTH changed from '50' to '10'
TIME_FORMATS changed from 'Array' to 'Array'
This must have happened in the process when it went south


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
I have found incremental backup files in my hosts WHM CP.
Don't wish to restote the whole site. only the affected files if possible.

Can I do something within the forum CP in order to reset the empty files ??? I can't be certain to know all the files that got corrupt..
Do you think this has affected the includes/ files only?

Last edited by Morgan; 07/27/2020 3:31 PM.

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
Since you do not have a clue.
No.
Depends on how bad it is and how old your backups may be.
The longer you wait the worse it gets.
I have no idea what is corrupted.
Neither do you it appears.
You have the board closed currently.
I would start with a current backup and reload the files first.
Starting with the includes folder
Keeping the forum closed.
Keep checking the site.
It will be closed but open to admin.
Then you may need to pick and choose older backups to find like includes files that are populated as well as attachments,avatars, etc.
That at least have some content.
The forum should popup after.
If posts seem off then maybe try uploading a db backup.

WOW, bad news.

Did the host change something like apache versions or such?

I am not a admin so all I can see is what a normal user sees , which is the board is closed.

Last edited by Ruben; 07/27/2020 3:49 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
Ruben thanks for your reply

see this info
config.inc.php seems to have lost about 500 bytes and it seem that config-bak.inc.php was updated the same second that I hit submit.
perhaps the system created a config.inc.php backup there... hmm...
I wonder if there is a way to replace the config file using the forum CP or maybe one should do it manually???

Last edited by Morgan; 07/27/2020 3:53 PM.

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
There is no way to replace files in the UBB cp other that going over every screen and re-saving them.
Yes UBB now makes a backup of config.inc.php.
So you could rename it.
But if you have no confidence in that file then.
It would be best to upload a copy.
You will need to use ftp and upload the files.
Using the clear cache may help while doing so.

As I said before maybe you host edited them during a maintenance. upgrade.

By coincidence I have a site that the .htaccess file and php.ini file was edited just this past week and broke the forum.
There was evidence that a backup file was created but they were both incorrect.

Last edited by Ruben; 07/27/2020 4:23 PM. Reason: Added Comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Apr 2004
Posts: 1,745
Likes: 72
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,745
Likes: 72
you probably refreshed during the saving of files. thats how this usually happens. the data is replaced with blank data. its extremely rare. but it does happen. backups are the tools that admins use. admins of every single software.

email address is simple to answer. if the field is "" (blank) then it uses the address from the admin user accessing the page. code for that is within the top of /admin/gen_display.php

if you're curious, open the script file and you'll see it near the top. its a fail-safe rick added for when you access the page for the very first time. this field is the return address for all forum emails.
$config['SITE_EMAIL'] = (!$config['SITE_EMAIL']) ? $user['USER_REAL_EMAIL'] : $config['SITE_EMAIL'];

what mogan may have done probably was:
close his browser during the submit screen.
OR did a CTRL-F5 or forced F5
OR opened a new tab
OR anything that would clear the <input> get/post browser data
...on the GENERAL DISPLAY submission screen in a the browser tab.

when this happens, nothing from the entry screen is passed through to it. essentially submitting "empty fields" and creating "HTML INCLUDES" files of zero-bytes. every tab on the General Display settings page is submitted and written at once. all of the tabs on that page.

[Linked Image]


config-bak.inc.php was automatically created prior to any update being done. this is the current backup of forum configuration. it gets replaced with the current settings just before new ones are written. if you make changes, the previous settings will overwrite that file.

you should have a backup plan for your entire site. especially your /includes files.

bonus commentary: my backup plan is to backup the settings and scripts every 24 hours. that file is about 5mb total. after that is done, anything older than 30 days is deleted from the directory. this is all done through the CRON tasks on my server. I also FTP in to my sites on a schedule, and mirror the important data to my local hard drives.


Current developer of UBB.threads PHP Forum Software // 7.7.4 released!
isaac @ id242.com // my forum @ CelicaHobby.com
2 members like this: Gizmo, Morgan
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
So probably the site paused due to connectivity issues and Morgan hit refresh while editing?

That sucks.

Last edited by Ruben; 07/27/2020 4:50 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
Hi I restored following files from backup
Includes/footer.php
header.php
privacy.php
header-insert.php
header-insert-descrip.php
community_intro.php

The backup is incremental and it seems that it worked out fine

I changed name on the config-bak.inc.php to config.inc.php and it seems to have worked as well

I miss the robots crawler data but I'll look for that somewhere

Yes I must have refreshed or closed the tab cause it was really slow and timed out.

I hope it works now and I guess I'll open the site

I see in UBB.threads System Requirements Test that some fields are Empty but hope its not any vital..


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
1 member likes this: isaac
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
Humm when I login as a user at your site the forum rules keep coming back to revisit.
Maybe it is not all done yet

Could be cookie path?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
The forum is not open yet


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
Its open now


Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
1 member likes this: isaac
Joined: Jan 2004
Posts: 2,472
Likes: 3
Pooh-Bah
Offline
Pooh-Bah
Joined: Jan 2004
Posts: 2,472
Likes: 3


Using version :: 7.7.4
2 members like this: Gizmo, isaac
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
Deja Vu grin


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
2 members like this: Gizmo, isaac
Joined: Apr 2004
Posts: 1,745
Likes: 72
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,745
Likes: 72
Thank you Driv. I see your linked posts from 2012 regarding the loss (zeroed-out) of the config.inc.php file, and present you with the following:

UBB.threads 7.6.1 Changelog (January 1, 2018) -
[NEW] The current forum config file is now backed up before new changes are saved. A forum owner can now roll back to their backup config file, if the new one gets corrupted during its creation.
https://www.ubbcentral.com/forums/u.../7-6-1-1-changelog-discussion#Post260743

config-bak.inc.php is mentioned in this thread's OP and a few other times in the replies. As a result of this new feature added in 2018, It appears that Morgan was able to make use of this auto-backed up configuration file for his main settings, in conjunction with a previous backup of his forum header/footers.


Current developer of UBB.threads PHP Forum Software // 7.7.4 released!
isaac @ id242.com // my forum @ CelicaHobby.com
1 member likes this: Gizmo
Joined: Jan 2004
Posts: 2,472
Likes: 3
Pooh-Bah
Offline
Pooh-Bah
Joined: Jan 2004
Posts: 2,472
Likes: 3
Originally Posted by isaac
Thank you Driv. I see your linked posts from 2012 regarding the loss (zeroed-out) of the config.inc.php file, and present you with the following:

I am well aware of config-bak.inc.php.
The way that you phrase your response (including date) appears to be patronising. That you don't consider it worthwhile.

I found that lock & write function to be lacking and later discovered that SD (a very experienced programmer) considered the same.
I am simply pointing out that this issue is still happening!

I won't bother in future.


Using version :: 7.7.4
1 member likes this: JAISP
Joined: Jun 2006
Posts: 15,973
Likes: 38
UBB.threads Developer
Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 15,973
Likes: 38
Isaac was simply referencing that your referenced post was in 2012, and a backup function had been added in later builds. We have nothing to do with the lock and write function, it was written well before we began development on any portion of the software.

When we post updates in various threads, especially when i referencing items older than a couple of years, we always reference the date they were made; this is pretty standard for a product with support discussions over 15 years old that contain outdated information.

We consider every UBB System's customer inquiry important, however this is a rather ancient product which we're trying to bring into today's standards, we have yet to recode every bit of the software as it takes quite a bit of time to get very far at all.

We go through huge undertakings to update portions of the software; for example, the PHP 7 rewrite took the better part of a year to get the database handler and all portions of coding to play nice with modern systems. This doesn't even include keeping up to date with further changes to PHP while retaining backwards comparability with outdated systems.

I understand that things can be infuriating to some, but we try to fix things when we can replicate them; We have attempted to recreate all sorts of methods of zero out the configuration file and have found several items which can cause it such as closing your browser while the files are being written to. A method towards recovery was introducing the backup when a new settings are written to file so that one can have a snapshot of their configuration before attempted changes to the system until a fix could be identified and pushed out..

I also understand that, while promises and ideas made by previous developers may seem easy to implement and adapt changes, however we are not those programmers and items take time to write and test; we are just two guys on the West coast trying to provide a service to a vendor.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jun 2006
Posts: 805
Likes: 11
Morgan Online Shocked OP
Old Hand
OP Online Shocked
Old Hand
Joined: Jun 2006
Posts: 805
Likes: 11
When I found out that the forum was affected I felt like disaster had hit me. When trying to understand the magnitude I posted this message here.
Rubens answer didn't give me much but a tiny bit and that actually got me thinking more constructive.
FYI I have never had to restore anything with the hosts WHM/CP and didn't really dare to hit the start button.
Then I remembered the config-bak.inc.php and checked the time it was created. It was one second after I hit the button when it all happened.
I also compared the files and then used the config-bak.inc.php as config.inc.php.
Suddenly most things started to work and I dared to restote the header, footer and other affected files. All was within /includes.

I am very grateful for the config-bak.inc.php as it made my day. Thanks guys for building that feature.

After a few days it seem that it works ok.

We can't thank the west coast guys enough for your efforts!!!

Oh I'm a west coast guy too.. but on the Swedish coast and that's a complete different story.
Thanks also to Ruben.

Last edited by Morgan; 08/01/2020 4:39 PM.

Morgan Johansson
BritBike Forum
http://www.britbike.com/forums/ubbthreads.php
2 members like this: isaac, Gizmo
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
Sorry I made it confusing to you.
But I had no idea how severe the issue was.
As far as what files were corrupted.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Apr 2004
Posts: 1,745
Likes: 72
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,745
Likes: 72
New for UBB.threads 7.7.5, all config file updates are checked for a valid post key before anything is written to disk.

Backups of config files will continue to be written prior to any new config file updates.

For the forum admin making changes, there is nothing different that needs to be done. This is all handled on the back-end.

This update should finally resolve the issue of a blank (zeroed-out) config file being written when a null or corrupt $_POST is submitted.


EDIT:
This fix also includes protection for the HTML Includes header/footer files


Current developer of UBB.threads PHP Forum Software // 7.7.4 released!
isaac @ id242.com // my forum @ CelicaHobby.com
Joined: Dec 2003
Posts: 6,210
Likes: 31
Online Yawn
Joined: Dec 2003
Posts: 6,210
Likes: 31
Wow, awesome.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Link Copied to Clipboard
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Like unlike bug?
by Morgan - 09/24/2020 5:03 PM
looking to renew :)
by Mors - 09/23/2020 7:52 PM
test
by Mors - 09/23/2020 7:51 PM
What triggers page view numbers
by Morgan - 09/21/2020 10:31 AM
Forum Permissions Question
by FREAK - 09/20/2020 2:13 PM
Who's Online Now
4 members (Ruben, Gizmo, Morgan, 1 invisible), 69 guests, and 46 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200925)