|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
I recently upgraded our forum to version 8. The upgrade seemed to go smoothly, but after the upgrade, I am unable to login. I type the username/password, the screen goes to the forum list, but I'm still logged out.
I've double checked permissions, and cleared cookies. Any ideas?
I can browse the forum fine, just can't access anything that requires login.
Last edited by phoenix011235; 10/24/2024 9:00 AM. Reason: added information
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Is your forum behind a Content Delivery Network such as CloudFlare? If so, have you cleared all of the expired assets from after you've upgraded? What does a hard refresh (Ctrl F5) show after attempting to login? What browser are you using? If Safari they no longer follow web standards, so it is not recommended to depend on it.
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Is your forum behind a Content Delivery Network such as CloudFlare? No. It's running on a linux box. It was running on a virtual private server, and I wanted to try it in a different environment before asking for help. What does a hard refresh (Ctrl F5) show after attempting to login? Hard refresh has no effect. I've also tried it in private browser windows. I've tried in Firefox and Chrome. I was logged in as sysop after the upgrade finished The next morning, I couldn't log in. Interestingly, some of my students who had been logged in before the upgrade, remained logged in after this started happening. No one else could log in. fwiw, I also tried changing to the default stylesheet, since I was using a custom one. Still couldn't log in.
Last edited by phoenix011235; 10/24/2024 8:27 PM. Reason: thought of something to add
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
if I had to guess here, I was thinking that it might be a cookie issue but you mentioned that you attempt a login in private mode and different browsers... Do you have a copy of the UBB.threads Test Script installed? It should display any potential issues with your hosting environment if it detects any... Are the paths and URLs all set correctly in your includes/config.inc.php file? What do you have set as your cookie prefix?
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Do you have a copy of the UBB.threads Test Script installed? It should display any potential issues with your hosting environment if it detects any... Just installed it. Here's a screenshot: ![[Linked Image]](https://www.ubbcentral.com/forums/ubbthreads.php/ubb/download/Number/3548/filename/Screenshot From 2024-10-25 06-34-10.png) Are the paths and URLs all set correctly in your includes/config.inc.php file? What do you have set as your cookie prefix? Just double checked the paths and URLs. They all look good. The cookie prefix is: phx
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
I just updated the Test Script to eliminate a PHP8 strict error when hosts don't allow exec, which should make the test script load fully. Do you have Let's Encrypt or another free certificate authority on your hosting server? In testing we've found some rare instances where cookies wouldn't be created properly when SSL isn't in use in PHP8.
|
|
1 member likes this:
phoenix011235 |
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
It turned out to be https. Once I enabled the security certificate, I had to edit my config so it didn't refer to http addresses. (Caused infinite redirect problems after enabling https).
Now I'm able to login, but not able to load pages in admin. They're all outputting blank pages now. Checking permissions now.
At least authentication is working, so that's a relief!
Thanks for all of your help!
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Do a hard refresh on the landing for the control panel and see if it loads, there's a cookie issue fixed in v8.0.1 relaxing to strict mode that we've been testing, if it works the fix is to Edit /forums/admin/doapproveusers.php and remove line 176 where it mentions $ubbt_admin = serialize($ubbt_admin);
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
A hard refresh didn't solve the problem. I've double checked permissions. All admin pages are coming up as empty white pages. (I also tried the fix, just in case, but no change)
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
It is not a NGINX server is it? I have had cache issues with that type server. Causing settings not to stick So I exclude ubbthreads.php from the cache in cpanel
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Hmmm..no, I'm using apache
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
It would still be apache as well as a Linux os NGINX just adds features like site caching proxy etc check with your host. Also they usually have a setting in cpanel for NGINX if it is used
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
I gotcha..I don't believe I'm using NGINX
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Just checked. I'm not running nginx. I guess the question is now..should I be?
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Do your error logs show anything when the page blanks?
|
|
|
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88
|
|
Joined: Dec 2003
Posts: 6,649 Likes: 88 |
Just checked. I'm not running nginx. I guess the question is now..should I be? I would only use it if the host provides it as part of the hosting plan and then with caution. It is just a cache on the server and sometimes it causes issues such as make a change in ubb and it appears the change did not complete or a new post does not appear for a while or you end up re posting
Blue Man Group There is no such thing as stupid questions. Just stupid answers
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Do your error logs show anything when the page blanks? The access log shows the initial request, but nothing else. The error log shows this message: [Mon Jan 06 12:32:38.014796 2025] [core:notice] [pid 1061] AH00052: child pid 1067 exit signal Segmentation fault (11) [Mon Jan 06 12:32:40.017004 2025] [core:notice] [pid 1061] AH00052: child pid 1065 exit signal Segmentation fault (11) Those were from the time around the request. Earlier in the error log, I see this as well: [Mon Jan 06 12:11:53.290087 2025] [mpm_prefork:notice] [pid 1082] AH00170: caught SIGWINCH, shutting down gracefully [Mon Jan 06 12:12:42.261794 2025] [http2:warn] [pid 1061] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive. PHP Warning: PHP Startup: Unable to load dynamic library 'openssl' (tried: /usr/lib/php/20230831/openssl (/usr/lib/php/20230831/openssl: cannot open shared object file: No such file or directory), /usr/lib/php/20230831/openssl.so (/usr/lib/php/20230831/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0 [Mon Jan 06 12:12:42.658194 2025] [mpm_prefork:notice] [pid 1061] AH00163: Apache/2.4.58 (Ubuntu) OpenSSL/3.0.13 configured -- resuming normal operations Perhaps this sheds some light?
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
It's been awhile, but the problem still exists. I've even tried numerous times to install the software on a freshly formatted lamp server. Everything goes flawlessly until I try to access the control panel. I can make forum posts, my users can use the forum, but I'm presented with a white screen everytime I try to access Control Panel.
This happens on new installations with a fresh database as well. As many times as I've replicated the error, I'm surprised no one else has experienced it. It feels like a permissions problem, but I'm at a loss at this point.
Any new ideas of things to try?
Thanks!
p.s. - to be clear..originally this was a problem with authentication. The problem is now blank white pages when trying to access Control Panel
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Try this if you're running v8.0.0 and the dashboard.php file comes up blank. Open /admin/dashboard.php Find: // We only want to do some of these queries every 5 minutes (300) or 30 minutes (1800)
// so as not to slow things down if they keep hitting the login screen.
$rightnow = time();
if ($ubbt_admin) {Replace With: if (($ubbt_admin) && (strpos($ubbt_admin, "timestamp"))) {Open /admin/doapproveusers.php Remove: $ubbt_admin = get_input("{$config['COOKIE_PREFIX']}ubbt_admin", "cookie");Remove: $ubbt_admin = serialize($ubbt_admin); Find: $html->ubbt_setcookie("{$config['COOKIE_PREFIX']}ubbt_admin", $ubbt_admin);Replace With: // Purge control panel cache cookies
$html->ubbt_setcookie("{$config['COOKIE_PREFIX']}ubbt_admin", "", time() - 3600);
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Made the adjustments, but dashboard is still coming up white.
From the other thread, tried these again after the modifications. /admin/phpinfo.php works fine /admin/primary.php also comes up blank.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
What is displaying in your system error log? What version of PHP8? What versions of PHP are available to you on your web host?
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
I'm not seeing anything in Apache's error log. Just getting a white screen when I go to the admin dashboard.
I'm using PHP 8.3.6 (cli) (built: Jul 14 2025 18:30:55) (NTS). I have full shell access to the machine, so can try anything. (Not using a hosting provider..just using ubuntu server on a PC)
|
|
|
|
|
Joined: Mar 2014
Posts: 16
Stranger
|
|
Stranger
Joined: Mar 2014
Posts: 16 |
Non of this helps.
Interesting note: last installation I got in when I couldn't log in with my main admin account I created, I had Registered a new user, and the board created that user as the admin account. <<<<< This looks a bit suspicious as an internal code error (just guessing)
This time I tried Registering a new account and I cannot log in with that either
A day without learning is a wasted day
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
During testing the fix to the white screen error was a part of two bugs, of which this post explains how to patch the bug (a script in the admin pages was corrupting cookies in PHP8 which resulted in a white a page when you try to hit the landing page as the corrupt cookie would cause the dashboard.php page to not load). You should still be able to access the other pages in the Control Panel such as primary.php or features.php to manage the forum if this bug is unpatched. As for your support inquiry in your other thread, please keep the discussion in one place here.
|
|
|
|
|
Joined: Mar 2014
Posts: 16
Stranger
|
|
Stranger
Joined: Mar 2014
Posts: 16 |
I didn't get a white screen,
I get the forums page and shows not logged in like a guest.
Did I misunderstand your first line? "During testing the fix to the white screen error was a part of two bugs" ?
A day without learning is a wasted day
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
What I'm pointing at is that in this thread we are trying to figure out Phoenix's issues for his instance, which is separate from the issues you're having on your support post, I'm asking that instead of blending them both that we keep both support issues in their own threads versus trying to merge them.
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
During testing the fix to the white screen error was a part of two bugs, of which this post explains how to patch the bug (a script in the admin pages was corrupting cookies in PHP8 which resulted in a white a page when you try to hit the landing page as the corrupt cookie would cause the dashboard.php page to not load). I believe I already tried this fix, but it didn't change the white screen. You should still be able to access the other pages in the Control Panel such as primary.php or features.php to manage the forum if this bug is unpatched. Just tried to access primary.php and features.php, but they are also coming up with the white screen.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
What messages display in your error log?
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Which error log should I check? I'm not seeing anything in the apache log
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Most systems combine some error messages in the access log; just try to access a forum page that blanks out then attempt to look at the access_log and/or error log. If you have access to change environmental variables (such as cPanel) you can configure PHP to dump error messages to the browser " StackOverflow: How do I get PHP errors to display?"
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
I'm not getting anything in the error logs. I'm thinking it may be some php or apache module I'm missing, because I can reliably re-create the error on a fresh install of ubuntu server with a basic lamp setup. This is what I currently have: [PHP Modules] calendar Core ctype date dom exif FFI fileinfo filter ftp gd gettext hash iconv json libxml mbstring mysqli mysqlnd openssl pcntl pcre PDO pdo_mysql Phar posix random readline Reflection session shmop SimpleXML sockets sodium SPL standard sysvmsg sysvsem sysvshm tokenizer xml xmlreader xmlwriter xsl Zend OPcache zlib
Apache access_compat_module (shared) alias_module (shared) auth_basic_module (shared) authn_core_module (shared) authn_file_module (shared) authz_core_module (shared) authz_host_module (shared) authz_user_module (shared) autoindex_module (shared) core_module (static) deflate_module (shared) dir_module (shared) env_module (shared) filter_module (shared) http2_module (shared) http_module (static) Loaded Modules: log_config_module (static) logio_module (static) mime_module (shared) mpm_prefork_module (shared) negotiation_module (shared) php_module (shared) reqtimeout_module (shared) rewrite_module (shared) setenvif_module (shared) socache_shmcb_module (shared) so_module (static) ssl_module (shared) status_module (shared) unixd_module (static) version_module (static) watchdog_module (static)
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
You'll likely need hands on support (someone to look at your configurations) via the Support Desk at this point; UBB.threads is a basic standalone web script and assumes a basic working web server is in place, at this point we've exhausted any assistance this User to User support forum allows without having to delve into your system.
|
|
|
|
|
Joined: Nov 2025
Posts: 7
Stranger
|
|
Stranger
Joined: Nov 2025
Posts: 7 |
Hello, I have the white page on PHP 8.3 as well as 7.3... (the background installation on the server is ISPConfig), it worked on a 7.5.6 version with PHP 5.3x. This is a new installation from scratch and new forum. https://www.finalemus.com/admin/dashboard.phpalso admin/phpinfo.php works fine /admin/primary.php also comes up blank. Thank you
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Please see your thread, also the fix was mentioned in this thread here
|
|
|
|
|
Joined: Sep 2024
Posts: 19
Stranger
|
|
Stranger
Joined: Sep 2024
Posts: 19 |
Finally fixed my problem. It was a permission problems in templates.
|
|
|
|
0 members (),
399
guests, and
96
robots. |
|
Key:
Admin,
Global Mod,
Mod
|
|
|
|