Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 47 guests, and 224 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Outdoorking
Outdoorking
Sydney, Australia
Posts: 322
Joined: June 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 18
isaac 14
TheBrit 10
SteveS 8
Zarzal 6
Morgan 5
Ruben 4
jorb 4
Latest Photos
Test
Testing to drag photos
Comfortable Cats
Test
BSA photos
Active Threads | Active Posts | Unanswered Today | Since Yesterday | This Week
Version 7 Installation Assistance
Yesterday at 09:20 PM
I run an update from 7.5.6p2 to 7.6.2 on a site witch contains 3 language packs. The update scripts comes to 'update language files automaticly' I say go on and it doesnt come back, the frame stay blank. I try it sometimes but no success. In another run I have to click to change my files manually to go on.

I take a deeper look and found a problem that maybe forced this problem:
/language/admin/dogroupmanage.php missing php in the first line

In one of my own language files was a closing ?> missing at the end. I fixed it and hope the update to 7.7 runs smooth.
0 14 Read More
General Assistance (How Do I?)
Yesterday at 08:59 PM
I use ubb.threads for a very long time starting with a v6 version centuries ago. I life in Germany and this includes to use german special chars like öäüß (umlaute). This can you drive crazy and I like to share my experience with this and how to handle it.

If you install a brand new version 7.6.2 from stock you create a utf-8 databse, the install script create utf-8 tables and the language files (generic.php) contains the utf-8 string. All language files are in utf-8 coding. So you dont have any trouble and can use any king of char you like. It display always correct. The only thing to watch out for: while editing a language file offline use a editor (I use notepad ++) who can keep the file coding. Be carefull, check if utf-8 ist selected and not ansi or something else.

The second precaution is coding the special chars with html. Example
Code
Ä -> Ä

I alwas use the coding in my language files to avoid any surprise. But watch out for the mailer text strings! Some of them sent out in plain text and the coding will not parsed. Theses strings must contain the char itself.

Back to my old installation and the problems I encounter after updating to 7.6.2

My database runs in utf-8 but the tables was created in swedish-latin-1 long time ago. To use german chars the coding in generic.php was set to iso-8859-1. This work but if you interact with rss feeds to a utf-8 site you run in trouble. You will see ? for a special char. Sad.

Now we have to change everything. Setting the language string in generic.php to utf-8 dont fix our problem. We must digg little bit deeper. Close your forum and do a backup of the database. I use mysqldumper for this. We need it later for some steps because the tables are to big for normal importing.
After doing your backup go to phpmyadmin and watch your database tables. We have to chance the collate to utf-8. This can be done with this SQL-statement
Code
ALTER TABLE table CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
or from the options menu inside the table.
If you have done this to all tables go to your generic.php and set the language code to utf-8
Now you encounter a lot of display errors in your forum. The special chars look strange and need to convert to display properly. I go this way to do it:
Create a test post with all you chars you need to convert. View this post with phpmyadmin in uub_Post table at the end of the table. You will see the correct coding and can use it für copy/paste for the next step.
Next step: export with mysqldumper the table for posts, download it, edit it with notepad++ and do a search&replace for any special char in your test posting. Re-Upload it and do a restore of this table with mysqldumper. Repeat this with Post-Topic and both private posts tables. This will convert 99% of all chars.

After this operation your ubb runs in utf-8 and is prepared for V7.7
Please note that is my way to do it without any warrenty. You should know to handle phpmyadmin and mysqldumper

Greetings
Zarzal
0 18 Read More
Shout Box
Today's Birthdays
No Birthdays
Recent Topics
update multilanguage site problem
by Zarzal. 12/15/18 04:20 PM
Char coding utf-8 and older forums
by Zarzal. 12/15/18 03:59 PM
table issue
by TheBrit. 12/13/18 06:05 PM
testing table layout
by TheBrit. 12/13/18 11:16 AM
header.php after update from 7.5.x to 7.6.x
by Zarzal. 12/12/18 05:29 AM
Forum Statistics
Forums36
Topics35,180
Posts191,677
Members12,122
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2