Well the install documentation will guide you through the proper file /folder permissions for all of them even if the control panel does not check them all.
But if you have database issues none of the above will fix the problem.
My suggestion would be to enable the server logs in the ubb control panel.
Then you will see what is going on. Or at least should be able to.
If it just reports a database connection error then one of a couple of issues. The user access for the database does not have global access, or the host has issues.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers