Previous Thread
Next Thread
Print Thread
Hop To
error on importing from classic to threads #165366 10/09/2006 5:53 AM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
the script stops on:

The script stops on:

Importing moderator (Forum #27)
Script: E:\accounts\forum.domainame.com\root\www\ubbthreads\importers\classic_import.php
Line#: 1602
SQL Error: Duplicate entry '0' for key 1
SQL Error #: 1062
Query: INSERT INTO ubbt_MODERATOR_PERMISSIONS ( `USER_ID`, `MODERATOR_CAN_EDIT_USERS`, `MODERATOR_CAN_APPROVE_POSTS`, `MODERATOR_CAN_EDIT_POSTS`, `MODERATOR_CAN_LOCK_POSTS`, `MODERATOR_CAN_MOVE_POSTS`, `MODERATOR_CAN_DELETE_POSTS`, `MODERATOR_CAN_STICK_POSTS` ) VALUES ( '' ,0,1,1,1,1,1,1)

What to now??



Re: error on importing from classic to threads [Re: webcare] #165374 10/09/2006 7:15 AM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
I have delete all moderators in the old forum, and reinstall the script, but there where no errors this time, except the members where not imported also the admin, I have the members dir before the www root, is this the problem that it will not import?

There is no log file so I can see whats wrong, If the location of the members dir is the problem, how to solved it and wich files must I change?

John

Last edited by webcare; 10/09/2006 7:16 AM.
Re: error on importing from classic to threads [Re: webcare] #165379 10/09/2006 8:32 AM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
It stuck because the members were not imported, and the importscript gives no error.... what is the normal location/path from the members dir in ubb classic? because I had tranfer it before the www root, and I do not remember the normal location?

Could someone tell me?

Last edited by webcare; 10/09/2006 10:32 AM.
Re: error on importing from classic to threads [Re: webcare] #165407 10/09/2006 10:38 AM
Joined: Jun 2006
Posts: 346
Ron M Offline
enthusiast
Offline
enthusiast
Joined: Jun 2006
Posts: 346
You should be able to get your Member's Directory path from your Paths & URLs section in your Classic Control Panel.

Moving this to Installation Help for now.

Re: error on importing from classic to threads [Re: Ron M] #165414 10/09/2006 10:44 AM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
I did copy the lines in the control panel into the importerfile but it seem not to import the members and the path is correct, because my old forum still works.

Re: error on importing from classic to threads [Re: webcare] #165440 10/09/2006 11:14 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
After getting the original error did you start over with the import or just try and resume where it left off?

Re: error on importing from classic to threads [Re: Rick] #165475 10/09/2006 2:55 PM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
I did a compleet new install, but evertime it fotgets to import the members, what to do now?

Re: error on importing from classic to threads [Re: webcare] #165476 10/09/2006 3:08 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Does it totally skip the members, or say it's importing them and just says it's done? If it tries to import them then it's possible it's not finding all of the members files. Check the path that your specifying for the Members Directory and make sure that all of your members files are in that directory.

Re: error on importing from classic to threads [Re: Rick] #165480 10/09/2006 3:31 PM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
Yes all the members are skiped and the import file is en and running normal.

I have only the members directory before the root file, make this a diference?

I did take the same path as in the controlpanel from the classic.

The old forum still works normal.

Re: error on importing from classic to threads [Re: webcare] #165482 10/09/2006 3:39 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
It's tough to say what's going on for sure, the location *shouldn't* matter as long as PHP can read it. If you can, try this and let me know what you get back. Bring up classic_import.php?ubb=members

Let me know if it does anything or just says it's going to continue to the categories or shoutbox.

Re: error on importing from classic to threads [Re: Rick] #165484 10/09/2006 3:54 PM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
Below the error

Warning: sort() expects parameter 1 to be array, null given in E:\************\accounts\forum.*********.nl\root\www\ubbthreads\importers\classic_import.php on line 355

Done! About to import categories. (please wait)
(classic_import.php?ubb=importsomeconfigstuff#bottom)
Generated in 0.1069 seconds in which 0.031 seconds were spent on a total of 2 queries.


Re: error on importing from classic to threads [Re: webcare] #165486 10/09/2006 4:01 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Ok, so that either means it's not able to find the members directory or there is some other issue.

The easiest thing would be if you can send me the ftp info to your server along with the URL to the import script so I can debug just a bit. You can either send it in a ticket or via a PT here.

Re: error on importing from classic to threads [Re: Rick] #165491 10/09/2006 4:16 PM
Joined: Jun 2006
Posts: 32
webcare Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 32
This is the message:

I just collect the data and send it to you.

Last edited by webcare; 10/09/2006 4:23 PM.

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Mobile app?
by Baldeagle - 12/06/2019 9:32 PM
How do you change Text Line spacing?
by jorb - 11/23/2019 12:14 AM
What happened to FAQ or Forum Help
by Ruben - 11/20/2019 11:58 AM
Search feature encountering an Error message
by jorb - 11/20/2019 12:06 AM
Followed List v7.7.2 Question
by Ruben - 11/12/2019 12:22 PM
Who's Online Now
1 registered members (JAISP), 71 guests, and 400 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)