Previous Thread
Next Thread
Print Thread
Hop To
[FIXED for 7.0.1] Portal box cache problem. #166784 10/21/2006 6:39 PM
Joined: Jun 2006
Posts: 46
Jamin Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 46
I'm having a problem with the cache versions of my portal boxes - specifically, Who's Online and Forum Statistics. All of my portal boxes are built into the template, so they're technically external. I've got Always Build checked on each one, and if I clear the cache manually it seems to fix it. But they never seem to update themselves.

Who's Online is currently stuck saying "1 registered (Jamin) and 0 anonymous users online" even when the forum index shows several people currently viewing various forums. And the Forum Statistics still says 539 total members, when the Newest Members box says 546. So I'm guessing the Newest Members box is working fine, since it's always correct. Dunno why the other two aren't working.

All the files in the /cache folder are CHMOD'd to 666 (the folder itself is 777), and if I try to change the CHMOD manually through FTP, I get the error "550 Could not change perms on whatever file: Bad file descriptor."

Any thoughts? Thanks in advance for any help.

http://se7enet.com/forums/ubbthreads.php is my URL, if you need to look at it.

---Jamin

Last edited by Rick; 10/24/2006 1:45 PM.

"Those who would give up essential liberty to purchase a little temporary safety, deserve neither liberty nor safety."
Re: Portal box cache problem. [Re: Jamin] #166788 10/21/2006 7:05 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Hmm, if they aren't even changing when you clear the cache manually that's a bit strange. Try this, delete those files from your cache completely and rebuild the cache. If it doesn't change in your side template then open up the files in the cache directory directly and take a look at them.

It almost sounds like the template you have them in is caching just one copy and not updating for some reason.

Re: Portal box cache problem. [Re: Rick] #166792 10/21/2006 7:47 PM
Joined: Jun 2006
Posts: 46
Jamin Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 46
They were changing when I cleared the cache manually. They just weren't changing under normal circumstances.

I've deleted the files and rebuilt the cache, so I guess I'll have to wait awhile and see if they're still stuck at their current values. Thanks Rick. smile

---Jamin


"Those who would give up essential liberty to purchase a little temporary safety, deserve neither liberty nor safety."
Re: Portal box cache problem. [Re: Jamin] #166795 10/21/2006 9:55 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Ahh, I must have misread that, I thought clearing the cache wasn't fixing the either. If it continues, let me know. It could be a problem in the code that's not rebuilding the cache as it should for those that are used externally.

Re: Portal box cache problem. [Re: Rick] #166882 10/22/2006 5:15 PM
Joined: Jun 2006
Posts: 46
Jamin Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 46
They're definitely still stuck. The New Users one is fine - I've got a new registration since yesterday and it is updated correctly. But none of the others are updated. Who's Online and Forum Stats are stuck where they were when I flushed the cache yesterday.

---Jamin


"Those who would give up essential liberty to purchase a little temporary safety, deserve neither liberty nor safety."
Re: Portal box cache problem. [Re: Jamin] #166904 10/22/2006 9:06 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
It very well could be the "always build" isn't always building for some of them. Before I go poking around on your server I'll need to see if there is a bug in the base code.

Re: Portal box cache problem. [Re: Rick] #166917 10/23/2006 2:27 AM
Joined: Aug 2006
Posts: 1,640
jgeoff Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Aug 2006
Posts: 1,640
I had someone join about 6 hours ago, and she's still not listed under Newest Members. confused I don't recall seeing any cache time options for Newest Members -- when should it update?



GangsterBB.NET (Ver. 7.6.1.1)
2007 Content Rulez Contest - Hon Mention
UBB.classic 6.7.2 - RIP
Browsers: Chrome, Firefox, & Safari (iPhone); No IE, ever!
Re: Portal box cache problem. [Re: jgeoff] #166970 10/23/2006 9:01 PM
Joined: Aug 2006
Posts: 1,640
jgeoff Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Aug 2006
Posts: 1,640
Okay, what I just said above is true: That person who signed up yesterday, over 24 hours ago, did not appear on Newest Members until a few minutes ago, after someone else signed up.

A Bug?


GangsterBB.NET (Ver. 7.6.1.1)
2007 Content Rulez Contest - Hon Mention
UBB.classic 6.7.2 - RIP
Browsers: Chrome, Firefox, & Safari (iPhone); No IE, ever!
Re: Portal box cache problem. [Re: jgeoff] #166971 10/23/2006 9:03 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Hmm, will have to look at that. The newest members doesn't have a cache timer, it's supposed to just be updated any time someone registers.

Re: Portal box cache problem. [Re: Rick] #166989 10/24/2006 1:45 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Definitely a bug with the always_build option. Not necessary an easy fix, but will get this fixed for 7.0.1. Also, moving this into the bugs forum.

Re: Portal box cache problem. [Re: Rick] #167024 10/24/2006 11:43 PM
Joined: Jun 2006
Posts: 46
Jamin Offline OP
newbie
OP Offline
newbie
Joined: Jun 2006
Posts: 46
Good to know it's a bug and I didn't just screw something up. I was afraid there was some CRON job that I was supposed to set up, and that I was just retarded for not knowing that.

---Jamin


"Those who would give up essential liberty to purchase a little temporary safety, deserve neither liberty nor safety."

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Having issue with redirects to UBB classic URLs
by amciotola - 10/16/2019 1:11 AM
Unable to save General settings
by amciotola - 10/13/2019 4:23 AM
I see signature line images, but no avatars
by Morgan - 10/12/2019 2:21 PM
Show PDF
by Geoff - 10/09/2019 1:33 AM
Subscription’s Auto Return URL for PayPal
by Geoff - 09/27/2019 12:10 AM
Who's Online Now
1 registered members (Ruben), 68 guests, and 141 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20190930)