Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 53 guests, and 388 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Morgan
Morgan
Sweden
Posts: 518
Joined: June 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 18
M4TT 12
FREAK 11
Ruben 8
mmkk 4
isaac 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
[FIXED] [7.4.1] Error in showprofile.inc.php #219087
11/11/08 04:44 PM
11/11/08 04:44 PM
Joined: Aug 2006
Posts: 39
Bern, Switzerland
Micky Offline OP
newbie
Micky  Offline OP
newbie
Joined: Aug 2006
Posts: 39
Bern, Switzerland
My Error Message

We encountered a problem. The reason reported was

Script: /xxxxxxxxxx/scripts/showprofile.inc.php
Line#: 138
SQL Error: Table 'xxxxxxxxxx.ubbt_ONLINE' doesn't exist
SQL Error #: 1146
Query: SELECT count( t1.USER_ID ) FROM ubbt_ONLINE AS t1, ubbt_USER_PROFILE AS t2 WHERE t1.USER_ID = t2.USER_ID AND t1.USER_ID = 3

Please click back to return to the previous page.

Find in /scripts/showprofile.inc.php

PHP Code
 $query = "
		SELECT count( t1.USER_ID )
		FROM ubbt_ONLINE AS t1, ubbt_USER_PROFILE AS t2
		WHERE t1.USER_ID = t2.USER_ID
		AND t1.USER_ID = ?
		$extraquery
	"; 


and replaces

PHP Code
 $query = "
		SELECT count( t1.USER_ID )
		FROM {$config['TABLE_PREFIX']}ONLINE AS t1, {$config['TABLE_PREFIX']}USER_PROFILE AS t2
		WHERE t1.USER_ID = t2.USER_ID
		AND t1.USER_ID = ?
		$extraquery
	"; 


Finishedly wink


Gruss Micky

Sorry for my bad English whistle

Golf Diesel Forum
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: [7.4.1] Error in showprofile.inc.php [Re: Micky] #219090
11/11/08 05:16 PM
11/11/08 05:16 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
Good catch! Thanks for the report and fix.

Re: [7.4.1] Error in showprofile.inc.php [Re: Rick] #220694
12/31/08 02:52 PM
12/31/08 02:52 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Bump.
Rick don't forget this one for bug fix release


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: [7.4.1] Error in showprofile.inc.php [Re: Ruben] #220696
12/31/08 03:16 PM
12/31/08 03:16 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
This one was fixed and is already in 7.4.1 wink

Re: [7.4.1] Error in showprofile.inc.php [Re: Rick] #220697
12/31/08 03:21 PM
12/31/08 03:21 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Thats funny I just installed 7.4.1 on a new host for a test and it was there.
Zip file is dated 11/10/2008

Last edited by Ruben Rocha; 12/31/08 03:26 PM.

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: [7.4.1] Error in showprofile.inc.php [Re: Ruben] #220698
12/31/08 03:26 PM
12/31/08 03:26 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
The bug was there, or the fix was there?

Re: [7.4.1] Error in showprofile.inc.php [Re: Rick] #220699
12/31/08 03:28 PM
12/31/08 03:28 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
the bug was there. I had to edit and add the fix because it was a test board and I named the tables all test_ for the prefix.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: [7.4.1] Error in showprofile.inc.php [Re: Ruben] #220700
12/31/08 03:29 PM
12/31/08 03:29 PM
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
R
Rick Offline
Former Developer
Rick  Offline
Former Developer
R
Joined: Jun 2006
Posts: 10,177
Aberdeen, WA
Hrmm, ok. Well I have it fixed for 7.4.2 then laugh

Re: [7.4.1] Error in showprofile.inc.php [Re: Rick] #220703
12/31/08 03:55 PM
12/31/08 03:55 PM
Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Mark S Offline
Mark S  Offline

Joined: Jul 2006
Posts: 4,704
Liverpool : England : UK
Its good to Talk lol


Version v7.5.8
People who inspire me Gizmo ID242 SD
Its been a long road. . . .to be waiting
Re: [7.4.1] Error in showprofile.inc.php [Re: Mark S] #220705
12/31/08 04:13 PM
12/31/08 04:13 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Rick the fix is in 7.4.1 now.
You must have updated it the day after the release.
I just downloaded a fresh copy of 7.4.1 and the fix is in place.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar [Not a Bug]
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,544
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)