Previous Thread
Next Thread
Print Thread
Hop To
SQL Corruption? #219458 11/20/2008 9:52 AM
Joined: Jun 2006
Posts: 9
Jason Carey Offline OP
stranger
OP Offline
stranger
Joined: Jun 2006
Posts: 9
Hello all, I'm having a bit of a problem with my board and have tried to isolate it as much as I can. I believe down to a rogue SQL table. At this point it would be great to see if anyone else ever had this problem. Please visit the two different servers I have been testing with. The issue started on the live server and I have been trying to isolate on the test server.

Live Server: http://www.melaniesmusic.com/forums/ubbthreads.php
7.4b2 - php 4.027, mysql 4.1.22

Testing: http://208.131.128.192/forums/ubbthreads.php
7.4.1 - php 5.2.6, mysql 5.0.27

You can see that there are no images, and the whole page layout is scattered. It only happens in the user forums. The admin section is fine. This is the second time this has happened to me within a couple months. It was fixed the first time by my host restoring a backup. To set up the test server I exported from phpmyadmin with recommendations I found on this site from my live server and imported into a new database on the test server. I then installed a fresh 7.4.1 and did not restore any forums directory files (styles, templates, etc.) from the old (live) board. The only thing from the live board is the sql database.

So, I seemed to have isolated the issue down to a sql table somewhere, but I'm not sure which one would be responsible. I would rather not have to lose any information. Could it be a person posting malformed characters? Maybe it's a bug. Maybe my sql files became corrupted. I'm just not sure. I can supply sql backup files to the developers upon request.

There is also a separate issue, if I delete a second language folder, the users that had that language file selected can no longer log in to the board. Sometimes even after deleting cookies, etc. Any workarounds for that?

Thanks for any replies you can give me!

Re: SQL Corruption? [Re: Jason Carey] #219463 11/20/2008 11:07 AM
Joined: Dec 2003
Posts: 5,952
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,952
I see at least the paths are incorrect to your images.
Probably your templates have the wrong path also.
I would suggest you start over.
I would say you need to transfer your existing version to your test server first. Then follow the upgrade instructions.
I know at least the styles are saved in the database. So you may find it is more difficult to fix your sql tables than to start over.
Here is Gizmos transfer guide HERE

UBB Upgrade guide is HERE


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: SQL Corruption? [Re: Ruben] #219493 11/20/2008 10:38 PM
Joined: Jun 2006
Posts: 9
Jason Carey Offline OP
stranger
OP Offline
stranger
Joined: Jun 2006
Posts: 9
Great resources, thank you. I may end up starting over, but wish I could pinpoint the source of the problem to satisfy the inner geek in me. Particularly because I didn't change anything to cause this. It appears to happen on its own. I don't log in for weeks at a time and every so often a user will email me and tell me its messed up again.

The test server is a new installation, except for the sql files, which to my knowledge shouldn't carry over anything that would mess up a layout that badly. So without my existing styles and templates, and it is still having the issue, that means its in a database somewhere. If one of the tables stores paths, shouldn't I be able to fix that from a control panel? And why is the admin section perfect but the public area messed up unless there are two different paths. And lastly, doesn't it seem likely that someone hacked something to cause this? I can't begin to imagine how this happens on its own. Thanks.

Re: SQL Corruption? [Re: Jason Carey] #219657 11/26/2008 5:12 PM
Joined: Dec 2003
Posts: 5,952
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,952
It would be nice to know what you did to fix the problem!!!


Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
ubb.threads 7.7.3 install error on create tables
by andrewjs18 - 09/17/2019 3:39 AM
Horizontal Image Attachment
by ECNet - 09/11/2019 12:17 PM
user profile, after I click Update nothing happens
by PianoWorld - 09/10/2019 12:38 PM
Inline Image Embeds
by ECNet - 09/03/2019 2:38 PM
Who's Online Now
1 registered members (isaac), 85 guests, and 288 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.3