Previous Thread
Next Thread
Print Thread
Hop To
Bots on the forum? #221615 01/26/2009 1:14 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Hi,

I am noticing high page views for threads that were posted years ago? I am really quite sure that people aren't still viewing these threads. Could it possibly be bots? Is there any way I can tell?

Thanks

Re: Bots on the forum? [Re: Softrak] #221619 01/26/2009 4:35 PM
Joined: Jun 2006
Posts: 15,851
Gizmo Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,851
It's possible that it's incoming hits from Search Engines; well crawled content that's been linked to shows higher in search requests through them...

And theres a simple way to tell, look at the Who's Online page, a bot will have a "user agent" string that tells you where it's from, and it'll show in the "guests" or "bots" section (it'll show in the bots section if you tell your ubb which UA's are bots)


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Need to Upgrade?
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Bots on the forum? [Re: Gizmo] #221620 01/26/2009 6:16 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Thanks Gizom,

This maybe a dumb question... where is the 'who's online' page?

Re: Bots on the forum? [Re: Softrak] #221622 01/26/2009 6:18 PM
Joined: Dec 2003
Posts: 5,944
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,944
Well if you enable the who's online island just click on that


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Bots on the forum? [Re: Ruben] #221712 01/29/2009 1:43 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Hi,

I created a php page with this script to see who's online:

<?php
if (!defined('UBB_MAIN_PROGRAM')) define('UBB_MAIN_PROGRAM',1);
$style_side="";$tbopen="";$tbclose="";
echo "<table width=\"100%\">";
include("/var/www/vhosts/softrak.com/httpdocs/ubbthreads/cache/online_now.php");
echo "</table>";
?>

I've set the cache time for 1 minute. Evertime I refresh the page I still see the same users online. Even when I am logged out it still shows that I am online. Am I missing something here?

Thanks

Re: Bots on the forum? [Re: Softrak] #221729 01/29/2009 3:52 PM
Joined: Dec 2003
Posts: 5,944
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,944
Not even looking at the code I see a issue.
If this is a separate page from the forum.
The cache folder is only updated when someone is visiting the forum. Even though you may have a time limit imposed.
So if you have no activity on the forum the time you view the page the cache file you reference will not update until there is some activity.



Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Bots on the forum? [Re: Ruben] #221872 02/02/2009 1:14 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Ok well the who's online island never changes. It always shows the same people online... it's been two weeks.

Re: Bots on the forum? [Re: Softrak] #221876 02/02/2009 1:28 PM
Joined: Jun 2006
Posts: 9,246
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,246
Check the permissions on all the files in the cache directory and make sure they are all writable. You can actually nuke everything in there except for the index.html file if you want and then go into the Control Panel and clear the cache. This way you can verify everything is rebuilt properly.

Re: Bots on the forum? [Re: Softrak] #221877 02/02/2009 1:29 PM
Joined: Dec 2003
Posts: 5,944
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,944
What is the url to your forum?


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Bots on the forum? [Re: Ruben] #221880 02/02/2009 1:57 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72

Re: Bots on the forum? [Re: Softrak] #221883 02/02/2009 2:10 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Ok i've updated the permissions on the files in the cache directory and cleared the cache. The Who's Online island has now changed. smile

Thanks Rick.

What I don't understand is Gizmo's comment:

"And theres a simple way to tell, look at the Who's Online page, a bot will have a "user agent" string that tells you where it's from, and it'll show in the "guests" or "bots" section (it'll show in the bots section if you tell your ubb which UA's are bots)"

Where's the Who's Online page?

Much thanks everyone.

Re: Bots on the forum? [Re: Softrak] #221884 02/02/2009 2:10 PM
Joined: Dec 2003
Posts: 5,944
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,944
I just visited your site and watched a while and the island is updating. Maybe you followed Ricks suggestion?

But the details link in the island is not showing anything.?ubb=online.
Not sure what to check. I never used version 7.0.
Maybe a permission setting for guests to view.

We must have been typing at the same time.
On my version the whos online setting is in the control panel>general>>expand whos online

Last edited by Ruben Rocha; 02/02/2009 2:12 PM. Reason: added comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Bots on the forum? [Re: Ruben] #221886 02/02/2009 2:25 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Yes... I followed Ricks suggestion. smile

I don't see the Who's Online setting in the control panel on my version.


Re: Bots on the forum? [Re: Softrak] #221887 02/02/2009 2:30 PM
Joined: Dec 2003
Posts: 5,944
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,944
Looks like that feature was added in version 7.1.

Read the change log HERE


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Bots on the forum? [Re: Ruben] #221896 02/02/2009 2:52 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Ok actually i've noticed calendar information isn't being displayed either and the shout box isn't working. Might this be related to permission errors???

Re: Bots on the forum? [Re: Softrak] #221898 02/02/2009 2:58 PM
Joined: Dec 2003
Posts: 5,944
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,944
Well All the islands are built the the same cache directory as the whos on line island.
You could try going over Rick's suggestion again and check the individual island scripts for each feature to see if it is set the same as the whos online script which is working now.

I tried to register to see but you moderate registrations.
I can't tell if guests are not allowed to view those features or what.
Sent a PM


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: Bots on the forum? [Re: Ruben] #221918 02/02/2009 4:58 PM
Joined: Jan 2007
Posts: 72
Softrak Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2007
Posts: 72
Thanks Ruben. smile


Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
visual accessibility issues.v7.7.3
by Ruben - 08/21/2019 1:50 PM
Holy grail to fix compatibility bewteen browsers
by Ruben - 08/20/2019 4:25 PM
File Manager and Image Uploads
by Ty Griffin - 08/19/2019 4:48 PM
Minimum Post Character Count
by M4TT - 08/19/2019 1:58 PM
[FIXED for 7.7.4] Strange Merge Issue
by Baldeagle - 08/16/2019 3:37 PM
Who's Online Now
1 registered members (isaac), 41 guests, and 233 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Photos
Stones
Amusing Terain Scenics
Sky places
Work spaces
Powered by UBB.threads™ PHP Forum Software 7.7.3