Previous Thread
Next Thread
Print Thread
Hop To
Troubleshooting Fatal Error #238423 08/02/2010 12:45 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
Various users are getting this erorr intermittently. Any ideas on what might be causing this?

Fatal error: Maximum execution time of 30 seconds exceeded in C:\WEB SITES\SEMINARSTHREADS\libs\ubbthreads.inc.php on line 915

Re: Troubleshooting Fatal Error [Re: Travis T] #238425 08/02/2010 12:59 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Hmm, what version are you currently running? In the latest version that line is in a function that tries to grab an XML feed.

Re: Troubleshooting Fatal Error [Re: Rick] #238426 08/02/2010 1:04 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
7.5.5 - as far as I know we are not grabbing any XML feeds (RSS Feeds).

Re: Troubleshooting Fatal Error [Re: Travis T] #238428 08/02/2010 1:14 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
I just double checked and I confirmed that I do not curretnly have RSS feeds eanbled for any forums.

Re: Troubleshooting Fatal Error [Re: Travis T] #238429 08/02/2010 1:28 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Hmm, at what point does the error come up? Any place in common between the user's getting the error, meaning a maybe a particular page or action?

Re: Troubleshooting Fatal Error [Re: Rick] #238430 08/02/2010 1:36 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
I will try to get back to as many people as possible and see if I can put together a list of when/where for you.

Re: Troubleshooting Fatal Error [Re: Travis T] #238431 08/02/2010 2:03 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
The response I got was this:

After logging in or during and if after, right when they clicked on a Forum (although not necessarily the same forum).

Re: Troubleshooting Fatal Error [Re: Travis T] #238432 08/02/2010 2:32 PM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Ok, it will help if you can find out if it's getting the exact same line number in the error.

Re: Troubleshooting Fatal Error [Re: Rick] #238439 08/02/2010 10:22 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
OK - they are really flowing in now. Same error message for all users (they can't even log in at this point).

The line numbers change though, 927, 928, 954. Still asking for more error message at this point.

Any ideas?

Re: Troubleshooting Fatal Error [Re: Travis T] #238440 08/02/2010 10:25 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
Line 909 now too. 954 again.

Re: Troubleshooting Fatal Error [Re: Travis T] #238441 08/02/2010 10:27 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138

Fatal error: Maximum execution time of 30 seconds exceeded in C:\WEB SITES\SEMINARSTHREADS\libs\user.inc.php on line 160 this time.

Re: Troubleshooting Fatal Error [Re: Travis T] #238442 08/02/2010 10:29 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
928, 909 again

Re: Troubleshooting Fatal Error [Re: Travis T] #238443 08/02/2010 10:35 PM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
When I tried becoming one of the members that is having troubles logging in, (from Administrator), I ran into the same problem.

Interesting.

Fatal error: Maximum execution time of 30 seconds exceeded in C:\WEB SITES\SEMINARSTHREADS\libs\ubbthreads.inc.php on line 954

Re: Troubleshooting Fatal Error [Re: Travis T] #238453 08/03/2010 1:03 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
How large is your forum? If you have full new post tracking turned on, and they have a ton of unread posts, this could be causing it. Maybe have them try to Mark All Forums Read. Basically since the line number is changing, then it's not a particular function, it's just a matter of overall it's taking too long to load everything.

Re: Troubleshooting Fatal Error [Re: Rick] #238457 08/03/2010 9:54 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
But they can't even log in at this point. The error comes up after they enter their username and password. If I try to become them, I run into the same problem.

Now - something new I am researching. This was an import from Classic and I am noticing that some of the users in question have two accounts (one for them and one for their kids - SOP for us), but both with the same email address. Classic allowed this, but maybe Threads does not? Could this be causing the problem? IF so, haw can I rectify it?

Re: Troubleshooting Fatal Error [Re: Travis T] #238459 08/03/2010 9:57 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
"If you have full new post tracking turned on"

I do not believe I have this enabled, but if I did, where would I find that setting?

Re: Troubleshooting Fatal Error [Re: Travis T] #238460 08/03/2010 9:58 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Hmm, that shouldn't cause an issue, since they would each have their own login info.

How large of a forum do you run? You might try turning off the full new post tracking in the control panel and see if that fixes it for them.

Re: Troubleshooting Fatal Error [Re: Travis T] #238461 08/03/2010 10:02 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
Board Statistics
Version: 7.5.5
Total Members: 3641
New in past 24 hours: 0
New in past 7 days: 6
New in past month: 28
Total Forums: 371
Total Topics: 4026
Total Posts: 53769

Re: Troubleshooting Fatal Error [Re: Travis T] #238462 08/03/2010 10:10 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
And it would appear that this seem to affect only new users that may have not logged in yet. This may point to what you are referring to.

How do I disable "Full new Post Tracking"? I have gone through the obvious places and haven't run across this yet.

Re: Troubleshooting Fatal Error [Re: Travis T] #238463 08/03/2010 11:18 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Hmm, that's a relatively small forum so if it is timing out due to this, then I'd say you're on a pretty slow server/host. You can try it by going into the Display Options -> General -> Primary Tab. Click on Forum Summary Options and uncheck the "Show total # of unread posts per forum" option.

Re: Troubleshooting Fatal Error [Re: Rick] #238464 08/03/2010 11:23 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
That was already unchecked.

Any other ideas?

Re: Troubleshooting Fatal Error [Re: Travis T] #238465 08/03/2010 11:25 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
Also...if I try logging in as one of the users that get these errors, I cannot log back in as myself until I close all browser windows and log back in.

Re: Troubleshooting Fatal Error [Re: Travis T] #238466 08/03/2010 11:26 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
I just tried again after rebuilding items form the Control Panel - same problem.

Fatal error: Maximum execution time of 30 seconds exceeded in C:\WEB SITES\SEMINARSTHREADS\libs\ubbthreads.inc.php on line 954

Re: Troubleshooting Fatal Error [Re: Travis T] #238467 08/03/2010 11:34 AM
Joined: Jun 2006
Posts: 9,243
Rick Offline
Former Developer
Offline
Former Developer
Joined: Jun 2006
Posts: 9,243
Can you open up a support ticket with FTP and admin info? I'd like to do some direct debugging and add some timestamps so I can get a better idea of what's going on.

Re: Troubleshooting Fatal Error [Re: Rick] #238469 08/03/2010 11:46 AM
Joined: Feb 2004
Posts: 138
Travis T Offline OP
member
OP Offline
member
Joined: Feb 2004
Posts: 138
As a matter of policy the forum servers do not have FTP, but I can share a desktop with whomever might be doing the troubleshooting.

Since the problem is easily 100% reproduce-able at any time it should be fairly easy to pin down.

I will open up a ticket now.


Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Mobile app?
by Baldeagle - 12/06/2019 9:32 PM
How do you change Text Line spacing?
by jorb - 11/23/2019 12:14 AM
What happened to FAQ or Forum Help
by Ruben - 11/20/2019 11:58 AM
Search feature encountering an Error message
by jorb - 11/20/2019 12:06 AM
Followed List v7.7.2 Question
by Ruben - 11/12/2019 12:22 PM
Who's Online Now
1 registered members (Gizmo), 57 guests, and 410 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)