Previous Thread
Next Thread
Print Thread
Hop To
Page 2 of 2 1 2
Morgan #259406 02/25/2017 11:22 AM
Joined: Dec 2003
Posts: 117
K
Member
Offline
Member
K
Joined: Dec 2003
Posts: 117
Wouldn't it be better to release these small updates and changes as a patch?

Morgan #259412 02/25/2017 12:53 PM
Joined: Feb 2004
Posts: 64
JPG Offline
Journeyman
Offline
Journeyman
Joined: Feb 2004
Posts: 64
I am having log in problems as well. I tried from a desktop, laptop and iPad on two different 7.6 forums, one being this forum. When I hit "log In" I was routed to the forum summary page - I could not access the log in page. Someone suggested trying a different connection, so I used my mobile hotspot and log in worked!

Here's a fix. If you disable "stop forum spam" the log in problem is solved. This is 100% reproducible.

JPG #259413 02/25/2017 1:04 PM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by JPG
I am having log in problems as well. I tried from a desktop, laptop and iPad on two different 7.6 forums, one being this forum. When I hit "log In" I was routed to the forum summary page - I could not access the log in page. Someone suggested trying a different connection, so I used my mobile hotspot and log in worked!

Here's a fix. If you disable "stop forum spam" the log in problem is solved. This is 100% reproducible.

Did you do this:
https://www.ubbcentral.com/forums/ubbthreads.php/topics/259319/re-login-issues#Post259319

Or did you manually edit the single file to make the correction listed here:
https://www.ubbcentral.com/forums/ubbthreads.php/topics/259286/re-login-issues#Post259286

That would have resolved the issue. The problem starts because of the beta version of the browser you're running. This is not an issue on the current Release versions of Firefox or Chrome. This is not a cookie or cache issue.

Whats happening is that the beta versions of the browsers are looking at the page before displaying it to you, and calling it a "login page." Then they are not permitting any conversation from that page, to the StopForumSpam third-party. So because SFS cannot be connected to, your forum is delivering a silent error and would take you back to the main Category/Forum page.

Performing the single modification above, resolves the check that happens when a user first gets to that login page.

Again, the only browsers currently experiencing this issue are Mobile Firefox beta, and Chrome beta/developer.


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
JPG #259415 02/25/2017 1:28 PM
Joined: May 2008
Posts: 741
Likes: 1
Old Hand
Offline
Old Hand
Joined: May 2008
Posts: 741
Likes: 1
Originally Posted by JPG
Here's a fix. If you disable "stop forum spam" the log in problem is solved. This is 100% reproducible.


I know the code tweak seems to have solved it, but this is something worth looking into, as I have SFS enabled on my site as well.


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Morgan #259416 02/25/2017 1:28 PM
Joined: Feb 2004
Posts: 64
JPG Offline
Journeyman
Offline
Journeyman
Joined: Feb 2004
Posts: 64
I’ve downloaded the latest .zip ( 5mins ago ), noted new files – login.inc.php showed a 2 line change ... I uploaded that and I still have the problem, unless I turn OFF stopforumspam.

SFS settings are ‘auto with silent fail’, when ON.

Keep in mind that the problem exists here on ubbcentral as well and I can’t turn off SFS here to really test that part.

Also, this exists on multiple browsers and multiple devices - desktop, laptop, iPad using Chrome, IE and Safari.


JPG #259421 02/25/2017 1:50 PM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by JPG
Keep in mind that the problem exists here on ubbcentral as well and I can’t turn off SFS here to really test that part.

If it exists here, and SFS is turned on here, how were you able to log in here?


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Morgan #259423 02/25/2017 1:55 PM
Joined: Apr 2007
Posts: 3,940
SD Offline
Former Developer
Offline
Former Developer
Joined: Apr 2007
Posts: 3,940
JPG was able to login here by switching over to his verizon hotspot ( new IP )

I was trying to get him to isolate different cases.

Switching hotspot also 'fixed' login on his forum as well..

2c

Last edited by SD; 02/25/2017 1:56 PM.
Bad Frog #259424 02/25/2017 1:59 PM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by Bad Frog
I know the code tweak seems to have solved it, but this is something worth looking into, as I have SFS enabled on my site as well.

It has been looked in to. This is why several browsers (Release versions, beta versions, developer versions) were tested, across several different operating systems (Windows10 DESKTOP and MOBILE, WindowsXP, Google Android 4.4 and 7.1.1, Chrome OS, Apple iOS 9.3 on iPhone and iPad).

They were tested with IPv4 and IPv6 addresses.
The problem presented itself.
A resolution was created and initiated.
The problem did not exhibit itself again.

Other than Mac, was there a browser combo not tested?


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
SD #259425 02/25/2017 2:03 PM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by SD
JPG was able to login here by switching over to his verizon hotspot ( new IP )

I was trying to get him to isolate different cases.

Switching hotspot also 'fixed' login on his forum as well..

2c

Have you tried the obvious? He could marked as a spammer, and might want to visit this page to get his address corrected.
http://stopforumspam.com/removal


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
isaac #259426 02/25/2017 2:07 PM
Joined: May 2008
Posts: 741
Likes: 1
Old Hand
Offline
Old Hand
Joined: May 2008
Posts: 741
Likes: 1
Originally Posted by id242
Originally Posted by Bad Frog
I know the code tweak seems to have solved it, but this is something worth looking into, as I have SFS enabled on my site as well.

It has been looked in to. This is why several browsers (Release versions, beta versions, developer versions) were tested, across several different operating systems (Windows10 DESKTOP and MOBILE, WindowsXP, Google Android 4.4 and 7.1.1, Chrome OS, Apple iOS 9.3 on iPhone and iPad).

They were tested with IPv4 and IPv6 addresses.
The problem presented itself.
A resolution was created and initiated.
The problem did not exhibit itself again.

Other than Mac, was there a browser combo not tested?

only suggested it as I hadn't seen SFS mentioned in the previous troubleshooting


"No matter where you go, there you are."
"If you can't do something smart, Do something right"
"There are three kinds of people in the world, those who can count, and those who can't"
Bad Frog #259428 02/25/2017 2:14 PM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by Bad Frog
only suggested it as I hadn't seen SFS mentioned in the previous troubleshooting

The "login" file which had the two single lines edited, was purely related to SFS. It was to help prevent a Spammer from logging in to your forum.

From:
Control Panel » Primary Settings
Stop Forum Spam tab

Quote
Stop Forum Spam provides free access to a database of known forum and blog spammers. UBB.threads can connect with this database to check Email Addresses and IP Addresses in an attempt to block known spammers from creating new accounts, and logging in to post on your forum.


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
isaac #259429 02/25/2017 2:19 PM
Joined: Feb 2004
Posts: 64
JPG Offline
Journeyman
Offline
Journeyman
Joined: Feb 2004
Posts: 64
Originally Posted by id242
Originally Posted by SD
JPG was able to login here by switching over to his verizon hotspot ( new IP )

I was trying to get him to isolate different cases.

Switching hotspot also 'fixed' login on his forum as well..

2c

Have you tried the obvious? He could marked as a spammer, and might want to visit this page to get his address corrected.
http://stopforumspam.com/removal

OK, the obvious seems to have been the problem. Not sure why I am able to log in to forums running 7.5.8 and couldn't log in to 7.6, but this new IP I have is listed at stopforumspam. I requested removal.

JPG #259430 02/25/2017 2:23 PM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by JPG
OK, the obvious seems to have been the problem. Not sure why I am able to log in to forums running 7.5.8 and couldn't log in to 7.6, but this new IP I have is listed at stopforumspam. I requested removal.

The reason why you could login to 7.5.8 is because SD never implimented the full SFS when he used Gizmo's code. SD only used what he wanted to use, which was just checking SFS at the time of posting.

760 includes the entire SFS package. Which checks at login, account creation, sending PM, posting messages/replies. The entire package, as Gizmo had originally written it.

In addition, 760 supports IPv4 and IPv6.
758 only supported IPv4.

Source1:
https://www.ubbdev.com/forums/ubbth...um-spam-integration-v0-5.html#Post318736

Source2:
https://www.ubbdev.com/forums/ubbth...5-7-stop-forum-spam-login-detection.html


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Morgan #259441 02/25/2017 8:53 PM
Joined: Feb 2004
Posts: 64
JPG Offline
Journeyman
Offline
Journeyman
Joined: Feb 2004
Posts: 64
My problem reminds me of the movie Sling Blade.


Morgan #259502 02/27/2017 5:01 AM
Joined: Jun 2006
Posts: 898
Likes: 23
Morgan Offline OP
Old Hand
OP Offline
Old Hand
Joined: Jun 2006
Posts: 898
Likes: 23
OK back at work and can't login the regular way. tried also att UBBDEV and noticed below message.
Obvialsy our Company ip is bad i guess


Quote
Your IP address is currently listed in the Stop Forum Spam database as a known spammer/spambot, and as such your account cannot be registered. To proceed you'll need to request a removal to clear yourself from their database.


Morgan Johansson
BritBike Forum
https://www.britbike.com/forums/ubbthreads.php
Morgan #259503 02/27/2017 5:06 AM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by Morgan
OK back at work and can't login the regular way. tried also att UBBDEV and noticed below message.
Obvialsy our Company ip is bad i guess


Quote
Your IP address is currently listed in the Stop Forum Spam database as a known spammer/spambot, and as such your account cannot be registered. To proceed you'll need to request a removal to clear yourself from their database.

Request a removal.
http://stopforumspam.com/removal
Its pretty simple to submit, and usually reviewed within the same day.

edit: i just checked the ip address of your last post. Its not in the SFS database, as far as I could tell.

edit2: i do see that your ip address was listed 8 times in this list:
http://whatismyipaddress.com/blacklist-check
maybe you're on a shared address...

Last edited by id242; 02/27/2017 5:11 AM.

Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Morgan #259504 02/27/2017 5:16 AM
Joined: Jun 2006
Posts: 898
Likes: 23
Morgan Offline OP
Old Hand
OP Offline
Old Hand
Joined: Jun 2006
Posts: 898
Likes: 23
Now I understand.
our Company IP address is as bad according to Stop forum spam and i had settings set to Auto with Silent Fail

changing it to Auto with Message brought up a message with that info.
with Manual or Semi-Auto its still possible to login.. and there was light finally..

Quote
Spam Protection Level

You have four choices; Manual (initial setting), Semi-Auto, Auto with message to Registrant and Auto with silent Fail. Each have their pros and cons.
•Manual - This allows the Admin to easily check new registrations with one click
•Semi-Auto - This automatically checks new registrations in member management, but might delay, if there are timeouts with StopForumSpam
•Auto with Message - Adds to Semi-Auto and gives a new registrant a message that they were blocked and how to remedy the situation
•Auto with Silent Fail - Does what Auto with Message does, but fails silently, which might fool spammers into thinking they signed up.


Morgan Johansson
BritBike Forum
https://www.britbike.com/forums/ubbthreads.php
Morgan #259505 02/27/2017 5:20 AM
Joined: Jun 2006
Posts: 898
Likes: 23
Morgan Offline OP
Old Hand
OP Offline
Old Hand
Joined: Jun 2006
Posts: 898
Likes: 23
Isaac, I'm on the Swedish Posts server here so there are many shared users


Morgan Johansson
BritBike Forum
https://www.britbike.com/forums/ubbthreads.php
Morgan #259506 02/27/2017 5:20 AM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
I believe that as a regular user (not an admin account) who has been flagged in SFS, posting and sending message is blocked. So even if a spammer gets in through an error page, they are blocked from doing a bit of interacting.


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Morgan #259507 02/27/2017 5:23 AM
Joined: Apr 2004
Posts: 1,842
Likes: 110
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,842
Likes: 110
Originally Posted by Morgan
Isaac, I'm on the Swedish Posts server here so there are many shared users

smile


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Page 2 of 2 1 2

Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Scroll Up Button
by JAISP - 04/28/2021 7:39 AM
[Cannot Replicate] Unapprove Post Bug
by Larry Miller - 04/26/2021 10:07 AM
Just popping in
by Harold - 04/25/2021 9:05 PM
Moving Forum/Category location
by ECNet - 04/25/2021 12:11 PM
7.7.5 become member issue
by Ruben - 04/15/2021 10:06 AM
Who's Online Now
1 members (Ruben), 76 guests, and 54 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5