Previous Thread
Next Thread
Print Thread
Hop To
https http #261457 05/22/2018 5:46 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
Hello, I am having a slight problem here with this link at the bottom of the page.
Powered by UBB.threads™ PHP Forum Software 7.6.0

This link is http and our site is https, so we are getting (Connection is not Secure) do to this link. Any quick fix on this?

Express Hosting
Re: https http [Re: sundance] #261458 05/22/2018 5:58 PM
Joined: Apr 2004
Posts: 1,494
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,494
A simple link to an http domain will not cause https issues unless it is serving content (gif, jpg, css, any content...etc) sitting on that http domain, which the copyright notice is not doing.

have a look at content on your https page, being served from an http link. especially have a look at your users avatars, user signatures, and even your custom styles. you may also have ads or third-party APIs attempteming to insert insecure http content on to your https pages.

but a simple off-site http url link will not trigger https warnings.


off topic... ubb.threads 7.6.0 was released Febuary 2017. ubbcentral.com was fully upgraded from http to https sometime mid to late 2017. The current version of ubb.threads is 7.6.1.1, which was released January 2018.

Last edited by isaac; 05/22/2018 6:03 PM. Reason: corrected a keyboard autocorrect typo

isaac @ id242.com // my forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.7.3 released!
Re: https http [Re: isaac] #261459 05/22/2018 6:55 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
OK , I checked it out and you were right, it was this smiley in one of the admins profile. TY

Re: https http [Re: sundance] #261460 05/23/2018 6:13 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
OK new problem now. Yesterday when making changes some links Chrome deleted some of my files in General HTML Includes and I lost my Default Header and Footer. I was able to restore the Header and Footer from a backup file I had but I can not seem to find the Body Onload file. Can someone tell the code for that.

One other problem I am having is I cannot load an image using UBB, so something changed on that as well, help please?

and why are we getting this error message, this has been going on for some time now???
https://sundance-communications.com/forum/ubbthreads.php/galleries/620212/error

Last edited by sundance; 05/23/2018 7:04 PM.
Re: https http [Re: sundance] #261461 05/23/2018 7:35 PM
Joined: Apr 2004
Posts: 1,494
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,494
Quote
I can not seem to find the Body Onload file. Can someone tell the code for that.

Attached is a screenshot of the default "HTML Includes" settings for a fresh install of UBB.threads:

The default settings are: all fields are blank.


Quote
One other problem I am having is I cannot load an image using UBB, so something changed on that as well, help please?

Confirm that your forum paths are correct:
Control Panel / Master Settings: Database & Paths [Paths & URLs tab]


Quote
and why are we getting this error message, this has been going on for some time now???

Control Panel / Display: General [New Post/Reply Page Settings section]
"Maximum Number of Nested Quotes in a Post" - Enter a number for this setting. The default is 4.

Attached Files 20180523_16-28-59.PNG
Last edited by isaac; 05/23/2018 7:42 PM.

isaac @ id242.com // my forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.7.3 released!
Re: https http [Re: sundance] #261463 05/24/2018 10:15 AM
Joined: Dec 2003
Posts: 5,940
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,940
Sounds to me like your includes/config.inc.php file got wiped.
Not just your header and footer files.
Every item you talked about is stored in that file.

You need to restore it from what ever backup you have.
Then review every setting in the ubb control panel, even if the setting looks correct elect the save/update button at the bottom.

The body on load file is a option for a custom code that you add.

This was a issue a while back where the config file would wipe to 0 bytes.
This was addressed several times over the last couple of versions.

Last edited by Ruben; 05/24/2018 12:10 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: https http [Re: Ruben] #261464 05/24/2018 4:47 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
I think I have everything back on line but the images are not loading on new post, any ideas?

Re: https http [Re: sundance] #261465 05/24/2018 4:49 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
I guess here is another one,

Another, the follow topic doesn't seem to be working. I've taken it off topics I was following and can't get it back. I did this because curlycord in his topic said that wasn't working for him. I tried several new topics and that didn't work so that's why I took it off topics that were being followed to see if I could get it back, Including this thread.

Re: https http [Re: sundance] #261466 05/24/2018 4:50 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
And this is what I am getting on trying to load an image,

[Linked Image]

Also cant load any new image in the photo section forum??

Re: https http [Re: isaac] #261467 05/24/2018 4:57 PM
Joined: Apr 2004
Posts: 1,494
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,494
Originally Posted by sundance
And this is what I am getting on trying to load an image,

[Linked Image]

Also cant load any new image in the photo section forum??


This question was previously answered as:

Originally Posted by isaac
Quote
and why are we getting this error message, this has been going on for some time now???

Control Panel / Display: General [New Post/Reply Page Settings section]
"Maximum Number of Nested Quotes in a Post" - Enter a number for this setting. The default is 4.


If you are having issues with attached images not displaying, confirm that your paths are also correct:
Control Panel / Master Settings: Features [Attachments tab]
Absolute PATH to Attachment Storage Directory
and
Full URL to Attachment Storage Directory


isaac @ id242.com // my forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.7.3 released!
Re: https http [Re: sundance] #261468 05/24/2018 5:02 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
OK, I got the images to work and the quotes

Re: https http [Re: sundance] #261469 05/24/2018 5:03 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
What would keep this from working(the follow topic doesn't seem to be working)?

Re: https http [Re: sundance] #261470 05/24/2018 5:07 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
Another weird one, it is showing on Whos Online Now 0 guests??

Re: https http [Re: sundance] #261471 05/24/2018 5:14 PM
Joined: Apr 2004
Posts: 1,494
isaac Offline
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,494
As Ruben mentioned above, it sounds like your includes/config.inc.php file got wiped.

When you restored the config file from your earlier backup, the file you restored may have had outdated settings in it. Always make sure to have a relatively recent backup of your files and setting.

I also see that you are on UBB.threads 7.6.0. You should look at upgrading to at least version 7.6.1, where the config file is automatically backed before any changes are being made and a new one is created.

Originally Posted by isaac
UBB.threads 7.6.1 Changelog 2017-05-02
[NEW] The current forum config file is now backed up before new changes are saved. Normally there would be no need for this step, though an incorrectly configured server or php.ini setting may cause havoc and corrupt the new config file creation process. A forum owner can now roll back to their backup config file, if the new one was corrupted upon its creation.

SOURCE: https://www.ubbcentral.com/forums/u...e-ubb-threads-7-6-1-changelog#Post260196


isaac @ id242.com // my forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.7.3 released!
Re: https http [Re: sundance] #261472 05/24/2018 5:43 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
I have not been using the backups to bring this back online just manually putting in the info. I do have 7.6.0

Can you tell me where and what setting for,
What would keep this from working(the follow topic doesn't seem to be working)?
Another weird one, it is showing on Whos Online Now 0 guests??

Re: https http [Re: sundance] #261473 05/25/2018 12:28 PM
Joined: Dec 2003
Posts: 5,940
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,940
On your site files for ubb you have a includes folder.
In that folder is a filename
config.inc.php

It holds most all the settings for your site that you enter in the ubb control panel.
You can look and edit it from a text editor. Like notepad or Notepad ++ do not use wordpad or word.

I appears that the file got corrupted or deleted somehow

If you have any type of current backup of the script files after installation then upload that to the site to overwrite the file.
You might even find your custom body on load.

As a precaution I would ftp to the site just to make sure the config.inc.php file exists before you start anything.
And if you find a backup config file view the contents to see if it would be better to use it or let it be.

If you don't have a usable backup then below still applies.

Then in ubb control panel
Methodically review every single section and every single entry field one at a time edit what needs to be corrected and save/update.
Even if it looks correct with no edits save/update.

In the future I would at the very least make regular backups of the includes folder.
This is not a substitute for a full backup of files and database

You can find a dummy config file at ubbwiki.
to compare to what you should have.
https://www.ubbwiki.com/archive/fetch/1/ubb-threads-v7-config-file.html
It will have different data than what you need but it will contain all the fields blank or not for what your forum needs.

Only you will know what your settings should be.
Every site is different.


Last edited by Ruben; 05/25/2018 12:52 PM.

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: https http [Re: Ruben] #261474 05/25/2018 1:57 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
Ruben,

I totally understand what you are saying and what to do. I dont want to run a backup that's for sure. I have these files on my PC somewhere but I dont trust myself to make changes in the includes folder or others. Can you do it for me or at least take a look at it?

Re: https http [Re: sundance] #261475 05/25/2018 2:07 PM
Joined: Dec 2003
Posts: 5,940
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,940
Well I can if you wish.
If you can send me ftp login via PM I can take a look.
That means all I can do is check file permissions and file integrity.
If you wish me to look at the ubb control panel I would need admin access which I am not a registered member yet at your board.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: https http [Re: sundance] #261476 05/25/2018 2:16 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
Yes I will now

Re: https http [Re: sundance] #261477 05/25/2018 2:19 PM
Joined: Aug 2012
Posts: 113
sundance Offline OP
member
OP Offline
member
Joined: Aug 2012
Posts: 113
what is your email?

Re: https http [Re: sundance] #261478 05/25/2018 2:20 PM
Joined: Dec 2003
Posts: 5,940
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,940
I sent it via PM


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Re: https http [Re: sundance] #261490 05/27/2018 2:54 PM
Joined: Dec 2003
Posts: 5,940
Ruben Offline
Offline
Joined: Dec 2003
Posts: 5,940
According to the user the issues were resolved.
who is online agents had formatting similar to a htaccess file.
With extra line feeds for allow deny.
Replaced with a default spider list.

Attachments path was incorrect corrected same.
Reviewed many of the cp settings and re-saved.
Never got a backup file/files or ftp access.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Additional Resources
UBB Developers
UBB Wiki
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Strange Merge Issue
by Baldeagle - 08/16/2019 3:37 PM
Formatting Links
by Ty Griffin - 08/13/2019 4:39 PM
Changing from iso-8859-1 to UTF-8?
by Daryl Fawcett - 08/13/2019 9:58 AM
Threaded Mode
by ToddUGA - 08/10/2019 9:18 PM
Who's Online Now
3 registered members (SD, Gizmo, ECNet), 52 guests, and 229 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
d-talk
d-talk
Germany
Posts: 90
Joined: June 2006
Show All Member Profiles 
Forum Statistics
Forums34
Topics35,320
Posts192,716
Members11,865
Most Online2,569
Jul 27th, 2019
Random Gallery Image
Latest Photos
The Sky
Land Rocks
Cozy Places
Trees
Powered by UBB.threads™ PHP Forum Software 7.7.3