Previous Thread
Next Thread
Print Thread
Hop To
#264165 09/16/2020 8:36 AM
Joined: Jan 2010
Posts: 9
M
Stranger
OP Offline
Stranger
M
Joined: Jan 2010
Posts: 9
My forum (version 7.5.6p1) has recently developed an issue where replies are visible (in 'Preview Post') but then don’t appear when the reply is actually submitted. This applies with ‘Reply’ and ‘Quote’. I’d be interested to know if anyone else has encountered this issue - and found out how to rectify it. Many thanks in advance.

Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
This could be due to two possible causes.
One is there was a bug that presented this behavior but was squashed in newer releases.
Or it could be your php settings are incorrect such as max_input_variables.
Try the link below to download the ubb test script to check your hosting settings for compatibility.with UBB

https://www.ubbwiki.com/latest/system-requirements-test
If the max_input_variables are suspect read up at:
https://www.ubbwiki.com/article/view/25/issues-with-the-php-max_input_vars-setting.html

Remember the UBBWIKI is your friend.

PS
I would also suspect your host has upgraded you to php7.x which your UBB version is not rated for.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 16,039
Likes: 66
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,039
Likes: 66
There are numerous reports of this behavior on outdated forum versions (this was fixed in UBB.threads v7.5.8 and improved in v7.7.5; this happens when special/uft8 characters are inserted on PHP 5.4 or php.ini server configuration that HIDES the entire text block; they are now run through htmlspecialchars); the fix would be to upgrade your forums from your build, which was released in 2010, and to run the content rebuilders once you're running something that isn't severely outdated.

Some of the aforementioned reports:
https://www.ubbcentral.com/forums/ubbthreads.php/topics/253582/empty-posts
https://www.ubbcentral.com/forums/ubbthreads.php/topics/256299/7-5-7-posts-disappering

Also, max_input_vars would only affect editing permissions on sites with a lot of forums, and would have no affect on the reported behavior.

Again, your UBB.threads version was released 10 years ago, before UTF8 became a standard; you should really keep up on updates to both PHP and UBB.threads as many bugs have been fixed in the last decade. There have also been significant security related changes to the UBB.threads package as well as within PHP in the last decade.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Joined: Jan 2010
Posts: 9
M
Stranger
OP Offline
Stranger
M
Joined: Jan 2010
Posts: 9
Thank-you for your replies - and please accept my apologies for not responding sooner...

It looks like updating my version of The Forum is definitely the way forward...

However, to compound this issue, my ISP has just upgraded the platform onto which my Forum is currently located.
I presume that the IP address will have changed as part of this move - but I can't now access The Forum's control panel, and instead get the following error message...

UBB Message
We encountered a problem. The reason reported was
Database error only visible to forum administrators
Please click back to return to the previous page.

* The 'back' button here is a link to the previous page in my browser history.

Is there another way to get into the Control Panel? Many thanks in advance.

Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
I would suspect that the host updated your php to version 7.x of which your forum version is not compatible,
I would first log into your hosting cpanel and check if that is in fact true.
Most host will let you roll back to a older php version for a while.
But you probably were on php 5.x

Also while there you may be able to look at the error logs but that error usually means the database can't be found.
So I would check if the database is there and verify the database path, name and database user and database user password
Then compare it to forum/includes/config.inc.php and update that files contents on the top couple of lines with the database info


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
Update.
Well it appears that you are still on php 5.6 because anyone can get to phpinfo
So I would suspect that the includes/config.inc.php file got wiped to 0 meaning the contents are gone which is another issue with that version and another reason to upgrade.

Anyway check that file with a text editor and see if it has any content and that the top few lines are correct for connecting to your database.
Maybe you have a old backup you can get a copy of that file to use.

And delete that phpinfo file or rename it to something you can remember to stop people like me seeing it..

Last edited by Ruben; 02/02/2021 1:50 PM. Reason: Added Comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jan 2010
Posts: 9
M
Stranger
OP Offline
Stranger
M
Joined: Jan 2010
Posts: 9
Thank-you for your answers...

Yes, the name, location and password have all changed. I've gone back to the ISP and asked why this has happened.
Would renaming the database stop it from working?

Many thanks in advance.

Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
Yes it would not work.
As I said before edit your forum/includes/config.inc.php file,

Change the top few lines to what it is now or what you change them to be.
Do not delete the quote surrounding the fields:

'DATABASE_SERVER' => 'USUALLY IS localhost',
'DATABASE_USER' => 'change to database user name',
'DATABASE_PASSWORD' => 'change to database user password',
'DATABASE_NAME' => 'change to database name',


This section tells the forum software how to login to the database.
If it is incorrect now then the forum can't login to the database and shows an error.
Because it can't find the posts and replies nor can it save new posts.

Hopefully everything else in the file is intact and correct.
But you should review it anyway while you are there.
When done make sure to save to the server in the includes folder.

Last edited by Ruben; 02/07/2021 2:07 PM. Reason: Added Comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 16,039
Likes: 66
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,039
Likes: 66
Originally Posted by Metamatic
UBB Message
We encountered a problem. The reason reported was
Database error only visible to forum administrators
Please click back to return to the previous page.

* The 'back' button here is a link to the previous page in my browser history.
This is a generalized error that generally indicates a configuration issue (such as the database information being incorrect); you can disable the mechanism that hides the message (it does so for security [passwords can be displayed], if your forums are configured to save errors to a log file it'll be displayed there) by editing the libs/mysqli.inc.php file and changing:
Code
$showerror = 0;

To:
Code
$showerror = 1;

Be sure to change the value back once the error message has been viewed (as again it can contain connection information for your server, saving logs is the recommended option).


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
1 member likes this: isaac
Joined: Jan 2010
Posts: 9
M
Stranger
OP Offline
Stranger
M
Joined: Jan 2010
Posts: 9
Originally Posted by Gizmo
Originally Posted by Metamatic
UBB Message
We encountered a problem. The reason reported was
Database error only visible to forum administrators
Please click back to return to the previous page.

* The 'back' button here is a link to the previous page in my browser history.
This is a generalized error that generally indicates a configuration issue (such as the database information being incorrect); you can disable the mechanism that hides the message (it does so for security [passwords can be displayed], if your forums are configured to save errors to a log file it'll be displayed there) by editing the libs/mysqli.inc.php file and changing:
Code
$showerror = 0;

To:
Code
$showerror = 1;

Be sure to change the value back once the error message has been viewed (as again it can contain connection information for your server, saving logs is the recommended option).

Thanks for your reply - it's very much appreciated.
I followed your instructions, and the 'expanded' Error Message was as follows...

We encountered a problem. The reason reported was
Script: /home/ihlpfi7ucy12/public_html/forum/libs/user.inc.php
Line#: 467
SQL Error: Table 'ihlpfi7_ubb18394.ubbt_USERS' doesn't exist
SQL Error #: 1146
Query: SELECT t2.USER_TOPIC_VIEW_TYPE, t1.USER_ID, t1.USER_DISPLAY_NAME, t1.USER_PASSWORD, t1.USER_SESSION_ID, t1.USER_MEMBERSHIP_LEVEL, t1.USER_IS_BANNED,t1.USER_RULES_ACCEPTED, t1.USER_IS_UNDERAGE, t2.USER_TOTAL_PM, t2.USER_STYLE, t2.USER_HIDE_LEFT_COLUMN,t2.USER_HIDE_RIGHT_COLUMN, t2.USER_LANGUAGE, t2.USER_MOOD, t2.USER_RELATIVE_TIME, t2.USER_TIME_OFFSET,t2.USER_SHOW_ALL_GRAEMLINS, t2.USER_AVATAR, t2.USER_TITLE, t2.USER_CUSTOM_TITLE, t2.USER_NAME_COLOR, t2.USER_SHOW_LEFT_MYSTUFF,t2.USER_GROUP_IMAGES,t2.USER_TIME_FORMAT FROM ubbt_USERS as t1, ubbt_USER_PROFILE as t2 WHERE t1.USER_ID = 0 AND t1.USER_ID = t2.USER_ID


I've asked my ISP if there's an issue with the server - and they've confirmed that there isn't.

Joined: Jan 2010
Posts: 9
M
Stranger
OP Offline
Stranger
M
Joined: Jan 2010
Posts: 9
Also, I should add that I've checked the "user.inc.php" file - and the file on the new server appears to be identical to the back-up copy I have.

Joined: Apr 2004
Posts: 1,827
Likes: 109
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,827
Likes: 109
The /home/ihlpfi7ucy12/public_html/forum/libs/user.inc.php script is trying to connect to the 'ihlpfi7_ubb18394.ubbt_USERS' table

The error reported is:
SQL Error: Table 'ihlpfi7_ubb18394.ubbt_USERS' doesn't exist

This means that the database table does not exist, or cannot be found / connected to.

Check that your database and tables do in fact exist and are reachable.
Manually check that your SQL settings at the top of your includes/config.php.ini are correct.


Current developer of UBB.threads PHP Forum Software
Current Release: UBBT 7.7.5 // Work In Progress: soon
isaac @ id242.com // my forum @ CelicaHobby.com
Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
You said that the database info was changed by your host , I would bet probably the prefix,
If so then your forum/includes/config.inc.php is now incorrect so the other file crashes.
As been mentioned a few times you need to check this

Probably the best way is using your hosting cpanel.
Goto phpmyadmin.
Make sure you have around 64 tables and there is data in almost all of them.
If tables like users, posts or topics are empty you found a problem and need to load a database backup

Then while still in cpanel

Goto where you create the databases and users and verify the full names including the prefix of your forum database and assigned database user.

Might as well check to make sure that the password is correct or just change the password even if you make it the same.
Make a note of database name,database user name including the prefix and underscore or whatever and password
Also make sure the database user has global privileges.

Then while still in cpanel

Goto the file manager and find forum/includes/config.inc.php
Edit that file with the built in text editor.
The top few lines I have shown before are the database entries.
Correct them as needed save and check your forum

Unless you need to reload the database this should take about 10 minutes.

As a hint from your error it appears that ihlpfi7 is now something like ihlpfi7ucy12nd your user is ihlpfi7ucy12nd_ubb18394
or vice versa

This step is not uncommon when say moving the forum to a new host.
In your case it looks like your host moved you to a new server.

So it sounds like you may need to edit more that the top few lines in forum/includes/config.inc.php for absolute paths.

Last edited by Ruben; 02/10/2021 1:42 PM. Reason: Added Comment

Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
I sent you a PM.
Which you have not read.

I would be happy to help you.
Unless something is corrupted this is a simple task to do.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Dec 2003
Posts: 6,310
Likes: 48
Online Yawn
Joined: Dec 2003
Posts: 6,310
Likes: 48
Congratulations I see you finally got your forum up and running as well as upgraded to the latest version UBB 7.7.5 and changed your php to 7.4 which is supported now! thumbsup
A lot of changes and enhancements have happened since the version you had so feel free to ask questions.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers

Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Admin / User question /feedback
by Morgan - 02/25/2021 5:18 AM
Active links corrupts image links/urls
by Morgan - 02/24/2021 1:03 PM
Return to Page
by Abbott - 02/20/2021 9:57 AM
Importers folder?
by DaveZ - 02/18/2021 11:31 AM
PM Next and Prior
by Abbott - 02/15/2021 4:37 PM
Who's Online Now
2 members (Ruben, DaveZ), 48 guests, and 52 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
gallery test
gallery test
by Mors, September 23
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Powered by UBB.threads™ PHP Forum Software 7.7.5