Previous Thread
Next Thread
Print Thread
Hop To
#264165 09/16/2020 9:36 AM
Joined: Jan 2010
Posts: 5
Stranger
OP Offline
Stranger
Joined: Jan 2010
Posts: 5
My forum (version 7.5.6p1) has recently developed an issue where replies are visible (in 'Preview Post') but then don’t appear when the reply is actually submitted. This applies with ‘Reply’ and ‘Quote’. I’d be interested to know if anyone else has encountered this issue - and found out how to rectify it. Many thanks in advance.

Joined: Dec 2003
Posts: 6,198
Likes: 30
Offline
Joined: Dec 2003
Posts: 6,198
Likes: 30
This could be due to two possible causes.
One is there was a bug that presented this behavior but was squashed in newer releases.
Or it could be your php settings are incorrect such as max_input_variables.
Try the link below to download the ubb test script to check your hosting settings for compatibility.with UBB

https://www.ubbwiki.com/latest/system-requirements-test
If the max_input_variables are suspect read up at:
https://www.ubbwiki.com/article/view/25/issues-with-the-php-max_input_vars-setting.html

Remember the UBBWIKI is your friend.

PS
I would also suspect your host has upgraded you to php7.x which your UBB version is not rated for.


Blue Man Group
There is no such thing as stupid questions. Just stupid answers
Joined: Jun 2006
Posts: 15,961
Likes: 34
UBB.threads Developer
Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 15,961
Likes: 34
There are numerous reports of this behavior on outdated forum versions (this was fixed in UBB.threads v7.5.8 and improved in v7.7.5; this happens when special/uft8 characters are inserted on PHP 5.4 or php.ini server configuration that HIDES the entire text block; they are now run through htmlspecialchars); the fix would be to upgrade your forums from your build, which was released in 2010, and to run the content rebuilders once you're running something that isn't severely outdated.

Some of the aforementioned reports:
https://www.ubbcentral.com/forums/ubbthreads.php/topics/253582/empty-posts
https://www.ubbcentral.com/forums/ubbthreads.php/topics/256299/7-5-7-posts-disappering

Also, max_input_vars would only affect editing permissions on sites with a lot of forums, and would have no affect on the reported behavior.

Again, your UBB.threads version was released 10 years ago, before UTF8 became a standard; you should really keep up on updates to both PHP and UBB.threads as many bugs have been fixed in the last decade. There have also been significant security related changes to the UBB.threads package as well as within PHP in the last decade.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Do you need Forum Install or Upgrade Services?
Forums: A Gardeners Forum, Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!

Link Copied to Clipboard
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
[FIXED for 7.7.5] Broken CP Link
by JAISP - 09/17/2020 3:22 PM
Empty Replies and Quotes...
by Metamatic - 09/16/2020 9:36 AM
Ignore thread option?
by Morgan - 09/09/2020 2:37 PM
Forum help page
by Morgan - 09/09/2020 2:41 AM
php & mysql version needed
by DennyP - 09/01/2020 9:47 PM
Who's Online Now
1 members (JAISP), 83 guests, and 50 robots.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Los Angeles
Los Angeles
by isaac, August 6
3D Creations
3D Creations
by JAISP, December 30
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200903)