|
|
Joined: Jun 2006
Posts: 1,090 Likes: 30
Old Hand
|
|
Old Hand
Joined: Jun 2006
Posts: 1,090 Likes: 30 |
Using UBBT 8.0.1 php 8.3.32 I am confused Our UBBT forum has been around for 25+ years. Nowadays I can see below example of error messages. I use standard amount of connections 151 just like this forum and the developers. If it's not a bug feel free to delete. The last days have generated lots of logs like below. example 1 [01-Aug-2026 23:13:59 UTC] PHP Fatal error: Uncaught mysqli_sql_exception: Too many connections in /xxxxx/xxxxx/xxxxx/forums/libs/mysqli.inc.php:28 Stack trace: #0 /xxxxx/xxxxx/xxxxx/forums/libs/mysqli.inc.php(28): mysqli_connect('localhost', 'xxxxx', Object(SensitiveParameterValue), 'xxxxx') #1 /xxxxx/xxxxx/xxxxx/forums/libs/ubbthreads.inc.php(101): sql->connect() #2 /xxxxx/xxxxx/xxxxx/forums/ubbthreads.php(45): require_once('/xxxxx/xxxxx/...') #3 {main} thrown in /xxxxx/xxxxx/xxxxx/forums/libs/mysqli.inc.php on line 28 example 2 [03-Aug-2026 00:55:31 UTC] PHP Fatal error: Uncaught TypeError: sizeof(): Argument #1 ($value) must be of type Countable|array, false given in /xxxxx/xxxxx/xxxxx/forums/scripts/sendmessage.inc.php:109 Stack trace: #0 /xxxxx/xxxxx/xxxxx/forums/ubbthreads.php(286): page_sendmessage_run() #1 {main} thrown in /xxxxx/xxxxx/xxxxx/forums/scripts/sendmessage.inc.php on line 109
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
example 1 is indeed stating there are too many connections to the SQL Server and is a message from your MySQL server.
Example 2 appears to be a PHP8.3 error counting the size of an array when a PM is sent which we'll get added to the list of PHP8 errors
|
|
|
|
|
Joined: Jun 2006
Posts: 1,090 Likes: 30
Old Hand
|
|
Old Hand
Joined: Jun 2006
Posts: 1,090 Likes: 30 |
Hi Giz Example 1, I will have to increase the connections settings then.
Example 2, if I understand it right then with php8.3 the script needs a rewrite to avoid this error if I understand correctly? Should I go back to let say php8.0 I am not sure if 7.4 works on my new almalinux 10 server.
Ps have you and Isaac checked if your error logs show similar logs?
Last edited by Morgan; 08/06/2026 1:36 AM.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
It should be fine to run, it's just a PHP8 error that needs to be fixed but it's just counting participents, I'd check that you can still send PTs and if so just leave it for the time being.
Basically PHP8 runs in strict mode which shows all errors, PHP7 and prior allow a lot of loose code to run that wouldn't run in strict mode.
|
|
|
|
|
Joined: Jun 2006
Posts: 1,090 Likes: 30
Old Hand
|
|
Old Hand
Joined: Jun 2006
Posts: 1,090 Likes: 30 |
OK Thanks,
With PT I guess you mean PM as in Private message right?
I normally don't look at the forum error log but had to when the attachment folder chmod issue appeared. since May the error log file is now 8,5MB in size. I grew 1MB over the last week. What happen if I delete it or rename it will the system create a new error log file when next error happen?
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Yes, sending a Private Message is what's triggering it, but it looks like it could also be the display of messages.
If it's the UBB.threads error logs they'll make themselves if you purge, if it's the system error log you might not be able to delete it but any logs should make themselves when a new error arises.
|
|
|
|
|
Joined: Jun 2006
Posts: 1,090 Likes: 30
Old Hand
|
|
Old Hand
Joined: Jun 2006
Posts: 1,090 Likes: 30 |
Giz, I open a ticket to see what my host says and the answer to "max_connections" was I realize that some is not support on here but what do you say about the second and third? any input is appreciated cheers In addition to increasing the connection limit, we recommend:
Reviewing the MySQL process list for long-running or sleeping connections.
Enabling and reviewing the MySQL slow query log to identify inefficient queries.
Checking whether your forum software is leaving database connections open longer than necessary.
Monitoring overall server resources (CPU, RAM, and I/O), as increasing max_connections also increases memory usage.
|
|
|
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150
|
|
Joined: Jun 2006
Posts: 16,532 Likes: 150 |
Sometimes connection errors just happen, especially during server maintenance tasks; it's generally not something to worry about unless it's happening constantly.
|
|
|
|
0 members (),
270
guests, and
100
robots. |
|
Key:
Admin,
Global Mod,
Mod
|
|
|
|