Previous Thread
Next Thread
Print Thread
Hop To
Php accelerator error404 due to wrong url? #88811 04/03/2005 4:54 PM
Joined: Jan 2004
Posts: 43
noox Offline OP
newbie
OP Offline
newbie
Joined: Jan 2004
Posts: 43
Board is version 6.7.0, php 4.0.6

When I enable php accelerator the links to posts and forums changes from ....ulimatebb.cgi/topic to ...ultimatebb.php/topic/etc etc etc

The new ".php" links always result in a 404 error and I have to disable the php accelerator. The new links (with php in them) are essentially going to posts and forums that didnt have "php" in the url until I enabled the option. So technically, they are ERROR404 pages

This is the 2nd time in over a year that I decided to focus on the accelerator option.

Is it something as simple as a rebuild on the forums or shouldnt the ubb program adust for the url change?

Re: Php accelerator error404 due to wrong url? #88812 04/03/2005 5:32 PM
Joined: Jan 2004
Posts: 43
noox Offline OP
newbie
OP Offline
newbie
Joined: Jan 2004
Posts: 43
forgot to add - I do have the Use Spider-friendly URL Compatibility Mode? enabled.

I tried all settings. PHP accel alone, without spider friendly, alsop results in 404 pages

Re: Php accelerator error404 due to wrong url? #88813 04/03/2005 5:36 PM
Joined: Jan 2004
Posts: 43
noox Offline OP
newbie
OP Offline
newbie
Joined: Jan 2004
Posts: 43
1 more edit. sorry. I got this error when I went to

www.mydomainaddress.com/ultimatebb.php

Accelerator Error:
I was unable to locate my variables file. Please submit Configuration Settings in your UBB.classic control panel.

My ultimatebb.cgi has been working since 6.7.0 was released.

Re: Php accelerator error404 due to wrong url? #88814 04/03/2005 5:43 PM
Joined: Jan 2004
Posts: 43
noox Offline OP
newbie
OP Offline
newbie
Joined: Jan 2004
Posts: 43
1 final update: I browsed the ultimatebb.php file and saw that its looking for a php file called vars_config.inc.php That file is not in any of my folders. I have only cgi files and the ultimatebb.php file

Re: Php accelerator error404 due to wrong url? #88815 04/03/2005 6:53 PM
Joined: Apr 2004
Posts: 141
oracleweb Offline
member
Offline
member
Joined: Apr 2004
Posts: 141
you have a ultimatebb.php file in your noncgi directory?

Re: Php accelerator error404 due to wrong url? #88816 04/03/2005 7:05 PM
Joined: Jan 2004
Posts: 43
noox Offline OP
newbie
OP Offline
newbie
Joined: Jan 2004
Posts: 43
no and I dont have an ultimatebb.cgi there either. there are no cgi or php is that folder (the nonCGI)

Re: Php accelerator error404 due to wrong url? #88817 04/03/2005 11:02 PM
Joined: Apr 2004
Posts: 141
oracleweb Offline
member
Offline
member
Joined: Apr 2004
Posts: 141
ultimatebb.php is supposed to be in the noncgi directory. So the reason you get the file not found error is... the file isn't there.

Upload ultimatebb.php to the noncgi directory and all should be well

Re: Php accelerator error404 due to wrong url? #88818 04/04/2005 10:28 AM
Joined: Jul 2006
Posts: 2,143
David Dreezer Offline
Pooh-Bah
Offline
Pooh-Bah
Joined: Jul 2006
Posts: 2,143
If ultimatebb.php is present in your NonCGI directory (the board would not let you keep the Accelerator on without it), and you're still getting 404s, then your server is not properly configured to allow the PATH_INFO variable to be used with PHP scripts.

You must either have your web hosting provider look into the issue (which will require a server configuration change, for the better), enable Compatability Mode spider-friendly URLs (preferred solution), or disable the Accelerator (don't do that <img src="https://www.ubbcentral.com/boards/images/graemlins/wink.gif" alt="" /> ).


This thread for sale. Click here! [Linked Image from navaho.infopop.cc]
Re: Php accelerator error404 due to wrong url? #88819 04/04/2005 11:18 AM
Joined: Jan 2004
Posts: 43
noox Offline OP
newbie
OP Offline
newbie
Joined: Jan 2004
Posts: 43
Thanks again. Kinda works now since I moved the file over to the NonCGI folder. All links to posts were taking me back to the main forum listing (not displaying the post) so I found a post on here that mentioned "remove spirder friendly option" and that solved it. So I suppose php accelerator is preferred over spider friendly. Seems to work now


Forum Search
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Recent Topics
Mobile app?
by Baldeagle - 12/06/2019 9:32 PM
How do you change Text Line spacing?
by jorb - 11/23/2019 12:14 AM
What happened to FAQ or Forum Help
by Ruben - 11/20/2019 11:58 AM
Search feature encountering an Error message
by jorb - 11/20/2019 12:06 AM
UBB Dev
by JAISP - 11/03/2019 11:01 AM
Who's Online Now
2 registered members (isaac, JAISP), 65 guests, and 401 spiders.
Key: Admin, Global Mod, Mod
Random Gallery Image
Latest Gallery Images
Artistic structures
Artistic structures
by isaac, August 29
Stones
Stones
by isaac, August 19
Amusing Terain Scenics
Amusing Terain Scenics
by isaac, August 19
Sky places
Sky places
by isaac, August 19
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191023)