Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
2 registered members (mmkk, Gizmo), 30 guests, and 355 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
whk
whk
Portsmouth, RI
Posts: 86
Joined: January 2009
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 18
M4TT 12
FREAK 11
Ruben 8
isaac 4
mmkk 4
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Error creating a new post after upgrade[Non-Bug] #251389
12/15/12 12:07 PM
12/15/12 12:07 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
Went to try a new post on my testing site and got the error below when I clicked submit...

UBB Message We encountered a problem. The reason reported was

Script: /home/fgmcccom/public_html/testing/ubbthreads/libs/ubbthreads.inc.php
Line#: 970
SQL Error: Table 'fgmcccom_pptest.ubbt_SEARCH_AGENTS' doesn't exist
SQL Error #: 1146
Query: SELECT AGENTS FROM ubbt_SEARCH_AGENTS

Please click back to return to the previous page.

Last edited by Ruben; 12/18/12 04:38 PM.

Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Error creating a new post after upgrade [Re: Iann128] #251390
12/15/12 12:21 PM
12/15/12 12:21 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
Ok I fixed the new post issue by clearing the cache, but when I do that I get this message. I think it is something to do with one of my post islands, hope it does not happen on real site frown
Code
Script: /home/fgmcccom/public_html/testing/ubbthreads/cache_builders/post_island.php
Line#: 84
SQL Error: Table 'fgmcccom_pptest.ubbt_TOPICS' doesn't exist
SQL Error #: 1146
Query: select t1.TOPIC_ID,t1.POST_ID,t1.TOPIC_SUBJECT,t1.TOPIC_CREATED_TIME,t1.TOPIC_LAST_REPLY_TIME,t1.TOPIC_LAST_POST_ID,t1.TOPIC_LAST_POSTER_ID,t1.TOPIC_LAST_POSTER_NAME,t1.TOPIC_POSTER_NAME from ubbt_TOPICS as t1, ubbt_FORUMS as t2 where t2.FORUM_IS_GALLERY='0' and t1.FORUM_ID = t2.FORUM_ID and t1.TOPIC_IS_APPROVED = '1' and t1.TOPIC_LAST_REPLY_TIME > 1353018030 and t1.TOPIC_STATUS <> 'M' and t1.FORUM_ID in ('1','2') ORDER BY t1.TOPIC_LAST_REPLY_TIME desc limit 5 

Last edited by Iann128; 12/15/12 12:43 PM. Reason: Put inside code so it did not make the post so wide

Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Re: Error creating a new post after upgrade [Re: Iann128] #251391
12/15/12 12:45 PM
12/15/12 12:45 PM
Joined: Apr 2007
Posts: 4,313
SoCal, USA
SD Offline
Carpal Tunnel
SD  Offline
Carpal Tunnel
Joined: Apr 2007
Posts: 4,313
SoCal, USA
the error is clear... do you have a database locally called fgmcccom_pptest ?


Re: Error creating a new post after upgrade [Re: Iann128] #251392
12/15/12 12:55 PM
12/15/12 12:55 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
Yep but I can't find ubbt_TOPICS in it or in the live one...


Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Re: Error creating a new post after upgrade [Re: Iann128] #251397
12/15/12 03:47 PM
12/15/12 03:47 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Iann, you do remember that the ubbt_ is a table prefix?
You may have elected something else on the install when creating the tables the first time.

You can double check the prefix setting at:
Control Panel ┬╗ DB, Paths & URLs


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Error creating a new post after upgrade [Re: Iann128] #251403
12/15/12 04:33 PM
12/15/12 04:33 PM
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Gizmo Online tapedshut
UBB.threads Developer
Gizmo  Online Tapedshut
UBB.threads Developer
Joined: Jun 2006
Posts: 16,788
Portland, OR; USA
Well, according to his config he's using ubbt_ as his prefix in the db fgmcccom_pptest


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: Error creating a new post after upgrade [Re: Iann128] #251405
12/15/12 04:45 PM
12/15/12 04:45 PM
Joined: Dec 2003
Posts: 5,827
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,827
Lutz,FL
Then why is it stated:
Originally Posted by Iann128
Yep but I can't find ubbt_TOPICS in it or in the live one...


Topics table should exist in the live board.

Looks to be the database was recycled for testing.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: Error creating a new post after upgrade [Re: Iann128] #251417
12/15/12 08:19 PM
12/15/12 08:19 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
fgmcccom_pptest is the db for my PhotoPost gallery, fgmcccom_ubbtest is the UBB database. There is a island that pulls random images from the gallery which uses the UBB user database.. There is a disconnect somewhere I think...


Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Re: Error creating a new post after upgrade [Re: Iann128] #251418
12/15/12 08:23 PM
12/15/12 08:23 PM
Joined: Apr 2007
Posts: 4,313
SoCal, USA
SD Offline
Carpal Tunnel
SD  Offline
Carpal Tunnel
Joined: Apr 2007
Posts: 4,313
SoCal, USA
yup... it's not the stock code wink

Re: Error creating a new post after upgrade [Re: Iann128] #251419
12/15/12 08:36 PM
12/15/12 08:36 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
It was working before I upgraded frown


Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Re: Error creating a new post after upgrade [Re: Iann128] #251420
12/15/12 08:39 PM
12/15/12 08:39 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
I am getting that error any time I try to save any changes in the CP...


Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Re: Error creating a new post after upgrade [Re: Iann128] #251421
12/15/12 08:44 PM
12/15/12 08:44 PM
Joined: Apr 2007
Posts: 4,313
SoCal, USA
SD Offline
Carpal Tunnel
SD  Offline
Carpal Tunnel
Joined: Apr 2007
Posts: 4,313
SoCal, USA
yes, because the post island cache_builders is trying to rebuild each time...

i assume you have a special version of it for pp

put in the standard one from the installer...

then you can hack it back later, if that is what you want that island to do smile

Re: Error creating a new post after upgrade [Re: Iann128] #251422
12/15/12 08:59 PM
12/15/12 08:59 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
Did not change any of the cache_builders from the stock code...


Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."
Re: Error creating a new post after upgrade [Re: Iann128] #251423
12/15/12 09:30 PM
12/15/12 09:30 PM
Joined: Apr 2007
Posts: 4,313
SoCal, USA
SD Offline
Carpal Tunnel
SD  Offline
Carpal Tunnel
Joined: Apr 2007
Posts: 4,313
SoCal, USA
well.. some code, somewhere is changing which database to query from..

i know that is not in the stock code...

your DB settings / paths show ubb as the main db

but the post island decides to go with pp to query from..

look @ photopost mod code smile

Re: Error creating a new post after upgrade [Re: Iann128] #251424
12/15/12 09:35 PM
12/15/12 09:35 PM
Joined: Mar 2008
Posts: 268
Austin, AR
Iann128 Offline OP

enthusiast
Iann128  Offline OP

enthusiast
Joined: Mar 2008
Posts: 268
Austin, AR
I think I may have found it... I just copied over the cache_buliders dir from a fresh copy and overwrote the custom dir by accident, then tried to recreate the custom island from my "live" site and change one line to point to the testing gallery and it broke again.. My PP install may be hosed up on the testing site because of if I have the island pull from the live gallery it works fine... GRRRRR


Ian
http://www.firstgenmc.com/ubbthreads

"Experience is a hard teacher because she gives the test first, the lesson afterwords."

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar [Not a Bug]
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,544
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)