Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
3 registered members (M4TT, isaac, Gizmo), 45 guests, and 384 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Mark S
Mark S
Liverpool : England : UK
Posts: 4,704
Joined: July 2006
Show All Member Profiles 
Top Posters(30 Days)
Gizmo 13
M4TT 11
Ruben 8
mmkk 4
FREAK 3
isaac 3
Latest Photos
Chinese Buddhist temple.
My buddha beads.
Rendered Walls
Multi-Screen wallpaper
Stockholm Metro
Previous Thread
Next Thread
Print Thread
Mobile responsive issues #260641
11/05/17 09:52 PM
11/05/17 09:52 PM
Joined: Oct 2017
Posts: 3
F
F27Corsair Offline OP
stranger
F27Corsair  Offline OP
stranger
F
Joined: Oct 2017
Posts: 3
Hey Guys,

First time poster here. I recently inherited the ubb specialtactics.com/forums site and as a beginner at anything website developing, I am struggling. I successfully updated the site to 7.6.0 hoping to solve my mobile responsiveness problems. It changed the look of this site somewhat. The forums are still getting chopped off for some reason. When viewing the main forums or a topic, as a mobile user i still need to scroll side to side or zoom out to view the entire wording.
I have attempted different themes and a few other items to try and solve the problem but I'm at a loss.

I wouldn't mind having the forums have a layout very similar to this board's but I feel I'm a long way from figuring that out at this point. I cant even get the mobile layout correct.

Any tips on what is causing my mobile issue?
What theme is this board utilizing?

Thanks for the help.

Travis
specialtactics.com/forums

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: Mobile responsive issues [Re: F27Corsair] #260642
11/05/17 10:17 PM
11/05/17 10:17 PM
Joined: Apr 2004
Posts: 1,004
California
isaac Online splat
UBB.threads Developer
isaac  Online Splat
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
Your 728x90 Google ads are static width, and are pushing the content of your pages to at least 728px wide.

Update your Google Ad code to be responsive on all your pages, and your forums will display correctly.

Re: Mobile responsive issues [Re: F27Corsair] #260643
11/06/17 06:51 AM
11/06/17 06:51 AM
Joined: Oct 2017
Posts: 3
F
F27Corsair Offline OP
stranger
F27Corsair  Offline OP
stranger
F
Joined: Oct 2017
Posts: 3
Thanks for that, that helped quite a bit. I removed all of the ads and am attempting to start over from square one. But I'm still having a small issue w/ responsiveness when viewing posts. The posts still appear to not be sized right- but they are close. The posts appear to cut off about a word or so from each line (see attached).

Do i need to modify some of my settings in the control panel to fix this? Thanks for the help.

Attached Files Screenshot_20171106-064929.png
Re: Mobile responsive issues [Re: F27Corsair] #260644
11/06/17 11:07 AM
11/06/17 11:07 AM
Joined: Apr 2004
Posts: 1,004
California
isaac Online splat
UBB.threads Developer
isaac  Online Splat
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
you're running in to the facebook bug. more information on that is discussed as "the second thing" in this post:
https://www.ubbcentral.com/forums/ubbthreads.php/topics/260384/re-mobile-view#Post260384

Quote
The second one is a bug in 760 that has been fixed in 761. its related to the Facebook images on the footer of each post.

Basically, that element under each of your post threads which says, "Tweet". There is a Facebook element right next to it that has a 450px wide iframe, which is preventing your pages from being mobile. This was a very old style of presenting Facebook's like system. They have since updated it to use javascript. There should be a Facebook "Like" phrase right next to Twitter's "Tweet" text also, but I am not seeing it displayed on your website on any of my browsers. So Facebook may have stopped using that old format all together (?). Though the 450px wide iFrame still exists in 7.5.x and 7.6.0's template.

backstory: while working on UBB.threads 7.6.0, I was unaware that there was even Facebook or Twitter integration at all. So it was never noticed until someone mentioned it about two months after the 7.6.0 release. This has been fixed for UBB.threads 7.6.1 by updating both Facebook and Twitter share buttons to follow their currently recommended integration code. In addition, a Facebook "Share" button was also added to 761.
The 760 bug was documented and fixed for 7.6.1 @ http://www.ubbcentral.com/forums/ubbthreads.php/topics/260038#Post260038

The fix for this Facebook iFrame is to just disable that integration in your Control Panel until you get 7.6.1+. This will remove the display problem. This does not affect Twitter at all. You can continue using the 760 Twitter integration without issue.

1) go to Control Panel > Display Settings
2) And then open the "Topic & Post Page Settings" section.
3) Remove the check-mark from the "Show Facebook "Like" Button" box.

Last edited by isaac; 11/06/17 11:11 AM. Reason: added relevant quote
Re: Mobile responsive issues [Re: F27Corsair] #260686
11/22/17 09:42 AM
11/22/17 09:42 AM
Joined: Oct 2017
Posts: 3
F
F27Corsair Offline OP
stranger
F27Corsair  Offline OP
stranger
F
Joined: Oct 2017
Posts: 3
Thanks for all the help this far. All suggestions have helped tremendously but I am still seeing some issues that I can't seem to track down, especially when viewed from a tablet.
In the attached, you can see the site gets cut off from the right side. When zoomed out, a white bar appears on the side that aligns with where the site gets cut off. Any ideas on this?
Once again, thanks for all the help.

Travis

Attached Files Screenshot_20171122-093448.pngScreenshot_20171122-093443.png
Re: Mobile responsive issues [Re: F27Corsair] #260687
11/22/17 12:55 PM
11/22/17 12:55 PM
Joined: Mar 2015
Posts: 51
Canada, SK
M4TT Online cat
journeyman
M4TT  Online Cat
journeyman
Joined: Mar 2015
Posts: 51
Canada, SK
I think that happens to my site as well, because when it's viewed in landscape on mobile (Galaxy S8+), the header graphic gets cut short and anything straight down has a blank background. However, it's fine in portrait and on PC. So I imagine that's what happens when it's viewed on a tablet (about 5% of my viewers). UBB.threads version 7.6.0.

Attached Files landscape.jpg
Re: Mobile responsive issues [Re: F27Corsair] #260688
11/22/17 01:02 PM
11/22/17 01:02 PM
Joined: Apr 2004
Posts: 1,004
California
isaac Online splat
UBB.threads Developer
isaac  Online Splat
UBB.threads Developer
Joined: Apr 2004
Posts: 1,004
California
Thanks guys!

UBB.threads version 7.6.1 fixes the "Last Post" column to replace that forced "nw" (no wrap) with an auto adjusting ellipses. That update enables the column widths to adjust on tablets to not push content off the side of the screen.

https://www.ubbcentral.com/forums/ubbthreads.php/topics/259887#Post259887


Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Users Unable to Upload Avatar [Not a Bug]
by M4TT. 12/13/17 08:51 AM
Shout Box Sound Effect
by M4TT. 11/29/17 08:28 PM
Ad island
by TGCsanderson. 11/25/17 06:41 PM
Taking to long to connect to DB
by AstroCat. 11/24/17 12:34 PM
Forum Statistics
Forums36
Topics35,015
Posts190,544
Members12,045
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171106)