Originally Posted by DennyP
Can I go directly to 7.6.0 from 7.5.8 or do I need to install 7.5.9 first?


Originally Posted by id242
The upgrade path from UBB.threads 7.5.x versions, has always been to move to the most recent version of UBB.threads as they become available. Such as 7.5.x => 7.6.x.

There is no need to do an incremental update from 7.5.8 to 7.5.9 to 7.5.9.1 to 7.6.0. You should update directly from your current UBB.threads 7 version, to the most recent version of UBB.threads.