Site Links
Home
Features
Documentation
Pricing & Order
Members Area
Support Options
UBBDev.com
UBBWiki.com
Who's Online Now
0 registered members (), 38 guests, and 255 spiders.
Key: Admin, Global Mod, Mod
Member Spotlight
Posts: 781
Joined: June 2006
Show All Member Profiles 
Top Posters(30 Days)
isaac 18
Gizmo 13
Ruben 10
Morgan 4
BB 2
Abbott 2
Latest Photos
Testing to drag photos
Comfortable Cats
Test
BSA photos
Chinese Buddhist temple.
Previous Thread
Next Thread
Print Thread
New Install Problem #261116
02/09/18 11:05 PM
02/09/18 11:05 PM
Joined: Jun 2016
Posts: 4
Broadwing Offline OP
stranger
Broadwing  Offline OP
stranger
Joined: Jun 2016
Posts: 4
I have been able to install the forums software, but my forums will still not work. I created a new mySql database. Using install.php won't go beyond Step 3 and gives this message:

Step 3
Here we are checking your database connectivity and permissions. If any of these checks fail you will need to correct the errors in order to proceed.

Connecting to server

Going to my forums produces this message:

Warning: include(/libs/ver.inc.php): failed to open stream: No such file or directory in /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php on line 9

Warning: include(): Failed opening '/libs/ver.inc.php' for inclusion (include_path='.:/usr/share/php') in /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php on line 9

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /users/dark-poet.info/htdocs/forums/libs/mysql.inc.php:21 Stack trace: #0 /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php(92): sql->connect() #1 /users/dark-poet.info/htdocs/forums/ubbthreads.php(42): require_once('/users/dark-poe...') #2 /users/dark-poet.info/htdocs/forums/index.php(19): include('/users/dark-poe...') #3 {main} thrown in /users/dark-poet.info/htdocs/forums/libs/mysql.inc.php on line 21

All files are chmoded to the values given on the UBB installation page. I would appreciate any help/advice you will provide. Thank you much for your help and time.

Express Hosting
Express Hosting "We are the official hosting company of UBB.threads. Ask us about our free migration services to migrate your UBB.threads installation."
Re: New Install Problem [Re: Broadwing] #261117
02/10/18 01:42 AM
02/10/18 01:42 AM
Joined: Jun 2006
Posts: 16,931
Portland, OR; USA
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,931
Portland, OR; USA
The error message on the forums is because the configuration file hasn't been written to by the installer; it's looking for a variable (the path to the folder) which doesn't exist, so it's trying to load it anyway.

As it looks like the installer is stalling at the database steps, please ensure that your username, password, and database information are all correct; UBB.threads will not create a database for you, it will simply insert the forum information into the database to get you started.

As for the installer, could you try re-uploading the UBB.threads archive that you downloaded from UBBCentral; I just ran an upgrade with the files last night, and Isaac ran a couple of fresh installs prior to release, so it should work. If it cannot continue again, please check your hosting with the System Requirements Test.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: New Install Problem [Re: Broadwing] #261120
02/10/18 11:38 AM
02/10/18 11:38 AM
Joined: Dec 2003
Posts: 5,898
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,898
Lutz,FL
Remember that the forum will not run at all until you complete the install.php script.

You did create a mysql database and a database user with global permissions before you started the install.php script
Is this correct?
You will need that info as well as the server host usually locahost to enter into the install script when prompted

Another item is say you name the database 123 with a user name of me.
Some hosts attach a prefix to them such as it would become say
database domain_123
user domain_me

Also the install script is usually good figuring out your paths but not always 100% so don't just skip over them to the next step. Review them and correct them as needed.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: New Install Problem [Re: Gizmo] #261125
02/11/18 12:39 AM
02/11/18 12:39 AM
Joined: Jun 2016
Posts: 4
Broadwing Offline OP
stranger
Broadwing  Offline OP
stranger
Joined: Jun 2016
Posts: 4
Alright then. The system requirements test passed. I started the install script and reached step 3 before receiving this message:


"Step 3
Here we are checking your database connectivity and permissions. If any of these checks fail you will need to correct the errors in order to proceed.

Connecting to server FAILED
Connecting to database FAILED

One or more of the above checks failed. Click the button below to return to the previous screen to verify your settings."


I have verified my server name, mysql database login and password. I have no idea how to determine the table prefix. I also assume that the database does not have global permissions. How do I set that, and how do I find the path to my database?

Last edited by Broadwing; 02/11/18 01:16 AM. Reason: More Information Found
Re: New Install Problem [Re: Broadwing] #261133
02/11/18 05:51 PM
02/11/18 05:51 PM
Joined: Jun 2006
Posts: 16,931
Portland, OR; USA
Gizmo Offline
UBB.threads Developer
Gizmo  Offline
UBB.threads Developer
Joined: Jun 2006
Posts: 16,931
Portland, OR; USA
It looks like the database connection is being refused; please validate the correct MySQL database user, host, and password are correct. Some control panels have their user accounts as [site username]_[created database user] (ie siteuser_username), please validate that wherever the username is displayed that it is displayed EXACTLY as you're entering. If you are copying and pasting you'll want to make sure that you're not copying any " " blank characters (which tends to happen when copying from an email or a web page). You'll also want to make sure that the created MySQL user has been granted sufficient access to the new database that you've created.

Some control panels do not assign the same password to the MySQL database user as the FTP password; try going into your web hosts control panel and change the database password to what you think it already is.

The table prefix is simply what you'd like the table names prefixed with; if you have multiple installs in the same database you would set the prefix on install B as a different one from install A so that the databases can run along side eachother. The default is fine, and there is no validation necessary for this field.

I have just validated that the latest copy of the v7.6.1 install archive from the member area is capable of running a new install without any problems.


I am a Web Development Contractor, I do not work for UBBCentral. I have provided free User to User Support since the beginning of these support forums.
Forums: A Gardeners Forum Scouters World
UBB.threads: UBBWiki, UBB Styles, UBB.Sitemaps
Longtime Supporter & Resident Post-A-Holic
VNC Web Services: Code Modifications, Upgrades, Styling, Coding Services, Disaster Recovery, and more!
Re: New Install Problem [Re: Broadwing] #261134
02/11/18 07:38 PM
02/11/18 07:38 PM
Joined: Dec 2003
Posts: 5,898
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,898
Lutz,FL
the default database table prefix is ubbt_
Unless you changed it during the install.
You can look in phpmyadmin in your site control panel as well as see the full database name and users if your versions allow to see everything.
Otherwise go back to the main view of your site controlpanel and look for something like mysql. They are all a little different depending on what control panel your host provided but it would be where you created the database and user to begin with.


Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: New Install Problem [Re: Broadwing] #261135
02/12/18 12:25 AM
02/12/18 12:25 AM
Joined: Jun 2016
Posts: 4
Broadwing Offline OP
stranger
Broadwing  Offline OP
stranger
Joined: Jun 2016
Posts: 4
phpMyAdmin is not working. I've notified my host to get that fixed.

1) I created the database.
2) Set login and password exactly.
3) Ran the install script again.
4) Set permissions on the database to 777.
5) Received the message that connecting to server and database failed.

Trying to access my forums gives this message now:

"Warning: include(/libs/ver.inc.php): failed to open stream: No such file or directory in /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php on line 9

Warning: include(/libs/ver.inc.php): failed to open stream: No such file or directory in /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php on line 9

Warning: include(): Failed opening '/libs/ver.inc.php' for inclusion (include_path='.:/usr/share/php') in /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php on line 9

Database error only visible to forum administrators"


Line 9 of that script reads: include("{$config['FULL_PATH']}/libs/ver.inc.php");

libs is there as is the script called out.

Re: New Install Problem [Re: Broadwing] #261136
02/12/18 08:07 PM
02/12/18 08:07 PM
Joined: Dec 2003
Posts: 5,898
Lutz,FL
Ruben Offline

Ruben  Offline


Joined: Dec 2003
Posts: 5,898
Lutz,FL
Read My PM.
You don't even have a built database at this point, so it is a waste of time to try to keep running the forum till you
complete the install script.

If you get the phpmyadimn to work you will see there is nothing there.

The first thing is to fix the server connection issue to complete the install script or you are dead in the water.
The $config['FULL_PATH is not even set at this point in the config file again till you complete the install script.

Nothing will work at all till the install script completes.
It builds the database it creates the paths and settings to run the forum
So your database and config file are blank paths are blank at this point in time
Till you resolve your connection issue and complete the install script.
I offered to help in the pm ,but i would need access to your site control panel.

Last edited by Ruben; 02/12/18 08:18 PM.

Blue Man Group


There is no such thing as stupid questions. Just stupid answers
Re: New Install Problem [Re: Broadwing] #261149
02/16/18 11:58 PM
02/16/18 11:58 PM
Joined: Jun 2016
Posts: 4
Broadwing Offline OP
stranger
Broadwing  Offline OP
stranger
Joined: Jun 2016
Posts: 4
Update: I purchased a domain through GoDaddy to try and do an install there. They confirmed they use PHP 5+ and are mysql_connect compatible. I had tech support there run a mySql diagnostic on the database I created for the forums. The test script was able to connect to the database using the database name, login, and pass. I then ran the install.php for UBBthreads. Step 1 passed. Step 2, I entered the correct connection information that had been verified by the test script. Step 3 gave me the message "Connecting To Server" and remained that way for nearly 40 minutes before I called it quits.

GoDaddy supports both mySql_connect and mySqli, other UBB forums run on their servers. The tech believes there is an error in the install script that prevents it from connecting to the database. He directed me to try to learn the steps needed to convert and allow mysql_connect to be used on machines using mysqli. Apparently, mysql is being deprecated. I have found several methods, but all involve the working scripts and not an install script.

So, I've tried installing at two vastly different hosting companies, one Unix and one Linux, and had the same result. I would appreciate someone looking into this now.

Re: New Install Problem [Re: Broadwing] #261150
02/17/18 04:11 AM
02/17/18 04:11 AM
Joined: Apr 2004
Posts: 1,171
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,171
California
From your PM to me earlier today.
Originally Posted by Broadwing
I'm sorry to bother you with this, but I do need someone with expertise, patience, and a decent "bedside manner." If you would look over the history of my problem, at this thread mySql Problem then I would be grateful, sir.

Thank you for your time.


Its usually good practice to post support answers in the public forum, so others can also benifit from them.

Originally Posted by Broadwing
Step 1 passed. Step 2, I entered the correct connection information that had been verified by the test script. Step 3 gave me the message "Connecting To Server"


As Ruben and Gizmo has posted earlier, this sounds exactly like a DATABASE CONNECTION ISSUE on your web server. You'll need to get the database connection information directly from your server/webhost.

You mentioned that you downloaded the Test Script and used information from that script for connecting to the DB. If you are coming from an upgrade after moving to a new server, you are probably pulling in old server connection information from config files which are irrelevant to your new server.

Again, those details should be retrieved from your current server/webhost. Not from an old install.

My suggestions:

For a new install:
1) Download a fresh copy of the ubbthreads-7-6-1 archive from Member area.
2) Follow the directions listed here: https://www.ubbcentral.com/doc_install.php

For a forum upgrade:
1) Download a fresh copy of the ubbthreads-7-6-1 archive from Member area.
2) Follow the directions listed here: https://www.ubbcentral.com/doc_upgrade7.php

Attached Files 2.database_info.png3.database_check.pnge3.database_check_error_check.png4.paths_urls.png

isaac @ id242.com // forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.6.2 Changelog
Re: New Install Problem [Re: Broadwing] #261151
02/17/18 05:03 AM
02/17/18 05:03 AM
Joined: Apr 2004
Posts: 1,171
California
isaac Offline
UBB.threads Developer
isaac  Offline
UBB.threads Developer
Joined: Apr 2004
Posts: 1,171
California
Also, reading the ERROR you've shared in your initial post,

Quote
Warning: include(): Failed opening '/libs/ver.inc.php' for inclusion (include_path='.:/usr/share/php') in /users/dark-poet.info/htdocs/forums/libs/ubbthreads.inc.php on line 9


it looks like you have an invalid path there:
".:/usr/share/php"

change to:
"/usr/share/php"

...or whatever the correct absolute path on your server should be.

And this is the reason why your initial install would fail.


isaac @ id242.com // forum @ CelicaHobby.com
a current developer of UBB.threads php forum software // 7.6.2 Changelog

Shout Box
Today's Birthdays
No Birthdays
Recent Topics
Control Panel / Transactions Username
by Morgan. 06/20/18 05:38 AM
Custom Insert won't save
by Baldeagle. 06/18/18 07:44 PM
New Image capabilities ver 7.6.1
by Abbott. 06/14/18 02:28 PM
Thread deleted?
by Lisanne. 06/05/18 11:13 AM
random 500 server errors on post
by Bad Frog. 05/31/18 09:34 AM
Forum Statistics
Forums36
Topics35,122
Posts191,326
Members12,085
Most Online978
Jun 24th, 2007
Random Image
Powered by UBB.threads™ PHP Forum Software 7.6.2
(Preview build 20180524)